Solved

Procurve networking management

Posted on 2009-03-31
2
740 Views
Last Modified: 2012-05-06
We have three procurves. (2)5406zl and a 2606 24 port 100 mbit POE.

Currently we have a 4-port trunk between the two 5406 chassis and a 2 port trunk to the 2606

My problem is that I haven't figured out a way to access the other switch management interfaces without plugging into the default_vlan (one port) on both the non-root switches.  So I can access the root switch by using the default gateway IP of :10.0.3.254, butt he other 2 switches I have  to physically plug into with my laptop to access.  This might seem good for security, but, not so good for administration.  Here's a simple ascii diagram:

            5406zl(b)
                || ||
__core between flores____
                || ||
            5406zl(a)  == 2606

switch a is the only switch I can administer over the network, the other two have to be plugged into.  Here are the two 5406zl config files
Switch b config:
 

; J8697A Configuration Editor; Created on release #K.12.57
 

hostname "ProCurve Switch 5406zl" 

module 1 type J8702A 

module 2 type J8702A 

module 3 type J8702A 

module 4 type J8702A 

module 5 type J8702A 

trunk A1-A4 Trk1 LACP 

ip routing 

snmp-server community "public" Unrestricted 

vlan 1 

   name "DEFAULT_VLAN" 

   untagged A5,Trk1 

   ip address 10.0.3.252 255.255.255.0 

   no untagged A6-A24,B1-B24,C1-C24,D1-D24,E1-E24 

   exit 

vlan 3 

   name "WRK_VLAN" 

   untagged A6-A24,B1-B24,C1-C14 

   tagged Trk1 

   no ip address 

   exit 

vlan 4 

   name "VOIP_VLAN" 

   untagged C15-C24,D1-D24,E1-E24 

   tagged Trk1 

   no ip address 

   exit 

spanning-tree Trk1 priority 6
 

Switch a config:
 

Running configuration:
 

; J8697A Configuration Editor; Created on release #K.12.57
 

hostname "ProCurve Switch 5406zl" 

web-management ssl 

module 1 type J8702A 

module 2 type J8702A 

module 3 type J8702A 

module 4 type J8702A 

module 5 type J8702A 

module 6 type J8702A 

trunk B1-B4 Trk1 LACP 

trunk B5-B6 Trk2 LACP 

ip routing 

ip directed-broadcast 

ip zero-broadcast 

ip udp-bcast-forward 

snmp-server community "public" Unrestricted 

vlan 1 

   name "DEFAULT_VLAN" 

   ip address 10.0.1.199 255.255.255.0 

   no untagged A1-A24,B7-B24,C1-C24,D1-D24,E1-E24,F1-F24,Trk1-Trk2 

   exit 

vlan 2 

   name "SERVER_VLAN" 

   untagged A1-A20 

   ip helper-address 10.0.2.1 

   ip address 10.0.2.254 255.255.255.0 

   tagged Trk1-Trk2 

   exit 

vlan 3 

   name "WRK_VLAN" 

   untagged D13-D24,E1-E24,F1-F24 

   ip helper-address 10.0.2.1 

   ip address 10.0.3.254 255.255.255.0 

   tagged Trk1-Trk2 

   exit 

vlan 4 

   name "PHONE_VLAN" 

   untagged B7-B24,C1-C24,D1-D12 

   ip address 10.0.4.254 255.255.255.0 

   tagged Trk1-Trk2 

   exit 

vlan 5 

   name "WIFI_VLAN" 

   untagged A21-A24 

   ip helper-address 10.0.2.1 

   ip address 10.0.5.254 255.255.255.0 

   tagged Trk1-Trk2 

   exit 

vlan 6 

   name "EDGE_VLAN" 

   ip helper-address 10.0.2.1 

   ip address 10.0.6.254 255.255.255.0 

   tagged Trk1-Trk2 

   exit 

vlan 7 

   name "INTERNE_VLAN" 

   ip helper-address 10.0.2.1 

   ip address 10.0.7.254 255.255.255.0 

   tagged Trk1-Trk2 

   exit 

qos type-of-service diff-services 

ip route 0.0.0.0 0.0.0.0 10.0.2.1

router rip

   distance 25

   exit

spanning-tree

spanning-tree Trk1 priority 4

spanning-tree Trk2 priority 4

spanning-tree config-name "mstp-vrrp"

spanning-tree config-revision 1

spanning-tree instance 1 vlan 1-8

spanning-tree priority 1 force-version RSTP-operation

Open in new window

0
Comment
Question by:mrtheplague
2 Comments
 
LVL 17

Accepted Solution

by:
jburgaard earned 500 total points
ID: 24033593
You run the a-sw as a routing sw. (layer3-sw) , meaning all vlans with an IP on this switch will participate in routing BETWEEN the vlan's. Fine.

L2 sw.'s:
The b-Sw only has (and prob. only should have) an IP in vlan 1.
On b-sw. change
from  'IP Routing'   to:
IP Default-gateway 10.0.1.199

To communicate WITHIN vlan 1 all sw.'s should have IP's in same network,
10.0.1.0 255.255.255.0:
such as
ip address 10.0.1.252   255.255.255.0
(not 10.0.3.252   255.255.255.0)

HTH
0
 

Author Closing Comment

by:mrtheplague
ID: 31564936
All I had to do was add a static management ip to the b switch for vlans 2 and 3.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Destination host unreachable 12 67
Transfering files via a single Cat5 between two DOMAIN computers. 14 76
DHCP Server 14 62
Need help with VLAN issue 6 35
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
For many of us, the  holiday season kindles the natural urge to give back to our friends, family members and communities. While it's easy for friends to notice the impact of such deeds, understanding the contributions of businesses and enterprises i…
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now