SMTP response "354 Ready, steady, go"

Posted on 2009-03-31
Medium Priority
Last Modified: 2012-06-21
I have Exchange 2007 SP1 Update 7 running on a Windows 2003 SP2 single box.  It is behind ISA 2006 firewall.

Twice now different people have said that they are getting a 5.5.0 NDR when trying to send to us.  It appears to be intermitant. The diagnositic code is:
Diagnostic-Code: smtp; 354 Start mail input; end with <CRLF>.<CRLF>

I have tried looking up the error codes and they haven't told me anything specific.  I have telneted to test it out and my email gets through every time.  However I do get a weird response after typing DATA -

220 <myEmailServer> Microsoft ESMTP MAIL Service ready at Tue, 31 Mar 2009 17:09:42 +1300
EHLO xmas.com
250-<myEmailServer> Hello [XX.XX.XX.XX]
250-SIZE 10485760
MAIL FROM:santa@xmas.com
250 2.1.0 Sender OK
RCPT TO:tom@<mycomany>.co.nz
250 2.1.5 Recipient OK
354 Ready, steady, go

Why is my Exchange server responding with Ready, Steady, Go?  This can't be normal?!  Could this be why some people are getting the 5.5.0 354 error?

Question by:TomMonkey
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
LVL 65

Expert Comment

ID: 24039193
That is not normal.
Something or someone has fiddled with the server. I normally see this when "funny" linux admins customise their SMTP server. What else is on the server?

Did you telnet to Exchange or the ISA server?

LVL 17

Expert Comment

ID: 24039621
This is not an error from your exchange server. Its some other 3rd party application responding for sure?
where did u do this telnet to?


Author Comment

ID: 24043386
Hi guys,

I telneted to the external IP address of our ISA server.  I tried it internally and from my home machine.  I also elneting directly to the Exchange server and got the same thing each time.

ISA has a publishing rule on that just directs all SMTP inbound traffic straight to the IP address of the exchange server.

I know how to change the 220 banner but not the 354 response so I don't think it was me mucking around and forgetting about it!

All our emails seem to be flowing in and out ok.  Just occasionally two different people have been complaining about these NDRs -

Reporting-MTA: dns; <server>.<theircompany>.local
X-Postfix-Queue-ID: 838F18CA15
X-Postfix-Sender: rfc822; <sender>@<theircompany>.co.nz
Arrival-Date: Tue, 31 Mar 2009 15:51:05 +1300 (NZDT)

Final-Recipient: rfc822; user@<mycomany>.co.nz
Original-Recipient: rfc822;user@<mycompany>.co.nz
Action: failed
Status: 5.5.0
Remote-MTA: dns; smtp.<mycompany>.co.nz
Diagnostic-Code: smtp; 354 Start mail input; end with <CRLF>.<CRLF>

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

LVL 65

Expert Comment

ID: 24043504
This is what you should see:

354 Start mail input; end with <CRLF>.<CRLF>

So I think someone has modified the SMTP response code.
No idea where it is changed though.


Author Comment

ID: 24043574
I have no idea either.

I only got suspicious about it because of the line in the NDR:

Diagnostic-Code: smtp; 354 Start mail input; end with <CRLF>.<CRLF>

So I thought maybe their server was expecting the standard response but got something else and rejected it.
LVL 65

Accepted Solution

Mestha earned 2000 total points
ID: 24053988
AV software maybe, but I cannot find anything that would allow that to be modified.

Most odd.


Author Comment

ID: 24055077
You are right Simon, it was AV!

A while back we upgraded all the AV from Trend Micro to Vipre.  It has been much better but has an email scannig agent in it for Outlook and scans any incoming SMTP traffic.  No idea why it changed the 354 response but when I made a new policy for our Exchange server and turned off the email scanning it went away.

There was nothing about this on the Vipre website.

Thanks for the help.  Not sure if this is what caused the intermitant email problem.  Will have to wait and see.

Featured Post

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
This video discusses moving either the default database or any database to a new volume.
Suggested Courses
Course of the Month10 days, 21 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question