Solved

How to configure a management vlan on a 2851 router

Posted on 2009-03-31
4
1,532 Views
Last Modified: 2012-05-06
Hello
I need to configure a management vlan on 2 2851 ISR's but have never done this on routers before.
What i've done is : Create vlan 91 on both routers (to use as management vlan)
vlan 91
name Management

Configure a subinterface as a trunk like so:
router1:
int G0/0.91
encapsulation dot1q 91
ip address 10.3.30.200 255.255.255.0
no shutdown

Then
int fa0/1/0
switchport mode access
switchport access vlan 91
description Management Vlan
Then connected PC to fa0/1/0(cross-over cable) with address ip address 10.3.30.202 255.255.255.0 and gateway ip address 10.3.30.200

router2:
int G0/0.91
encapsulation dot1q 91
ip address 10.3.30.201 255.255.255.0
no shutdown

Then (again router2)
int fa0/1/0
switchport mode access
switchport access vlan 91
description Management Vlan
Then connected PC to fa0/1/0(cross-over cable) with address ip address 10.3.30.203 255.255.255.0 and gateway ip address 10.3.30.201

Now a show ip int brief tells me that all is up/up
I can ping from router to router but am unable to ping either gateways from the pc's
In other words PC2 on router 2 cannot ping it's own gateway neither can pc1 ping it's own gateway.
Normally i would use a switch in between the router and pc, create a trunk between the 2 then an access port for the pc(pointing to it's gateway) but now since there is no switch in between and the router is suppose to perform both i'm a little lost (or maybe totally) on what to do in order to make this work.
Is there any chance someone can point me in the right direction on how to do this.?

Thanks for any and all help




0
Comment
Question by:ibanez7
  • 2
  • 2
4 Comments
 
LVL 8

Accepted Solution

by:
Sniper98G earned 500 total points
ID: 24035198
this is not quite right.

It is rather a-typical to have a management vlan span routers. This is normally something done on switches; routers are not meant to work this way. You have created a VLAN that passes over a trunk between the two routers but you have no SVI to allow host in VLAN 91 to talk to the routers. You should remove the subinterfaces from the trunk and instead create SVIs on each of the routers to connect hosts.

Router 1

no int G0/0.91

int vlan 91
ip address 10.3.30.200 255.255.255.0
no shutdown

Router 2

no int G0/0.91

int vlan 91
ip address 10.3.40.200 255.255.255.0
no shutdown

Change host to new subnet

0
 
LVL 8

Expert Comment

by:Sniper98G
ID: 24035211
Note: Because these are routers the VLANs do not need to span the trunk. There should not even be a trunk be a trunk between them. Traffic should be routedacross a point to point link.
0
 

Author Comment

by:ibanez7
ID: 24035343
Thanks very much i will try that first thing in the morning.
0
 

Author Comment

by:ibanez7
ID: 24041065
Here`s what i did
I configured vlans with ip addresses and was able to ping the pc`s but then i was unable to get across to the other router.So i connected the 2 physically together and created a switchport and it worked. Now since they will be in different cities i wouldn`t be able to do it this way so i removed the trunk and instead i re-created the subinterfaces with different subnets created an ip route pointing to it and got it working this way. I forgot to mention that this is for testing purposes only and will be removed once the routers are installed. Here are the configs to give an idea on what i did:
router1#

interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.90
 encapsulation dot1Q 90
 ip address 10.x.x.x x.x.x.x
!
interface GigabitEthernet0/0.91    *****SUBINTERFACE CREATED FOR TESTING PURPOSES*****
 description Management
 encapsulation dot1Q 91
 ip address 10.x.x.x x.x.x
!
interface GigabitEthernet0/1
 ip address 10.x.x.x x.x.x
 duplex auto
 speed auto
!
interface FastEthernet0/1/0     *****ACCESS PORT FOR THE VLAN*****
 description Test port
 switchport access vlan 91
!
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface Vlan1
 no ip address
!
interface Vlan91                     ****VLAN 91 CREATED****
 description Testing Vlan
 ip address 10.x.x.x x.x.x


HERE IS THE IP ROUTE TO MATCH
ip route 10.x.x.x x.x.x outgoing interface


PC CONFIGURATION:


  Connection-specific DNS Suffix  . :
  IP Address. . . . . . . . . . . . : 10.x.x.x
  Subnet Mask . . . . . . . . . . . : 255.x.x.x
  Default Gateway . . . . . . . . . : 10.x.x.x
I did the same thing on Router2 to match .
Thanks again for the info and the help.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Suggested Solutions

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now