Solved

Telnet and Remote Display Not Working

Posted on 2009-03-31
9
751 Views
Last Modified: 2012-05-06
I've installed Knoppix and configured the Ethernet with no issues. Ran "ssh" between my two servers and working great. I'm attempting to remote a xterm between the two servers and it failing.

Remote Issue:

What I've found on startup was the "DISPLAY" variable is set to ":0.0".

 When I ran the following on just one of the servers to ensure that I can start xterm on the local server:

1) Executed "xterm" with DISPLAY set to :0.0 and no problem
2) Ran "export DISPLAY=192.168.222.50:0.0" and then ran xterm and got the following error:
    xterm: can't open display 192.168.222.51:0.0
3) Ran "xhost +) on this local server and got the following error:
    xhost: can's open display 192.168.222.51:0.0

Telnet Issue:

When I attempt to telnet to other server or the local server I get the following error:

telnet: unable to connect to remote host: Connection refused.

I really need to understand what's going on with the remote display issue before the telnet issue. I can remote a "xterm" window from the Knoppix server to a RedHat 5.0 server, but not the other way.

Thanks,
John
0
Comment
Question by:johnj65
  • 5
  • 3
9 Comments
 
LVL 13

Expert Comment

by:WizRd-Linux
ID: 24035860
Check if the server has in /etc/ssh/sshd_config for X11Forwarding yes

If you need to change it to yes, restart the sshd server and try again.

As for the export, just use "export DISPLAY=192.168.222.51"
0
 

Author Comment

by:johnj65
ID: 24037508
ssh is working fine as I mentioned in my initial question and the /etc/ssh/sshd_config was set to "yes" for X11 Forwarding. Still need to determine why "telnet" is not working?

As for export, I've tried the "export DISPLAY=192.168.222.51" and still have the issue with unable to run xhost + or xterm on the local server unless I set the DISPLAY variable to the following:

export DISPLAY=:0.0

What should I try next??

John
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 24038687
use ssh -x to do X forwarding and do not set DISPLAY yourself

>telnet: unable to connect to remote host: Connection refused.

means that telnet is nut enabled on the remote server or there is a firewall denying you
0
 

Author Comment

by:johnj65
ID: 24039381
How can I determin if a firewall is configured for Knoppix?

Thanks,
John
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:johnj65
ID: 24040551
I was able to use ssh -x to call up a xterm from one server to the other. This is not correcting the problem that I'm having.

1) From a RHEL 5.0 server (192.168.222.51) I set the following:
    export DISPLAY 192.168.222.50:0.0
2) Execute "xterm" and I get the following error:
    xterm Xt error: Can't open display: 192.168.222.50:0.0
3) On the 192.168.222.50 server running Knoppix, I set the following:
     xhost + <Enter>
    access control disabled, clients can connect from any host
4) Execute "xterm" again from the RHEL server (192.168.222.51) and get the following error:
     xterm Xt error: Can't open display: 192.168.222.50:0.0

It seems that I've got some type of firewall or something on the Knoppix system thats stopping these remote displays? Once again ssh is working between the two servers and I'm able to remote a display "xterm window" from the Knoppix server to the RedHat server.

I can't find how this was setup on Knoppix and this problem is also stopping me from not just remoting displays but using telnet.

Thanks,
John
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 24043001
Check if iptables is the one denying you. I am not an iptables expert, but the link below might help:

http://iptables-tutorial.frozentux.net/iptables-tutorial.html
0
 

Author Comment

by:johnj65
ID: 24045815
Found no iptables being setup in Knoppix.
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 24045851
Do you have a firewall in your network between the two systems?
0
 

Accepted Solution

by:
johnj65 earned 0 total points
ID: 24099145
Sorry for not responding sooner... Out of town.

No firewall between the networks just using a simple hub for the connection of the two servers. It's something in the OS that's preventing the remote displays within Knoppix (DSL-N).

0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Network Interface Card (NIC) bonding, also known as link aggregation, NIC teaming and trunking, is an important concept to understand and implement in any environment where high availability is of concern. Using this feature, a server administrator …
Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now