Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions

Telnet and Remote Display Not Working

Posted on 2009-03-31
Last Modified: 2012-05-06
I've installed Knoppix and configured the Ethernet with no issues. Ran "ssh" between my two servers and working great. I'm attempting to remote a xterm between the two servers and it failing.

Remote Issue:

What I've found on startup was the "DISPLAY" variable is set to ":0.0".

 When I ran the following on just one of the servers to ensure that I can start xterm on the local server:

1) Executed "xterm" with DISPLAY set to :0.0 and no problem
2) Ran "export DISPLAY=" and then ran xterm and got the following error:
    xterm: can't open display
3) Ran "xhost +) on this local server and got the following error:
    xhost: can's open display

Telnet Issue:

When I attempt to telnet to other server or the local server I get the following error:

telnet: unable to connect to remote host: Connection refused.

I really need to understand what's going on with the remote display issue before the telnet issue. I can remote a "xterm" window from the Knoppix server to a RedHat 5.0 server, but not the other way.

Question by:johnj65
  • 5
  • 3
LVL 13

Expert Comment

ID: 24035860
Check if the server has in /etc/ssh/sshd_config for X11Forwarding yes

If you need to change it to yes, restart the sshd server and try again.

As for the export, just use "export DISPLAY="

Author Comment

ID: 24037508
ssh is working fine as I mentioned in my initial question and the /etc/ssh/sshd_config was set to "yes" for X11 Forwarding. Still need to determine why "telnet" is not working?

As for export, I've tried the "export DISPLAY=" and still have the issue with unable to run xhost + or xterm on the local server unless I set the DISPLAY variable to the following:

export DISPLAY=:0.0

What should I try next??

LVL 40

Expert Comment

ID: 24038687
use ssh -x to do X forwarding and do not set DISPLAY yourself

>telnet: unable to connect to remote host: Connection refused.

means that telnet is nut enabled on the remote server or there is a firewall denying you
Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.


Author Comment

ID: 24039381
How can I determin if a firewall is configured for Knoppix?


Author Comment

ID: 24040551
I was able to use ssh -x to call up a xterm from one server to the other. This is not correcting the problem that I'm having.

1) From a RHEL 5.0 server ( I set the following:
    export DISPLAY
2) Execute "xterm" and I get the following error:
    xterm Xt error: Can't open display:
3) On the server running Knoppix, I set the following:
     xhost + <Enter>
    access control disabled, clients can connect from any host
4) Execute "xterm" again from the RHEL server ( and get the following error:
     xterm Xt error: Can't open display:

It seems that I've got some type of firewall or something on the Knoppix system thats stopping these remote displays? Once again ssh is working between the two servers and I'm able to remote a display "xterm window" from the Knoppix server to the RedHat server.

I can't find how this was setup on Knoppix and this problem is also stopping me from not just remoting displays but using telnet.

LVL 40

Expert Comment

ID: 24043001
Check if iptables is the one denying you. I am not an iptables expert, but the link below might help:


Author Comment

ID: 24045815
Found no iptables being setup in Knoppix.
LVL 40

Expert Comment

ID: 24045851
Do you have a firewall in your network between the two systems?

Accepted Solution

johnj65 earned 0 total points
ID: 24099145
Sorry for not responding sooner... Out of town.

No firewall between the networks just using a simple hub for the connection of the two servers. It's something in the OS that's preventing the remote displays within Knoppix (DSL-N).


Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Why VNC doesn't work in Redhat? 11 72
how to rebuild XFS volume from LV 19 90
Rate limit for DNS queries 7 85
ftp to port 21 4 54
I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question