Solved

ASA VPN - Internet Access

Posted on 2009-04-01
6
318 Views
Last Modified: 2013-12-23
Having trouble getting internet access to work once I connect the VPN client.

I can ping all the way out to the external interface once the vpn client is connected.  

I am pretty sure it is something stupid, but I am currently stuck.

Thanks for the help.

-chris
ASA Version 8.0(3)

!

hostname sun

domain-name xxxx

enable password *&^%*&%*&^%&*% encrypted

names

!

interface Vlan1

 nameif outside

 security-level 0

 ip address xx.xx.xx.xx 255.255.255.248

!

interface Vlan4

 no nameif

 security-level 50

 ip address pppoe

!

interface Vlan11

 nameif inside

 security-level 100

 ip address 192.168.1.1 255.255.255.0

!

interface Ethernet0/0

!

interface Ethernet0/1

 switchport access vlan 11

 shutdown

!

interface Ethernet0/2

 switchport access vlan 11

!

interface Ethernet0/3

 switchport access vlan 11

!

interface Ethernet0/4

 switchport access vlan 11

!

interface Ethernet0/5

 switchport access vlan 11

!

interface Ethernet0/6

 switchport access vlan 11

!

interface Ethernet0/7

 switchport access vlan 11

!

passwd *&^%*&%*&^%&*% encrypted

ftp mode passive

dns server-group DefaultDNS

 domain-name hexnet

same-security-traffic permit intra-interface

access-list inbound extended permit ip host x.x.x.x host x.x.x.x

access-list inbound extended permit ip host x.x.x.x host x.x.x.x

access-list inbound extended permit tcp any host x.x.x.x eq 3389

access-list inbound extended permit ip any host x.x.x.x

access-list inbound extended permit tcp any host x.x.x.x eq www

access-list inbound extended permit tcp any host x.x.x.x eq 5001

access-list inbound extended permit tcp any host x.x.x.x eq 5002

access-list inbound extended permit tcp any host x.x.x.x eq 5003

access-list inbound extended permit tcp any host x.x.x.x eq https

access-list inbound extended permit tcp any host x.x.x.x eq www

access-list inbound extended permit tcp any host x.x.x.x eq imap4

access-list inbound extended permit tcp any hos tx.x.x.x eq ssh

access-list inbound extended permit tcp any hostx.x.x.x eq 5001

access-list inbound extended permit ip any host x.x.x.x

access-list inside_nat0_outbound extended permit ip any 192.168.1.0 255.255.255.0

access-list hexvpn_splitTunnelAcl standard permit any

pager lines 24

logging enable

mtu outside 1500

mtu inside 1500

ip local pool vpnpool 192.168.1.50-192.168.1.55 mask 255.255.255.0

icmp unreachable rate-limit 1 burst-size 1

asdm image disk0:/asdm-603.bin

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 1 0.0.0.0 0.0.0.0

static (inside,outside) x.x.x.x 192.168.1.80 netmask 255.255.255.255

static (inside,outside) x.x.x.x 192.168.1.133 netmask 255.255.255.255

static (inside,outside) x.x.x.x 192.168.1.132 netmask 255.255.255.255

static (inside,outside) x.x.x.x192.168.1.150 netmask 255.255.255.255

static (inside,outside) x.x.x.x 192.168.1.237 netmask 255.255.255.255

static (inside,outside) x.x.x.x 192.168.1.140 netmask 255.255.255.255

static (inside,outside) x.x.x.x 192.168.1.180 netmask 255.255.255.255

access-group inbound in interface outside

route outside 0.0.0.0 0.0.0.0 x.x.x.x 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout uauth 0:05:00 absolute

dynamic-access-policy-record DfltAccessPolicy

aaa authentication enable console LOCAL

aaa authentication http console LOCAL

aaa authentication ssh console LOCAL

aaa authentication telnet console LOCAL

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map outside_map interface outside

crypto isakmp enable outside

crypto isakmp policy 10

 authentication pre-share

 encryption 3des

 hash sha

 group 2

 lifetime 86400

telnet 0.0.0.0 0.0.0.0 inside

telnet timeout 10

ssh 0.0.0.0 0.0.0.0 inside

ssh timeout 10

console timeout 0

dhcpd dns x.x.x.x x.x.x.x

dhcpd lease 14400

dhcpd ping_timeout 300

dhcpd domain hexnet

!

dhcpd address 192.168.1.180-192.168.1.190 inside

dhcpd dns x.x.x.x x.x.x.x interface inside

dhcpd lease 14400 interface inside

dhcpd ping_timeout 300 interface inside

dhcpd domain geekadvice interface inside

dhcpd update dns both interface inside

dhcpd enable inside

!

 

threat-detection basic-threat

threat-detection statistics

group-policy hexvpn internal

group-policy hexvpn attributes

 dns-server value x.x.x.x x.x.x.x

 vpn-tunnel-protocol IPSec

 split-tunnel-policy tunnelspecified

 split-tunnel-network-list value hexvpn_splitTunnelAcl

 default-domain value hexnet

username nulluser password *(^*(&^*(&^&*(^&*(^&*(^ encrypted privilege 15

tunnel-group hexvpn type remote-access

tunnel-group hexvpn general-attributes

 address-pool vpnpool

 default-group-policy hexvpn

tunnel-group hexvpn ipsec-attributes

 pre-shared-key *

!

class-map inspection_default

 match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

 parameters

  message-length maximum 512

policy-map global_policy

 class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect netbios

  inspect rsh

  inspect rtsp

  inspect skinny

  inspect esmtp

  inspect sqlnet

  inspect sunrpc

  inspect tftp

  inspect sip

  inspect xdmcp

!

service-policy global_policy global

prompt hostname context

Cryptochecksum:d67f46de5e733b70147e0b02045cf13d

: end

sun#

Open in new window

0
Comment
Question by:TheHexzero
  • 3
  • 2
6 Comments
 
LVL 5

Expert Comment

by:theoaks
ID: 24036734
try being more specifc with your split tunnel acl

ie

access-list hexvpn_splitTunnelAcl permit ip 192.168.1.x 255.255.255.0 any
0
 
LVL 5

Expert Comment

by:theoaks
ID: 24036756
and remove the other line of course..
i believe whats happening is your telling your client to send "any" traffic through the tunnel - even internet traffic. specifiying 192.168.1.0 255.255.255 0 > any in your acl should tell the client that ony send local traffic over the tunnel and web traffic to go out the regular way.

can someone confirm that... its been a while since ive touched cisco ios (stuck with hp where i work!!)
0
 

Author Comment

by:TheHexzero
ID: 24036976
Thanks theoaks.  

I should have specified:

I would like all traffic to go through the tunnel and out the "Outside" interface of ASA firewall.

Let me know if that helps...

-hexzero
0
Give your grad a cloud of their own!

With up to 8TB of storage, give your favorite graduate their own personal cloud to centralize all their photos, videos and music in one safe place. They can save, sync and share all their stuff, and automatic photo backup helps free up space on their smartphone and tablet.

 
LVL 5

Accepted Solution

by:
theoaks earned 50 total points
ID: 24036997
0
 
LVL 2

Expert Comment

by:e3user
ID: 24304967
just correct this ACL to the following

access-list hexvpn_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0
no access-list hexvpn_splitTunnelAcl standard permit any
0
 

Author Closing Comment

by:TheHexzero
ID: 31565207
Link was good....turns out I was not sending everything to the tunnel.  

Needed to make sure I added: split-tunnel-policy tunnelall      <-- added this to the group-policy attributes.

Thanks for the help!
0

Featured Post

Scale it in WD Gold

With up to ten times the workload capacity of desktop drives, WD Gold hard drives employ advanced technology to deliver among the best in reliability, capacity, power efficiency and performance.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I found an issue or “bug” in the SonicOS platform (the firmware controlling SonicWALL security appliances) that has to do with renaming Default Service Objects, which then causes a portion of the system to become uncontrollable and unstable. BACK…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

896 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now