Solved

Exchange 2007 unable to relay for additional domain (550 5.7.1 Unable to relay)

Posted on 2009-04-01
12
3,639 Views
Last Modified: 2012-05-06
We currently have a single 2007 exchange server that is setup to receive from multiple domains.
a.com
b.com
c.com  etc

All of these are Authoritative and work fine. We've since added another domain d.com yet we can't recieve email to it and get a 550 5.7.1 Unable to relay NDR.

The Hub transport connectors are default (Client/Default) and anonymous is checked for both. It's all fairly standard and is setup with SMTP * as default.

Can't see where this is going wrong unfortunately, the troubleshooting assistant returns with Mail submission failed: Error message: The SMTP host was not specified..

0
Comment
Question by:v0r73x
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
12 Comments
 
LVL 49

Expert Comment

by:Akhater
ID: 24037965
is d.com also set as authoritative ?

who is giving back the unable to realy errors the exchange server itself ?

can you paste an NDR?

Do you have the same problem sending to that domain internally?
0
 

Author Comment

by:v0r73x
ID: 24038584
d.com is Authoritative.

Users trying to send from external domains are receiving the NDR (e.g. hotmail.com to d.com)

Users emailing internally are ok (e.g. a.com to d.com)
Delivery has failed to these recipients or distribution lists:
 
user1@d.com
Your message wasn't delivered because of security policies. Microsoft Exchange will not try to redeliver this message for you. Please provide the following diagnostic text to your system administrator.
 
The following organization rejected your message: mail.a.com.
 
 
--------------------------------------------------------------------------------
Sent by Microsoft Exchange Server 2007 
 
 
 
 
 
 
Diagnostic information for administrators:
 
Generating server: server.a.local
 
user1@d.com
mail.a.com #550 5.7.1 Unable to relay ##
 
Original message headers:
 
Received: from server.a.local ([fe80::f5b6:8710:75f0:9541]) by
 server.a.local ([fe80::f5b6:8710:75f0:9541%10]) with mapi; Wed,
 1 Apr 2009 09:52:21 +0100
From: Administrator <admin@a.com>
To: "user1@d.com" <user1@d.com>
Date: Wed, 1 Apr 2009 09:52:20 +0100
Subject: Test 3
Thread-Topic: Test 3
Thread-Index: AQHJsqcqIb72fTttNUGnCw7hZyCCVw==
Message-ID: <9B88EAB36D968B49A8F62442E550464F85D4FA8C8F@server.a.local>
Accept-Language: en-US, en-GB
Content-Language: en-GB
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
acceptlanguage: en-US, en-GB
Content-Type: multipart/alternative;
	boundary="_000_9B88EAB36D968B49A8F62442E550464F85D4FA8C8FMservera_"
MIME-Version: 1.0

Open in new window

0
 
LVL 49

Expert Comment

by:Akhater
ID: 24039569
Can you try to send an email by telnet & check what exchange will "say"

telnet mail.a.com 25
ehlo
mail from:a@gmail.com
rcpt to:user@d.com
----- do you get an error at this point?---
data
test
.
0
Comparison of Amazon Drive, Google Drive, OneDrive

What is Best for Backup: Amazon Drive, Google Drive or MS OneDrive? In this free whitepaper we look at their performance, pricing, and platform availability to help you decide which cloud drive is right for your situation. Download and read the results of our testing for free!

 

Author Comment

by:v0r73x
ID: 24040156
Unfortunately I just get 550 5.7.1 Unable to relay after I enter the rcpt to:user@d.com etc
0
 
LVL 49

Expert Comment

by:Akhater
ID: 24040247
well then exchange is not seeing itself as authoritative of that domain

can you double check in the list of accepted domains ?
0
 

Author Comment

by:v0r73x
ID: 24040302
I can guarantee 100% they are in the accepted domains list, hence the EE post :)

I've not restarted any services so wondering if that may help refresh anything?
0
 
LVL 49

Accepted Solution

by:
Akhater earned 500 total points
ID: 24040341
Well I have never seen this happening on exchange 2007 before sorry if i was skeptical  :o)


Usually there is nothing to restart but you can try restarting the transport service to see if it helps


Do you have any error in the event log ?
0
 
LVL 49

Expert Comment

by:Akhater
ID: 24040432
if you try a Get-ReceiveConnector | fl

can you paste the result, it might be a permission error or something
0
 
LVL 49

Expert Comment

by:Akhater
ID: 24040492
sorry for the multiple posts but you have intrigued me

Replace the above command by

Get-ReceiveConnector "ReceiveConnector" | Get-ADPermission -user "NT AUTHORITY\Anonymous Logon" | fl
0
 

Author Comment

by:v0r73x
ID: 24040505
Have restarted the transport service and that seems to have resolved it! Bit odd so will add a few more domains and test as usually it works straight away :S Thanks for the input!
0
 
LVL 49

Expert Comment

by:Akhater
ID: 24040520
yes i don't recall I have ever restarted the transport service this is odd in fact

glad to know it fixed it and sorry i wasn't of any help
0
 

Expert Comment

by:luckyhorse
ID: 25827169
i had the same problem and restarting the transport service fixed also.  cheers.
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question