• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5690
  • Last Modified:

certificate private key is not installed

Helly Everyone,

We are trying to implement our new exchange server. But we have a problem with the certificate on isa 2006. There it sais that the private key is not installed.

We have exported the certificate from the exchange 2007 server with the private key. This part was succesfull. But when we import this file back into the isa server, suddenly the private key is missing.

We have massive headaches at this point :P

Thanks in advance

1 Solution
When you created your cert, did you use the -privatekeyExportable:$true switch? (See: http://msexchangeteam.com/archive/2007/02/19/435472.aspx). Once you create your request, then receive your cert, you 1st have to install it using the LOCAL COMP acct (NOT USER acct) on the SAME server you generated the request. Once that is done, you will do the export on that server, then you can install it on your ISA server (again, using the LOCAL COMP acct for the cert MMC).

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Managed Security Services Webinar - March 15

Selecting the right managed security services platform to grow your business can be a huge undertaking. Join WatchGuard and Frost & Sullivan in an upcoming webinar as we dive into the key elements of selecting a vendor platform and partnership to fuel a successful MSSP business.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now