Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

iTunes Library file cannot be saved.

Posted on 2009-04-01
11
Medium Priority
?
11,554 Views
Last Modified: 2013-11-06
I am using Windows XP Professional Service Pack 2 32-bit, and currently iTunes v8.1, though the problem has occured with other versions.

Every so often, my iTunes will pop up with the error message:
The iTunes Library file cannot be saved. You do not have enough access privileges for this operation.

There is no particular action that causes this error. It could be while I'm downloading a podcast, or editing a song title, no specific time, and I cannot recreate the error at will.

My iTunes Library.xml and .itl files are located in the directory: C:\Documents and Settings\Walt\My Documents\My Music. This directory is not shared (it was at one time, and I stopped sharing it, which seemed to help the problem, but now the error message has popped up again, still with no sharing).

Thank you in advance,
Walt D in LV
0
Comment
Question by:WaltCD
11 Comments
 
LVL 66

Accepted Solution

by:
johnb6767 earned 1000 total points
ID: 24041087
Have you tried to reapply the permissions to that Music Folder? Grant yourself Full Control over it, and make sure to click the Advanced Button (in teh security tab), and "Replace permission entries on all child objects....etc...."
0
 
LVL 54

Assisted Solution

by:b0lsc0tt
b0lsc0tt earned 1000 total points
ID: 24045479
WaltCD,

What permissions does that Windows user account have (e.g. Admin, User, Power User)?  If not admin then does adding the user to the Administrators group help the problem or fix it?

What about another Windows user on that same computer?  You would need to copy your iTunes library, etc but it would be a nice test to see if the problem is related to your Windows profile or something else.

Let me know if you have any questions or need more information.

b0lsc0tt
0
 

Author Comment

by:WaltCD
ID: 24346532
I had the My Documents folder, that the iTunes folder was in, shared. I have now, un-shared it, as well as move the iTunes files folder to the Shared Documents folder at: C:\Documents and Settings\All Users\Documents\iTunes Files

This seems to have helped quite a bit, although every once in a while, the same message pops up (iTunes Library cannot be saved)


Walt D in LV
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 24346720
Did you need any other help with this then?  If so please try what I suggested and respond to it.  Thanks for the update on this.
bol
0
 

Author Comment

by:WaltCD
ID: 24400971
I am an Admin user on this computer. Having the iTunes library stored in the Shared Documents folder at: C:\Documents and Settings\All Users\Documents\iTunes Files works most of the time, but occasionally the same message pops up. Not right away, but perhaps after a few minutes of iTunes running.

I will next try to move the library to a different user. As I said, right now, it's under All Users and that helped quite a bit. I will move it and advise you of the results.

Thanks,
Walt D in LV
0
 

Expert Comment

by:RV_Reese
ID: 24675406
I am DEFINITELY not an expert.  I came here seeking answers.
I, too, have experienced this message.  Is this message just a random annoyance, or something to be worried about?
And . . . I just entered  "iTunes Library cannot be saved" as a search term and found out that there are LOTS of folks who've experienced this -- takeaway question from the search: why doesn't Apple do something about this issue?
0
 

Author Comment

by:WaltCD
ID: 24676061
Presently, this error only occurs occasionally. It seems more and more rare.

My problem was initially caused my SHARING the My Documents folder. I corrected that, still had SOME issues, then moved my iTunes Library to the All Users/Documents folder. This has helped quite a bit, and I am satisfied.

More of an issue is every time my iTunes starts up, it gives me an error message about my CD/DVD drives. That issue can be found here:
http://www.experts-exchange.com/Apple/Hardware/iPODs/iTunes/Q_24265956.html

Thank you everyone for your help.
Walt D in LV
0
 

Author Closing Comment

by:WaltCD
ID: 31565376
Thank you for all your help.
0
 

Author Comment

by:WaltCD
ID: 25119734
I recently moved my iTunes file over to another computer (the new computer is running Windows 7). Worked fine for several hours, then I got the same message:

The iTunes Library file cannot be saved. You do not have enough access privileges for this operation.
For me, the problem occurred again since I'm sharing my My Documents folder, and everything in it.
I was very easily able to fix the problem by:
  1. Finding my iTunes folder, which was located in my MUSIC folder
  2. RIGHT-click on the folder, select Properties, then the Sharing tab
  3. Click the Share... (you may have a "Share this Folder" button or "Share this folder on the Network" checkbox)
  4. NAME the Shared Folder (I chose Walt iTunes) and click OK. It may take a few minutes to share the folder.
  5. Finally, RIGHT-click on the iTunes folder again, and select "Stop Sharing this Folder" or you may have to go to Properties again, and deselect the Checkbox.
  6. Click OK and you should be done!
Not very difficult, but a few little steps. Best part is, it worked for me, and I'm still sharing My Documents!


Cheers!
Walt D in LV
0
 
LVL 3

Expert Comment

by:Jim Restucci
ID: 25410670
After a few hours on the phone with Apple Support we discovered the problem, it has nothing to do with permissions, as much as it has to do with a the way iTunes writes data to the library file.  If for some reason the iTunes cannot write to the library file it will create a TMP file which it stores your data in, then it will periodically attempt to write to the file; however the file is in use and neither iTunes or any other Windows application for that matter can write to the file.  If you attempt to delete the file you will be told you don't have permissions, if you attempt to change permissions or take ownership you will also be told you cannot because you don't have permission.
However; if you shut down your system and reboot into safe mode, and delete the file, and then restart your machine, the message should disappear and you shouldn't see the temp file anymore.
Believe me, I had the first Apple guy (Tier 1) stumped; only after he brought in a Tier 2 guy did we figure it out.
Hope this helps someone.  The Tier 2 guy did say that he was sending this one to the Engineers, so hopefully those of you updating to iTunes 9.01 won't have this problem.
0
 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 25415392
axcess_internet,

Thanks for the info and posting the details.  Very interesting and hopefully they will be helpful to those who view this in the future (at least until an update fixes it ;)).

b0lsc0tt
EE Zone Advisor
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Can I legally transfer my OEM version of Windows to another PC?  (AKA - Can I put a new systemboard in my OEM PC?) Few of us are both IT and legal experts but we all have our own views of Microsoft's licensing rules and how they apply.  There are…
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…
Suggested Courses

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question