Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

ASA 5505 RDP problem

Posted on 2009-04-01
3
Medium Priority
?
846 Views
Last Modified: 2012-05-06
Hello,Im having problems making RDP work on a computer. I can RDP to it internally, but not externally. I have a Public IP for the computer which is 99.*.*.41 and thats what i want to type and be able to access from external internet. So basically, an RDP port foward from that external ip to my internal ip which is 10.200.1.191. I once got it to work some time ago, but now on this config, im not sure what im  missing.

I also have some other ports (tcp-2776,1719,3230-3243. udp-1719,3230-3285) i need for a specific application to work fowarded to the computer (10.200.1.191). Dont know if it has to do anything with it.

On the LOG i get this message when i try to connect externally to the computer.

208.*.*.163      99.*.*.41  Deny tcp src outside:208.*.*.163/64063 dst inside:99.*.*.41/3389 by access-group "outside_access_in" [0x0, 0x0]


Here is the running config.


: Saved
:
ASA Version 7.2(3)
!
hostname *
domain-name *
enable password u1N2uiTOMgtVzzpC encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.200.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 99.*.*.43 255.255.255.248
!
interface Vlan3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd u1N2uiTOMgtVzzpC encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name *
access-list outside_1_cryptomap extended permit ip host 99.*.*.43 host 75.*.*.225
access-list outside_1_cryptomap extended permit ip 10.200.1.0 255.255.255.0 host 75.*.*.225
access-list outside_1_cryptomap extended permit ip 10.200.1.0 255.255.255.0 10.200.2.0 255.255.255.0
access-list rdp-capture extended permit tcp any interface outside eq 3389
access-list outside_access_in extended permit tcp any host 10.200.1.191 eq 2776
access-list outside_access_in extended permit tcp any host 10.200.1.191 eq 1719
access-list outside_access_in extended permit tcp any host 10.200.1.191 range 3230 3243
access-list outside_access_in extended permit udp any host 10.200.1.191 range 3230 3285
access-list outside_access_in extended permit udp any host 10.200.1.191 eq 1719
access-list outside_access_in extended permit tcp any host 10.200.1.191 range 3230 3285
access-list outside_access_in extended permit tcp any interface outside eq 3389
access-list outside_access_in extended permit tcp any eq 3389 interface outside eq 3389
access-list outside_access_in extended permit tcp any host 10.200.1.191 eq 3389
access-list inside_nat0_outbound extended permit ip host 99.*.*.43 host 75.*.*.225
access-list inside_nat0_outbound extended permit ip 10.200.1.0 255.255.255.0 host 75.144.228.225
access-list inside_nat0_outbound extended permit ip 10.200.1.0 255.255.255.0 10.200.2.0 255.255.255.0
access-list 100 extended permit ip 10.200.1.0 255.255.255.0 10.200.2.0 255.255.255.0
access-list outside_in extended permit tcp any host 99.*.*.41 eq 3389
pager lines 24
logging enable
logging monitor debugging
logging asdm informational
mtu inside 1500
mtu outside 1500
no failover
monitor-interface inside
monitor-interface outside
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 99.*.*.41 netmask 255.255.255.255
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 2776 10.200.1.191 2776 netmask 255.255.255.255
static (inside,outside) tcp interface 1719 10.200.1.191 1719 netmask 255.255.255.255
static (inside,outside) tcp 99.188.67.41 3389 10.200.1.191 3389 netmask 255.255.255.255
static (inside,outside) 99.*.*.45 10.200.1.5 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 99.*.*.46 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 10.200.1.5 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 75.*.*.225
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 10.200.1.5 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
  inspect pptp
!
service-policy global_policy global
username admin password 3ETJzDL4hW/jJ62O encrypted
tunnel-group 75.*.*.225 type ipsec-l2l
tunnel-group 75.*.*.225 ipsec-attributes
 pre-shared-key *
prompt hostname context
Cryptochecksum:c200a115842365c45ee4e198a67291d1
: end
asdm image disk0:/asdm-523.bin
no asdm history enable



0
Comment
Question by:Comptx
  • 2
3 Comments
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 2000 total points
ID: 24041271
Add this:

conf t
access-list outside_access_in extended permit tcp any host 99.188.67.41 eq 3389
0
 

Author Comment

by:Comptx
ID: 24041360
Well, that was quick!

You got it too, works perfectly.  Thanks..
 

and btw..
Since you know this ASA 5505 stuff alot, maybe you can also help me on this?  :)
http://www.experts-exchange.com/Hardware/Networking_Hardware/Firewalls/Q_24264125.html


Thank you for resolving this  so quickly.
0
 

Author Closing Comment

by:Comptx
ID: 31565407
Thanks alot!!
0

Featured Post

Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Powerful tools can do wonders, but only in the right hands.  Nowhere is this more obvious than with the cloud.
As managed cloud service providers, we often get asked to intervene when cloud deployments go awry. Attracted by apparent ease-of-use, flexibility and low computing costs, companies quickly adopt leading public cloud platforms such as Amazon Web Ser…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses
Course of the Month11 days, 21 hours left to enroll

916 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question