Solved

BGP USING LOCAL_PREF & MED ATTRIBUTES

Posted on 2009-04-01
3
447 Views
Last Modified: 2012-05-06
i have configured 3 routers:

sanjose3 - main router
ISP1A - another route path
ISP1B - another route path

ive now added:

- a local_pref on ISP1A
- & a badmetric on ISP1A
- a goodmetric on ISP1B

- always compare on Sanjose3
sanjose3 - then "clear ip bgp *"
sanjose3 - then "sh ip bgp"

sanjose3#sh ip bgp
BGP table version is 2, local router ID is 200.100.50.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.100.50.0     0.0.0.0                  0         32768 i
sanjose3#

1.  according to my instructions after doing the "sh ip bgp" command, im supposed to see on sanjose3 2 paths to the 10.0.0.0 network but each path should have different metrics.  why can I only see one path as above?
-----------------------------------------------------
Building configuration...

Current configuration : 799 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sanjose3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
interface Ethernet0
 ip address 200.100.50.1 255.255.255.0
!
 interface Serial0
 ip address 192.168.1.6 255.255.255.252
 clock rate 56000
 no fair-queue
!
interface Serial1
 ip address 172.24.1.17 255.255.255.252
 clock rate 56000
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router bgp 300
 no synchronization
 bgp always-compare-med
 bgp log-neighbor-changes
 network 200.100.50.0
 neighbor 172.24.1.18 remote-as 400
 neighbor 192.168.1.5 remote-as 200
 no auto-summary
!
ip http server
ip classless
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

sanjose3#
---------------------------------------
Building configuration...

Current configuration : 878 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP1A
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 192.168.1.5 255.255.255.252
 no fair-queue
!
interface Serial1
 ip address 10.1.1.1 255.255.255.252
 clock rate 56000
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 10.0.0.0
 neighbor 10.1.1.2 remote-as 400
 neighbor 10.1.1.2 route-map viaAS400 in
 neighbor 192.168.1.6 remote-as 300
 neighbor 192.168.1.6 route-map badmetric out
 no auto-summary
!
ip http server
ip classless
!
!
!
route-map viaAS400 permit 10
 set local-preference 150
!
route-map badmetric permit 10
 set metric 150
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

ISP1A#
--------------------------------
Building configuration...

Current configuration : 825 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP1B
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 172.24.1.18 255.255.255.252
 no fair-queue
!
interface Serial1
 ip address 10.1.1.2 255.255.255.252
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router bgp 400
 no synchronization
 bgp log-neighbor-changes
 network 10.0.0.0
 neighbor 10.1.1.1 remote-as 200
 neighbor 172.24.1.17 remote-as 300
 neighbor 172.24.1.17 route-map goodmetric out
 no auto-summary
!
ip http server
ip classless
!
!
!
route-map goodmetric permit 10
 set metric 50
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

ISP1B#
0
Comment
Question by:mikey250
  • 2
3 Comments
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 500 total points
ID: 24041966
Change the network statement on ISP1A and ISP1B to the following:

ISP1A:

router bgp 200
no network 10.0.0.0
network 10.1.1.0 mask 255.255.255.252

ISP1B:

router bgp 400
no network 10.0.0.0
network 10.1.1.0 mask 255.255.255.252
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24091218
Did my comment take care of this?
0
 

Author Comment

by:mikey250
ID: 24105583
apologies for taking so long to reply. my account has not been accessible until today.

yes this did rectify the problem.  my instructions were wrong and i will have to whatch out for this kind of error in my instructions.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
VoIP and Data on single switch, with SonicWall 6 54
iPad Won't Connect 16 74
How to make my old USB printer wireless? 71 152
BGP routing on Windows 2016 7 38
In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

912 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now