• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1673
  • Last Modified:

Problem transferring vmware image using winscp

I have taken an image of a machine using storage craft and converted that image to a .vdmk image however when I transfer that image from the current server to the new vmware server using winscp it gets nearly all the way but errors on could not rename server.vmdk.filepart to server.vmdk, not sure why this is happening?
0
Sid_F
Asked:
Sid_F
1 Solution
 
rvthostCommented:
There's an easy workaround...easy enough that I never dug into this to determine the core problem.  But go ahead and do your WinSCP and when you get the error, just click the Abort button.  Then putty into the ESX server that you were copying the image to, change directory to where you copied the file to, and do a "mv" to rename it and it works just fine.

In summary:

- Copy with WinSCP.
- Putty into ESX
- cd /vmfs/volumes/folder/folder2...etc.
- mv filename.vmdk.filepart filename.vmdk

Done.
0
 
za_mkhCommented:
Also, I recommend veeams, fastscp tool. it's free and is definitely faster that WinSCP from my own experience.
www.veeam.com
 
0
 
Sid_FAuthor Commented:
Sorry I'm a complete novice at commands for vmware, after I login what are the exact command to browse through the folder as i keep getting command not found
0
Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

 
rvthostCommented:
No problem.  The commands above should be close, depending on what your file structure looks like.  

1.  cd /  (change directory to root)
2. ls (list the directories, do you see 'vmfs'?)
3.  cd /vmfs
4.  ls (if you want to see what directories are there)

continue doing so until you drill into the folder where your VMDK resides.  Often it will look like "cd /vmfs/volumes/YourSANLun/Win2003"

Once there, do an 'ls' again and you should see your filename.vmdk.filepart.  So then it's just:

mv filename.vmdk.filepart filename.vmdk
0
 
Sid_FAuthor Commented:
[root@localhost root]# cd /vmfs
[root@localhost vmfs]# ls
devices  volumes
[root@localhost vmfs]# cd /volumes
-bash: cd: /volumes: No such file or directory
[root@localhost vmfs]#


Not sure why i get no such file or directory
0
 
rvthostCommented:
ahh, drop the front slash before you do volumes.  The slash in Linux indicates you are beginning from the root level.

cd /vmfs
cd volumes

OR  cd /vmfs/volumes  should also work if it's all together.
0
 
Paul SolovyovskyCommented:
Have you tried vConverter? You should be able to point to the .SPF file as the source and the ESX host as the destination.
0
 
Sid_FAuthor Commented:
Ok I renamed the file correctly but when I go to create a new virtual machine and say use existing virtual image and browse to the database it can't find the .vmdk file, I have browsed direct to the database and can see the file, its like it doesn't recognise the file as a vmdk file?
0
 
rvthostCommented:
Not sure about that one; never had that happen.  At this point, I would try this free tool that was previously mentioned to copy the file again:

http://www.veeam.com/vmware-esxi-fastscp.html
0
 
Sid_FAuthor Commented:
I have used fastscp to transfer files between vmware server and it works extremely well however the vmware images I am transferring sit in a running vmware image so fastscp doesn't have the option to copy
0
 
Sid_FAuthor Commented:
Ok, here is the process, installed storage craft took image of xp pro laptop and saved image onto another partition on laptop. Used vmware converter to convert the image.spf file to server.vmdk and saved this onto a network drive belonging to a windows 2003 server.

Installed winscp on the windows 2003 server and transferred the files
image.vmdk
image.vmx
folder called image.vmdk.lck this contains a small file called M43220.lck (not sure the relevance of this file.

Transfer appears to go fine but errors giving permissions problem and the file then changes to image.vmdk.filepart, i have renamed the image using the vmware commands to image.vmdk and checked the points in the image.vmx file which are both correct but when creating a new machine it still does not recognise the file as a virutal machine file

0
 
Sid_FAuthor Commented:
No solution
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now