Solved

Snap Server 4200 Active Directory users disappearing

Posted on 2009-04-01
10
1,482 Views
Last Modified: 2012-06-27
I have a Snap Server 4200 that we have been using for about 3yrs. It has always worked just fine with our AD but about 6 months ago I had a problem were just 1 user couldnt access a share anymore. I checked the permissions and that user was no longer listed on the share or even in the list of ad users to add to the share. The only way I was able to fix it was delete the account and recreate it and that worked. But that is a huge pain of having to copy over all the profile info on their desktop to the new profile. Well it has happened 2 other times a well. The last time was just today. I no longer have support with overland and they want to charge for it and there forum sucks. Please anyone know ways to correct this. I have tried disjoining and rejoining the server from the domain. Rebooting the Snap sever and rebooting the domain server.

Its running GuardianOS 4.2.049 and its a 2003 domain.
0
Comment
Question by:cisconoshut
  • 4
  • 3
  • 2
10 Comments
 
LVL 18

Expert Comment

by:Jeremy Weisinger
ID: 24049465
I had a Snap 4500 and ran into that issue too. I got round it by giving the user explicit permission to the share. It's a pain.

If that doesn't work then get another NAS device. I'm not a fan of Snap Appliance.
0
 

Author Comment

by:cisconoshut
ID: 24049531
What do you mean by giving them explicit permission? The user doesnt show up as an ad user on the snap server so how would I do that?
0
 
LVL 18

Expert Comment

by:Jeremy Weisinger
ID: 24049596
Oh, I misunderstood. My problem was the span server would not give permission to the user even though it was a member of the proper group(s).
0
 

Author Comment

by:cisconoshut
ID: 24245192
No one has any clue on this? I really need to get this resolved and I cant find a solution anywhere.
0
 
LVL 1

Expert Comment

by:techinfo_bpm
ID: 25154149
Hi there. I have the same problem here. I've set on the snap server that the members of one group have some permissions. All works fine until I've added someone to the group. This new member of the group can't access at all the snap server.

We've tried all the logins we've set on the snap server and this never worked. I think that the snap server doesn't have a up-to-date information of the AD because when I wanted to add the user account, it was not listed in the list of AD's users.

I'll continue to search on the web and let you informed if I find something that works.
0
 

Author Comment

by:cisconoshut
ID: 25155452
That would be great 4 months later and I still have no solution. Though my issue is slightly different. If I add a new user to AD it shows up no problem on the snap server but rarely i'll an exisiting AD account just disappear off the Snap server. It hasnt happen again since I posted this but it has happened about 3 other times before this last time. Like stated before I delete the AD account that is not showing up on the snap server and create a new AD account with same name it shows up no problem but of course the SID is different and I have to migrate all of the users profile info over and its huge pain in the neck.
0
 
LVL 1

Accepted Solution

by:
techinfo_bpm earned 500 total points
ID: 25155516
I saw something on the net and it seems to be the solution. For now, I can't apply it because we haven't set the root password (it's factory default), and I have to find what is the default factory root password. Tried the generics default passwords such as root, toor, admin, empty, and some others.

To resume, we have to delete a file that contains the temporary database of the AD, reboot the snap server and the problem is solved (for how long? who knows...)

More details on http://forums.procooling.com/vbb/showthread.php?t=14442
0
 
LVL 1

Expert Comment

by:techinfo_bpm
ID: 25181880
The solution worked for me. Not as described in the lik i've posted, but similar.

I proceeded like below :
- log on with the admin account with Putty to the Snap server
- type osshell then enter
- type su - (or su root) and type the admin's password (the root and the admin password is the same)
- after that it was possible to delete the file described in the link
- reboot
0
 

Author Closing Comment

by:cisconoshut
ID: 31565547
Thanks
0

Join & Write a Comment

As a financial services provider, your business is impacted by two of the strictest federal regulations on record: the Sarbanes-Oxley Act and the Gramm-Leach-Bliley Act. Correctly implementing faxing into your organization to provide secure, real-ti…
In this article, we will see the basic design consideration while designing a Multi-tenant web application in a simple manner. Though, many frameworks are available in the market to develop a multi - tenant application, but do they provide data, cod…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now