Solved

VM Network Connection Goes Idle Unexpectedly

Posted on 2009-04-02
3
641 Views
Last Modified: 2013-11-11
I have Hyper-V setup on Windows Server 2008 Enterprise in server with two physical network adapters.   I have a Standard 2008 virtual machine running as a guest on the Enterprise host machine.  The host machine has it's own dedicated network adapter.  The guest virtual machine is configured to talk to a virtual external network configured on the other adapter in the host physical machine.  

After a period of user inactivity, the network connection on the guest os stops responding.  The host os responds just fine.  I can log into the host, open the Hyper-V manager and connect to the guest os.  The guest os shows low processor utilization and appears to be up.  However, The guest os does not start talking to the network again until I do something to manually "wake up" the network connection i.e. browsing the web from the console, even pinging from the command line.   If I open an application that is not network related before initiating something network related, it DOES NOT wake the network connection.

Any and all thoughts appreciated.  Thanks in advance
0
Comment
Question by:bebers
  • 2
3 Comments
 

Accepted Solution

by:
bebers earned 0 total points
ID: 24060223
Update:

I created a simple batch file to ping a remote host and scheduled it to run every 15 minutes.  This seems to keep the connection alive.   This works but I would prefer to get to the root of the problem.

Any ideas? Thanks again.
0
 
LVL 7

Expert Comment

by:kumarnirmal
ID: 24060955
Please check the Power Options Configuration of the Virtual Machine and also check whether the option "Allow the computer to turn off this device to save power" is enabled under Device Management Options of the Virtual NIC.
0
 

Author Comment

by:bebers
ID: 24061772
Power configuration of both VM and physical host are set to High Performance.  

"Allow ... turn off..."  on the physcial host NIC dedicated to VMs is unchecked (This shouldn't require a reboot of the physical host??)

There is no "Allow ... turn off ..." option on the VM virtual NIC device manager.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Can’t disable NAT protocol in Windows Server 2012 3 76
AD Account lockout 11 62
NTP time source for DC 3 41
Determine what is creating a pagefile.sys file? 33 41
Issue: One Windows 2008 R2 64bit server on the network unable to connect to a buffalo Device (Linkstation) with firmware version 1.56. There are a total of four servers on the network this being one of them. Troubleshooting Steps: Connect via h…
Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question