Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Trying to get SBS 2003 Default SMTP Virtual Server to use smart host in stead of "Direct Delivery"

Posted on 2009-04-02
5
Medium Priority
?
1,592 Views
Last Modified: 2012-05-06
I'm trying to get our 2003 SBS server to email out using what I understand the server calls a "Smart Host" which is just either: 1) our domain host's smtp server or 2) our ISP's smtp server.  This sounds like it should be simple. I've followed instructions I've found here but it still seems to be sending out email directly to the recipient's email server (What MS calls "Direct Delivery" I believe). The reason for this is we have two web apps that need to email out. One is Trend Micro SMB antivirus. (notification reports) and the other is an order entry type web app built around .net.

The emails seem to go out from the web application. In the event log, I see many event 4000 and 4006 which basically say it can't make an smtp connection to the recipient's mail server.

What I've done:
In Server Management -> Advanced Management -> Internet Information Services -> "MYSERVER" (local computer) -> Default SMTP Virtual Server -> (right click - Properties). Delivery Tab -> Advanced -> Smart host: mail.optonline.net (I've also tried smtp.1and1.com, our email/domain host).

I've tried changing "Masquerade domain" to "ourdomain.com" which we have hosted with 1and1.com.

For the "Fully qualified domain name" , I've looked up my cable modem's host name (something like: ool-123abc.static.optonline.net) so that the "Check DNS" button works - reverse DNS checks out, I guess.

In "Outbound Connections" button, port 25 for "TCP Port" is unchanged.

For "Outbound Security" I checked "Basic Authentication" and put in the username and password that corresponds to the smtp server I used  for the "Smart host". (I've tested those usernames and passwords directly with the service provider's webmail interface).

None of these changes seem to alter the default behavior of the outgoing SMTP server.

One other fact:Exchange server is not set up. As I understand it, Exchange and its smtp engine are separate from this IIS "Default SMTP Virtual Server"
0
Comment
Question by:RickNCN
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 22

Assisted Solution

by:cj_1969
cj_1969 earned 800 total points
ID: 24059836
Check out this page and read the "Configure a Smart Host" option ... http://support.microsoft.com/kb/303734
0
 

Author Comment

by:RickNCN
ID: 24060154
I'm pretty sure that's what I outlined above, that I already tried.
0
 
LVL 22

Expert Comment

by:cj_1969
ID: 24060293
Per the instructions that MS provided, double check to make sure you are not over-riding the smart host option with the route domain setting ... an entry of * will bypass all of the smart host routing.
Also, make sure that the Attempt direct delivery before sending to smart host is unchecked.

In this article it also states that if you change the smart host otion, make sure you change it in the virtual SMTP settings also ... I don't see any other reference to virtual SMTP settings but check the properties for this also ... you might need to enable something there.
0
 

Accepted Solution

by:
RickNCN earned 0 total points
ID: 24060640
Part 1:
Ok - if I understand correctly, to have a route domain setting you first need a remote domain setup under Default SMTP Virtual Server. I don't think I have that. What I have under "Domains" is:

Domain Name                                                   Type
-----------------------------------------------------------------------------------------------------|--------------------------|
myserver.myserverdomain.local                                                                                Local (Default)
5d84566a-3862-451b-bf41-c9a68b71a503._msdcs.myserverdomains.local            Local (Normal)

So, that said, there's no way to enter an "*" if I don't have a remote domain and route domain setup.

Part 2:
"Attempt direct delivery before sending to smart host" is unchecked

Part 3:
I'm confused, because you say, "if you change the smart host option, make sure you change it in the virtual SMTP settings also", but they are one in the same, no? To change the smart host option, you have to go *into* the virtual SMTP settings.
0
 

Author Comment

by:RickNCN
ID: 24281635
The web app company fixed their program to do is own email sending. So - I guess I don't need to worry about this anymore, which is good since I didn't receive any more follow-ups.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
Suggested Courses

598 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question