Solved

Xenapp on Xenserver: first xenapp server can not contact licesing server

Posted on 2009-04-02
12
1,782 Views
Last Modified: 2013-11-11
I created 2 vm's on my new xenserver.
xen runs licensing server and Web interface

xen1 is the first of many xenapp servers

I disabled teh firewalls on both. I am able to ping from one to the other.

I can open the wi on both.
The licensing server fails to connect.  I have no idea where to begin trouble shooting this.
I can open the LMC on both servers.

And a RPC error comes up from xen1 to xen trying to view webinterface via AMC. (related?)

I did a netstat -a to see what was running.. i read port 27000 is the lic server port.
The only listing of this port has a local address of 127.0.0.1
i dont used netstat alot. maybe thats normal.  Not sure why it be set to the loopback address?
no idea how to change it

0
Comment
Question by:Eric
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 4
12 Comments
 
LVL 11

Author Comment

by:Eric
ID: 24053305
The licensing server may have resolved itself.. for now.  The only way i know to test it is to reboot.  the error dint come up.  I still get the rpc error
tring to view WI via xen1's AMC.  I cant get it to work.  It works from xen, which is odd... but keeps it from being a critical issue, more of a annoyance.
0
 
LVL 11

Expert Comment

by:pfcjoker
ID: 24055141
Did you make sure your account was able able to do remote com+? Make sure you have enable network com+ in add and remove windows components as well as making sure the account is in the Distributed COM Users group on each server.
0
 
LVL 11

Author Comment

by:Eric
ID: 24055226
Its windows 2008. there is no add remove components. there are roles and features. neither have it?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 11

Author Comment

by:Eric
ID: 24055306
Sorry got distracted did not finish that comment.

Where do i go to check if that is done?
I would think citrix setup would have confirmed it was installed?

0
 
LVL 11

Expert Comment

by:pfcjoker
ID: 24055486
Ah 2008 - sorry wasn't listed so I assumed 2003.

http://technet.microsoft.com/en-us/library/cc753510.aspx

To enable network DTC access and configure Windows Firewall on Windows Vista or Windows Server 2008
Click Start, click Run, type dcomcnfg and then click OK to open Component Services.

In the console tree, click to expand Component Services, click to expand Computers, click to expand My Computer, click to expand Distributed Transaction Coordinator and then click Local DTC.

Right click Local DTC and click Properties to display the Local DTC Properties dialog box.

Click the Security tab.

Set the following options on the Security tab of the Local DTC Properties dialog box and click OK.
0
 
LVL 11

Author Comment

by:Eric
ID: 24102447
That did not fix it.
FYI
0
 
LVL 11

Author Comment

by:Eric
ID: 24209843
Could be coincidence. but now my mfcom is broken since following this :(
it wont start.  now i cant discover anything via the AMC
0
 
LVL 11

Expert Comment

by:pfcjoker
ID: 24226541
Have you tried doing a repair of the XenApp Install? that should recreate all the services, credentials, etc.
0
 
LVL 11

Author Comment

by:Eric
ID: 24226762
i did this and it fixed it.  
it still cant view the other servers web interface.  i find that odd. this was never a issue with PS 4.5 on 2003 server.
 
0
 
LVL 11

Author Comment

by:Eric
ID: 24226865
hmm  additional note:
xen (web inteface /licensing server) can view web inteface in the AMC. it CANNOT discover Xen1 (only xenapp server so far)
Xen1 can discover itself in AMC but not the web inteface on Xen.
:|
they both can ping eachother.
0
 
LVL 11

Accepted Solution

by:
pfcjoker earned 500 total points
ID: 24273306
FYI Web Interface 5.1 and up now no longer stores any Web Interface information in the Citrix Datastore (in 4.x versions you used to have the option to have it stored in datastore so it could be administered from any server) - so essentially Web Interface administration can now only happen on the Web Interface server's locally installed AMC only...

Just something to keep in mind.
0
 
LVL 11

Author Comment

by:Eric
ID: 24273651
and explains why it dont work.  that seems dumb to me. but i guess its the answer i been looking for.
thanks
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Veeam Backup & Replication has added a new integration – Veeam Backup for Microsoft Office 365.  In this blog, we will discuss how you can benefit from Office 365 email backup with the Veeam’s new product and try to shed some light on the needs and …
In this article, I will show you HOW TO: Perform a Physical to Virtual (P2V) Conversion the easy way from a computer backup (image).
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
In this video tutorial I show you the main steps to install and configure  a VMware ESXi6.0 server. The video has my comments as text on the screen and you can pause anytime when needed. Hope this will be helpful. Verify that your hardware and BIO…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question