Solved

All Exchange 2007 roles are hung trying to install.

Posted on 2009-04-02
10
1,069 Views
Last Modified: 2012-05-06
This is on a 2008 Standard Server with Exchange 2007 Sp1 installed
Exchange BPA and Exchange Setup UI both show these issue.
Pulled directly from the ExBPA reports
_______________________________________________________

  Cannot install the Edge Transport server role when other roles are already installed. :  
 Cannot install the Edge Transport server role when other roles are already installed.
  Tell me more about this issue and how to resolve it.  
 
  Clustered Mailbox Server installation cannot continue: Unexpected error [0xB8EE13C6] while executing command 'New-ClusteredMailboxServerObjects -DomainController:'' -Name:'' -IPAddress: -IPv4Addresses: -IPv4Networks: -IPv6Networks: -SharedStorage:$ -DataPath:'' -whatif'. :  
 Clustered Mailbox Server installation cannot continue: Unexpected error [0xB8EE13C6] while executing command 'New-ClusteredMailboxServerObjects -DomainController:'' -Name:'' -IPAddress: -IPv4Addresses: -IPv4Networks: -IPv6Networks: -SharedStorage:$ -DataPath:'' -whatif'.
 
(THERE ARE ABOUT 30 OF THESE LISTED WITH ALL DIFFERENT PROCESSES)
  Setup cannot continue with the upgrade because the 'aspnet_state' () process (ID: 5460) has open files. Close the process and restart Setup. :  
 Setup cannot continue with the upgrade because the 'aspnet_state' () process (ID: 5460) has open files. Close the process and restart Setup.
 
  The Client Access server role is already installed on this computer. :  
 The Client Access server role is already installed on this computer.
 
  The clustered mailbox server removal cannot continue: Unexpected error [0xFA764A79] while executing command 'Remove-ClusteredMailboxServerObjects -DomainController:'' -Identity:'' -whatif'. :  
 The clustered mailbox server removal cannot continue: Unexpected error [0xFA764A79] while executing command 'Remove-ClusteredMailboxServerObjects -DomainController:'' -Identity:'' -whatif'.
 
  The clustered mailbox server removal cannot continue: Unexpected error [0xFA764A79] while executing command 'set-ClusterPassiveNodeDefaults -InstallMode:uninstall -DomainController:'' -ActiveCmsUninstall:('' -eq 'true') -whatif'. :  
 The clustered mailbox server removal cannot continue: Unexpected error [0xFA764A79] while executing command 'set-ClusterPassiveNodeDefaults -InstallMode:uninstall -DomainController:'' -ActiveCmsUninstall:('' -eq 'true') -whatif'.
 
  The Hub Transport server role is already installed on this computer. :  
 The Hub Transport server role is already installed on this computer.
 
  The Mailbox server role is already installed on this computer. :  
 The Mailbox server role is already installed on this computer.
 
  The Unified Messaging server role cannot be removed. Error: Unexpected error [0xFA764A79] while executing command 'Remove-UMPublishingPoint -whatif'. :  
 The Unified Messaging server role cannot be removed. Error: Unexpected error [0xFA764A79] while executing command 'Remove-UMPublishingPoint -whatif'.
  Tell me more about this issue and how to resolve it.  
 
  The Unified Messaging server role is not installed on this computer. :  
 The Unified Messaging server role is not installed on this computer.
 
  This computer is configured as a source transport server for 1 connector(s) in the organization. These must be moved or deleted before Setup can continue. :  
 This computer is configured as a source transport server for 1 connector(s) in the organization. These must be moved or deleted before Setup can continue.
  Tell me more about this issue and how to resolve it.  
 
  This computer requires Windows Media Audio Voice Codec. Install the Desktop-Experience component via Server Manager. :  
 This computer requires Windows Media Audio Voice Codec. Install the Desktop-Experience component via Server Manager.
  Tell me more about this issue and how to resolve it.  
 
  This computer requires Windows Media Encoder. Install the Desktop-Experience component via Server Manager. :  
 This computer requires Windows Media Encoder. Install the Desktop-Experience component via Server Manager.
  Tell me more about this issue and how to resolve it.  
_______________________________________________________________

I'm third party IT support, so there is no telling what has been done on this server.
There is no need for the Unified Messaging role to be installed, and obviously the Edge Transport role can't be installed, and I don't need clustering set up.
Hub, Client Access, and Mailbox roles are already on this server.
To me it looks as though Exchange setup is hung trying to install every server role and I haven't found a way to "reset" the installation.
I've tried the command line unattended uninstalls and it says edge and unified are not installed and fails out with a similarly long error like the one above when trying to uninstall the hub,ca, or um roles.
This is preventing any uninstalls or installs.
I'm trying to avoid completely bombing and reloading this server.
Any ideas?
0
Comment
Question by:tconkle
  • 4
  • 4
  • 2
10 Comments
 
LVL 65

Expert Comment

by:Mestha
Comment Utility
A rebuild is what I would be looking at, probably using the recoverserver switch - ie so the machine is just wiped as it stands (after removing the data and logs) then reinstalled as if the server had gone bang.

If you reboot the system, what happens?
What does the best practises tool in the toolbox say?
Is Exchange actually running?

Simon.
0
 
LVL 3

Accepted Solution

by:
RandyReichert earned 500 total points
Comment Utility
I would reload the server. Not know what has been done to this install of exchange will only cause you problems down the road. Just installing an RU can be a nightmare if everything isn't set correctly.
0
 

Author Comment

by:tconkle
Comment Utility
Well, heres the thing, exchange is receiving and sending mail fine.
The issue arose when owa stopped working.  After troubleshooting that for a while, I figured to do a reinstall of the CAS, which is when I came across those errors....
So, if I didn't need to reinstall any of the roles, I'd be fine....as far as I can tell from the BPA all the issues are related to the failed install of all the roles.

Does the exchange setup check against some registry settings to see what has been tried it the past and failed?
0
 
LVL 3

Assisted Solution

by:RandyReichert
RandyReichert earned 500 total points
Comment Utility
I have found...especially during the install of RU7, that when an installation appears to hang, it is because most of the exchange related services were shutdown and some even disabled and now they can't be restarted by the installation. While the installation is hanging, I go in and restart and re-enable all of these services and then the installation goes on normally.

In your case I'm not sure that this will help. What happened right before OWA stopped working? Server reboot? Update Install?

I don't know about the registry.
0
 

Author Comment

by:tconkle
Comment Utility
I'm not sure how you knew I was trying to install RU7 but I did realize it was taking an extreme amount of time and a lot of exchange and iis services where disabled. Maybe you gots some of that ESPN stuff.
Anyways...I'm trying it again now, I update with how that goes.

As far as when owa went down, the company IT guy claims it went down in mid march., but I see an owa patch log file listed in C:\ExchangeSetupLogs. from that I get:
Updating OWA to version 8.1.340.0
there were no errors in that log file.

I did just see that there is a EdgeTransport process running...does the hub transport service use that process, or could that be part of the issue?
0
Are end users causing IT problems again?

You’ve taken the time to design and update all your end user’s email signatures, only to find out they’re messing up the HTML, changing the font and ruining the imagery. What can you do to prevent this? Find out how you can save your signatures from end users today.

 
LVL 3

Expert Comment

by:RandyReichert
Comment Utility
I just did the RU7 update last week. I read plenty of posts about different troubles people were having and came up with a install solution. And got lucky...lol. I have an EdgeSync service running on my machine. Not sure if that is the same one you have.

Here is a good link:  http://social.technet.microsoft.com/Forums/en-US/exchangesoftwareupdate/threads/
0
 

Author Comment

by:tconkle
Comment Utility
ok, The more I read about other's issues I'm thinking maybe RU 6 broke owa and started this whole mess....can I jump from 5 to 7? or do the RUs build on each other?
0
 
LVL 65

Expert Comment

by:Mestha
Comment Utility
The rollups up cumulative. You could go from SP1 straight to RU7 if you wished.

Simon.
0
 

Author Comment

by:tconkle
Comment Utility
Ok....taking 6 off fixed the ExBPA issues which will allow me to reinstall the CAS role.
I'm going to try RU7 one more time which the hopes that it will fix the OWA issue.

Thanks Randy for getting me pointed in the right direction and reading my mind about the RU7 :)
0
 
LVL 3

Expert Comment

by:RandyReichert
Comment Utility
Glad you got it fixed. Feel free to contact me at anytime if you have anymore questions.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Resolve DNS query failed errors for Exchange
Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now