Configuring Dual NICs in a Windows Server 2003 machine - network has no internet!

Intro: I am running a Windows 2003 server with Dual NICs, the RAID controller recently gave up the ghost and a new motherboard and NICs have been put into the server. I somehow had this server working with the assigned IP addresses (I configured this a few years back), but I can no longer make it work. I can't remember what my gateway or DNS settings were, but I'll list what I have them set as now.

Physical Network Layout: Modem -> Router -> Server WAN NIC -> Server LAN NIC -> Network

WAN NIC:
IP: 192.168.3.1
SM: 255.255.255.0
Gateway: 192.168.3.40
DNS:
192.168.0.1

LAN NIC:
IP: 192.168.0.1
SM: 255.255.255.0
DNS:
192.168.0.1

Issue: Internal network has no internet connection.
The server connects to the internet fine, DHCP is working (configured on the server) and the network can connect to everything internally. I just deleted the DNS records and attempted to reconfigure, but I can't remember how I set this up originally. The only host record is the 192.168.0.1 IP address, and it is set to forward to the ISPs name servers. I ran the auto internet connection wizard in Server Management and set the DNS servers to the ISP's naming servers. I also have the ISPs name servers set in the router. If I ping the .3.1 address from within the network, I get a reply - destination host unreachable.

Desired Result: I'd like the internal network to have internet, and the LAN nic on the server to stay configured to the 192.168.0.1 IP address. I don't care what the IP address of the WAN nic and the gateway are, so long as it works. I did have it working before with these IP addresses - but again - I don't know what I set where to make it work.

Thanks for any assistance provided! :)
EleytheriaAsked:
Who is Participating?
 
Rob WilliamsConnect With a Mentor Commented:
I assume this is not Small Business Server 2003? If so please advise as the methodology is quite different.

Your configurations should work, so long as DNS is configured correctly, but you need to first enable RRAS. When doing so just enable LAN routing. You shouldn't have to configure anything within RRAS as the neighboring subnets are known as is the default gateway.
0
 
ajeabCommented:
are u set this server as proxy server as well?  if not, what you can do is 2 ways

1. set router IP to one of your internal network and set gateway on LAN interface to router IP. then modify DHCP to issue new gateway.

2.  if you want to keep your layout.  change WAN NIC dns to ISP DNS.  
     set DCHP to provide gateway to 192.168.0.1 and  DNS 192.168.0.1. Also, on server configure DNS to forward unknow to ISP as well
0
 
EleytheriaAuthor Commented:
...no proxy setup.

1. I attempted setting the WAN nic to .0.39 and the gateway to 0.40, destination host is still unreachable in the internal network and no internet. -the gateway is a static address on the router.

2. The DNS is already configured to forward unknowns to the ISP. I tried configuring the WAN to the ISPs DNS...also no luck.
I'm not sure what you mean by set the DHCP to provide a gateway to 192.168.0.1?
0
NEW Internet Security Report Now Available!

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out this quarters report on the threats that shook the industry in Q4 2017.

 
ajeabCommented:
then you don't need 2nd nic.  you can set user to go directly to router for internet.  here what to do
1. change router IP from 192.168.3.40 to 192.168.0.x.(example 2)  then disable WAN NIC or disconnect cable.
2. on server LAN NIC set gateway to 192.168.0.2 DNS is 192.168.0.1
2. modify DHCP option 3 to 192.168.0.2 and option 6(DNS) to 192.168.0.1 (assume you have DNS setting correctly to forward)
0
 
EleytheriaAuthor Commented:
RRAS, of course, I'm such a goof. ;p Thanks!
0
 
Rob WilliamsCommented:
Thanks Eleytheria.
Cheers!
--Rob
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.