We help IT Professionals succeed at work.

How do I access local sites thru Apache server from my internally networked laptop

304 Views
Last Modified: 2012-05-06
My Apache 2 server is installed on a W2K machine and is set up to listen at port 8080.  I've been using it for months and works fine when accessing local sites on that machine.  I now would like to access the same sites from a networked machine that is using a wireless connection.  This new machine is a laptop running XP.  

I am able to access the server itself, i.e. I can get to Apache's "test" page.  And I can run php files from the Apache root directory.  But I can't serve up the sites -- these sites are served up fine when I access them from the machine on which the Apache server is installed.  Therefore, the virtual hosts are properly set up for use within that machine.

So, I can get to the Apache server, but cannot access any virtual hosts.  It just can't make that final leap.  I've tried numerous things all to no avail.  My gut says it's something simple, but I'm stuck.

Help would be greatly appreciated.  Thanks,

Margaret
Comment
Watch Question

This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Thank you for getting back with your suggestion.  I tried updating DNS server but with no success (see below for details.)

Here's some more info on how my machines are set up:
W2K machine:
-- Hosts file associates sites to 127.0.0.1
-- Apache 2 Server: httpd.conf contains virtual server definitiions.  Here is one of my virtual server definitions:  
########################################### cuc:8080 #########################
<VirtualHost 127.0.0.1:8080>
    ServerName cuc
    DocumentRoot "E:/Eclipse Workspace/drupal"
    Alias /phpmyadmin       "E:/Program Files/phpMyAdmin"
    <Directory "E:/Program Files/phpMyAdmin">
      Options None
      AllowOverride None
      Order allow,deny
      Allow from 127.0.0.1
    </Directory>
    <Directory "E:/Eclipse Workspace/drupal">
      AllowOverride All
      Order Deny,Allow
      Deny from All
      Allow from 127.0.0.1
      Allow from 192.168.1.1
      Allow from 192.168.1.2
      Allow from 192.168.1.6
    </Directory>
    CustomLog logs\cuc-access.log common
    ErrorLog logs\cuc-error.log
</VirtualHost>

On the XP machine:
Host file has "cuc" associated with 192.168.1.2 (the W2K mahine)

On my W2K machine, entering "http://cuc:8080" in a browser takes me to the site (also located on W2K)
On my XP laptop, entering "http://cuc:8080" takes me to the root of the apache server, but I can't get any further.

I updated the DNS server with an entry for "cuc" pointing to W2K's IP address (192.168.1.2).  It did not change anything, tho.  I tried pointing it to localhost (127.0.0.1) but also to no avail.  Since I also have IIS on the W2K, I've told Apache server to listen on port 8080.  Therefore, I append my site names with ":8080".

I've set things up to work okay locally on W2K PC, but perhaps not for networked machines??

Let me know if you need any other info.  Thank you so much for your help.




 
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Awesome!
That was it.  A million thanks.
CERTIFIED EXPERT

Commented:
Accept his answer then!
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.