Windows Server 2008 64bit failed Updates

I am running Automatic Updates and I receive an error when trying to install update KB955706 "Update for Windows Server 2003 and Windows Server 2008 for x64-based Systems." with error code 643.

Resolution for me will be either this update installed or it no longer prompting me to install it.
update-error.jpg
update-error2.jpg
LrdKanienAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kentrix70Commented:
You should make sure your SQL server service is up and running, while you are installing this update,
or it will fail and try again, over and over again.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LrdKanienAuthor Commented:
SQL Server is not installed on this machine, neither is any form of SQL such as SQL Express, SQL Server, SQL anything.

The only database installed on this "Web Server" is Windows Internal Database, which is used for Resource Monitor.  I believe you are confusing this update with another update by the same KB#, but differen't name.  Possible?
0
Kentrix70Commented:
You are absolutely right. Sorry about that.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

Kentrix70Commented:
What happens if you download the file manually (not through windows update) and installs it?
0
LrdKanienAuthor Commented:
Log Name:      Application
Source:        MsiInstaller
Date:          4/2/2009 3:33:44 PM
Event ID:      10005
Task Category: None
Level:         Error
Keywords:      Classic
User:          ABACUS-CORP\davidf
Computer:      nthost1.abacus-winhost.com
Description:
Product: Windows Internal Database -- Error 29528. The setup has encountered an unexpected error while Setting Internal Properties. The error is: Fatal error during installation.

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="MsiInstaller" />
    <EventID Qualifiers="0">10005</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2009-04-02T22:33:44.000Z" />
    <EventRecordID>210051</EventRecordID>
    <Channel>Application</Channel>
    <Computer>nthost1.abacus-winhost.com</Computer>
    <Security UserID="S-1-5-21-1220945662-484763869-839522115-2973" />
  </System>
  <EventData>
    <Data>Product: Windows Internal Database -- Error 29528. The setup has encountered an unexpected error while Setting Internal Properties. The error is: Fatal error during installation.
</Data>
    <Data>(NULL)</Data>
    <Data>(NULL)</Data>
    <Data>(NULL)</Data>
    <Data>(NULL)</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Binary>7B43454235373830462D314137302D343441392D383530462D4445364334463641413846427D</Binary>
  </EventData>
</Event>
0
Kentrix70Commented:
What happens, if you stop Windows Internal Database, while you running the hotfix?
Same reaction?
0
LrdKanienAuthor Commented:
The service Windows INternal Database is stopped.  If I start it or stop it I get the same error.  If I try and remove WID from command line with

msiexec /x {BDD79957-5801-4A2D-B09E-852E7FA64D01} callerid=ocsetup.exe

it fails as well
0
Kentrix70Commented:
I think the error is related to the problem with your Windows Internal Database.
Do you have a backup of the database?
Please let me know. I have a suggestion for, how to remove the db
and make a fresh install, but the solution depends on how important
your existing data is.
0
LrdKanienAuthor Commented:
I have backups of the server.  I run ntbackup for full backups and system state backups.  I believe the WID is only used for Resource Monitor and I have no important data.
0
Kentrix70Commented:
You should use this utility:

http://support.microsoft.com/?scid=kb%3Ben-us%3B290301&x=11&y=13

to remove the "memory" of the WID.
Then you can delete or rename the folder, with the databases in.
You may also want to cleanup entries in the registry regarding the
WID before you proceed.

You should then make a fresh install of the WID.
I think that would do the trick.
0
LrdKanienAuthor Commented:
where is the folder that I should rename? and what registry keys?
0
Kentrix70Commented:
if you search your harddisk for files with the extension .mdf or/and .ldf,
you should be able to locate the folder/folders where the db resides.

I think you should leave the registry for now, and just rename/delete the db-folders
0
LrdKanienAuthor Commented:
I removed the WID using that tool, however the WID service still exists and can be controlled.

The update still fails on install and there were no mdf or ldf files on the boot volume.
0
Kentrix70Commented:
After you have removed the WID using the tool, it is not actually removed, you have just deletede Windows "memory" of the application.
That means, you should install the product again, and it should behave like, the application has not been installed before.
0
LrdKanienAuthor Commented:
Install it from where?
0
Kentrix70Commented:
Install it with the MSI-package that you installed it with in the first place.
Maybe you have a cd - or maybe you download it from the internet.
0
LrdKanienAuthor Commented:
Not much help my friend.  Please refrain from attempting to help with 2 liners that give no solid advice.

The WID is installed by default, thus I don't have a MSI to install it from and I don't plan on reinstalling the OS to reinstall the WID, nor do I know how to specify just the WID from the CD.  If you don't know either, then I'll find help elsewhere.

An example solution would be, download the MSI here: www.blah.com and run this comand MSIEXEC downloaded msi /switches.

See how that works?^?^
0
Kentrix70Commented:
I am sorry.
I will try to be more specific.
It turns out that the WID is not published as a standalone application.

Please check this link providing information about what the WID is.

http://en.wikipedia.org/wiki/Windows_Internal_Database

As you mentioned earlier the WID are installed together with the resource manager.

Have you tried to uninstall the resource manager and then install it again.

You should do that through the server manager, choosing the remove feature wizard.

once you have successfully removed the resource manager, you should use the server manager
to add the feature again, this time through the add feature wizard, choosing to install the resource manager.
0
LrdKanienAuthor Commented:
Thanks for the reply, here is what I did.

1.  used the office uninstaller to "remove" the WID.
2.  uninstalled the Resouce manager through features.  required reboot.
3.  tried to do the update, failed.
4.  reinstalled the Resource manager through feature.
5.  tried to do the update, failed.

Thanks for the detailed reply, just no luck.  Bleh.
0
Kentrix70Commented:
When you reinstalled the Resource manager, did you choose to install the WID,
or were you given the choice to do that?
When the WID is installed again, you might get lucky.
I don't think you can install the update without a working WID.

0
LrdKanienAuthor Commented:
No it selected it automatically.

No luck on this one.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.