Solved

SBS 2003 - HTTP redirect not working & OMA not syncing with WM6 device

Posted on 2009-04-02
7
645 Views
Last Modified: 2013-12-05
I'm having two problems with a client's SBS 2003 machine, and try as I might I'm not having any luck resolving them. I'm hoping someone here can help out.

This SBS 2003 box was pretty messed up when I started on it. The person who set it up didn't understand how SBS works, so he simply installed the first part, then manually installed Exchange. When I started working on it, most of the SBS IIS functionality wasn't working (no monitoring, RWW, backups, companyweb, etc.). However, OWA and OMA were working correctly. I've spent a fair amount of time on it and I've managed to get everything working really well without having to re-install Exchange (which I'm trying very hard to avoid), except for these two issues:

1) normally when an SBS 2003 installation finishes correctly, HTTP: address requests to the server for OWA and RWW (and I think OMA, though this is the first time I've worked with OMA) automatically redirect to HTTPS. I read on another EE thread that this is supposed to be configured automatically by CEICW, but it is not working on this machine and I have had no success finding a way (including the CEICW) to make it work. When I try to access an HTTP address for this server for any of the exchange services or RWW, I get a "page not found" error. HTTPS works great. This behavior is the same internally or externally. I'd really like to get this function working again.

2) one of the client's Windows Mobile 6.1 device was able to synchronize mail & whatnot with this server before I repaired the other issues, but now now matter what I  try, I cannot get it to sync. I've tried recreating teh Exchange virtual directories, recreating the "exchange-oma" vdir, messing with SSL configurations and pretty much every KB procedure and solution I've found on EE and MSExchangeBlog.com and petri.co.il and a few other sites, but still no success. There are no errors recorded in the event logs when I try to access, it just says "error authorizing" on the phone and that's it.

I was able at one point to get OMA to load in a web browser via "https://servername/oma" and I could see mail and calendar items, but that was broken again when I continued to try resolving this issue by changing SSL settings. it is my understanding that OMA is supposed to be accessible via "http://servername/oma", not the secure address, but this simply gives a 404 error.

At this point I've spent a number of (unpaid) hours on this and gotten nowhere. I'm afraid to keep messing with things, especially the certificate and SSL settings, as the lone Mac on the network had some trouble sending mail through the server at one point, citing a certificate error. I suspect the OMA problem is related to the apparently well known conflict between OWA needing SSL and OMA requiring basic authentication only, and I'm hoping that by fixing the redirect issue that it will somehow magically resolve the problem.

I'd greatly appreciate any guidance or empirical wisdom from someone who's resolved this type of issue before. I don't know if there's some type of EAS logging that happens in WM6 that might help, but I know I'm not finding much useful info on the server itself. If I have to, I will re-install Exchange, but I'd very very much like to avoid this, as I can see that being a can of worms if something goes wrong.
0
Comment
Question by:spudboy23
  • 3
  • 2
  • 2
7 Comments
 
LVL 6

Expert Comment

by:JerrytheGreat
ID: 24056249
It may seem like a personal failure to do this, but I would seriously consider this:
 
1. Get the keys to the building, a good book, and order Pizza.
2. Export all exchange mailboxes to PST, all usernames and passwords, and format- and reinstall the SBS the right way.  
Even if you get everyting kinda-working, you'll have a mess on your hands any time you need to fix something in the future.
 
0
 
LVL 5

Expert Comment

by:LinkNJ
ID: 24056722
I was too afraid to say the same thing so thanks to JerrytheGreat leading the way.  I have attempted to do this with two new clients in the past 3 years that had botched SBS installs.  The first one I ended up doing the reinstall after 1 year of messing around with everything.  Ironically enough, similar to your #2, the final straw was when I could not get a mobile phone to sync after a SSL certificate install.  The second time around, I was honest with the client and told them that SBS needs to be installed from the beginning a certain way and our best plan was to reinstall after the first month of working wtih them.  Perhaps I just don't know enough to work through the problems, but both these clients have been happy for years now.  Just wanted to share some experience as I know this is no kind of solution that you were looking for.  Best of luck to you, Rob.
0
 
LVL 6

Expert Comment

by:JerrytheGreat
ID: 24060002
I have also been-there, and done that, and if I could have done it again, I would take my advice--I would not have to have eaten so much labor, and the client would have a more stable environment--the one thing I never fixed was RPC-HTTP.  Everything else is working, but I hit my wall there after about 10 hours of work (and billing for 5).
--JTG
0
Shouldn't all users have the same email signature?

You wouldn't let your users design their own business cards, would you? So, why do you let them design their own email signatures? Think of the damage they could be doing to your brand reputation! Choose the easy way to manage set up and add email signatures for all users.

 

Author Comment

by:spudboy23
ID: 24062192
hmmm, I was afraid that might be where this is going. Fortunately, there are only 4 users and they don't use the sharepoint at all, so it won't be that difficult too difficult to get things back together after a complete re-install. I'm not looking forward to it by any means, but I suspect this will probably be the best route to take overall.

I'm going to leave this open for a couple of weeks to see if anyone can offer any other suggestions that might avoid the full reinstall. I'm going on vacation and won't have time to do the re-install until after I return anyway. I'll keep an eye on this thread and I'll award points when I've resolved it one way or another.
0
 
LVL 5

Expert Comment

by:LinkNJ
ID: 24072099
Well, if you wanted to play with it some more, you could try the following from Microsoft.  It is an article on how to reset the virtual directories for Exchange.  Good luck, Rob.
 http://support.microsoft.com/default.aspx?kbid=883380
 
0
 

Author Comment

by:spudboy23
ID: 24081278
I've already tried that a few times, but thanks for the suggestion. I ended up re-installing exchange in a last-ditch effort to get it fixed without having to fully re-install. Interestingly, it fixed the OMA sync with MY phone, but not the client's. I think that's progress, as mine wouldn't sync either before the re-install, but I won't know until I can work with the client's phone and see if I can get it to work. That should happen tomorrow.

The redirect still doesn't work, though. It's easy enough to get around but it's also nice to have when it does work.
0
 

Accepted Solution

by:
spudboy23 earned 0 total points
ID: 24238671
so, I was able to get the client's phone working finally. I'm not exactly sure how I did it; I just kept messing with the settings until I was able to get it to work, and I was on the verge of giving up and doing the SBS reinstall when it started to sync correctly.

I think setting up to use SSL was the necessary step to making it work with this particular installation. I did import the certificate of the SBS server into the phone, using a method I found on some forum somewhere when the "SPAddCert.exe" method on petri.co.il didn't work. (I just had to double-click on the .cer file in WM6 and it installed for me, no .exe required.) After that I turned SSL back on, which was the final thing that made it work (I think). I had been trying to set it up w/out SSL before.

I still have to do the client's wife's iPhone, but I think that should be fairly simple now that the WM6 phone is working.
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup". After a while, you have entered a loop for Auto repair which does not fix anything and you will be in a  panic as all your work w…
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now