Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Windows 2008- iSCSI does not automatically connect to targets after reboot

Posted on 2009-04-03
2
Medium Priority
?
1,158 Views
Last Modified: 2012-05-06
I have 2 Windows 2008 servers that are configured in a cluster using iSCSI disks.  The iSCSI initiator is configured to Automatically connect to the targets after a reboot.  

I am trying to test failover and it works successfully.  i.e. I reboot the 1st node and the 2nd node takes over.  However, after 1st node comes back up, iSCSI does not reconnect to the targets.  

All the validation tests pass just fine.
0
Comment
Question by:Florescu
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 

Accepted Solution

by:
Florescu earned 0 total points
ID: 24197232
I figured it out.  I had to go to the iSCSI Initiator, Targets tab, then click on Logon.  Check the automatically restore and enable multi path.  Then I had to go to Advanced   I selected the iSCSI Initator as the Local Adapter and the Source IP to be the 1st iSCSI NIC ip address.  

I repeated the process for the 2nd iSCSI NIC by clicking on the target again (even though it says Connected) and logging on to the target but this time going to Advanced and selecting the 2nd iSCSI NIC.  I still had to select automatically reconnect and multipath IO.  

The reason it was happening is because the iSCSI SAN was only setup to accept connections from certain IPs.  I looked in the Event viewer on the SAN and I noticed that as the server was rebooting, it was trying to connect via the Local Area connection, instead of the ISCSI NICs.  Once I followed the above steps, it started working just fine.

You only have to select Automatically reconnect the 1st time you logon to the target with an ip address.  You don't need to do it after that because it will establish multiple sessions to the same target and that's unneeded.  I had a bunch of sessions that were established so I had to remove those from the Favorites tab, log off all of the other sessions, then start from scratch and logon as outlined above.

For some reason the Multpath IO was not configured right either.  I had to go to Control Panel, Multipath IO and add add an MPIO end device as EQLOGIC 100E-00.  
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You might have come across a situation when you have Exchange 2013 server in two different sites (Production and DR). After adding the Database copy in ECP console it displays Database copy status unknown for the DR exchange server. Issue is strange…
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question