Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17


Where is the Notes Client User Preferences stored?

Posted on 2009-04-03
Medium Priority
Last Modified: 2013-11-16
Hi Experts!

Here is something new that I have not anticipated! For those of you that helped me with this ticket (, I find now after fixing the server problem, some other strange issues are starting to show.  One of the weirdest one is that some users can no longer open the "User Preferences" settings. They get the annoying error "Public key does not macth....". Same error when they try open the Archive preferences as well.  To fix this, we needed to basically create a new personal names.nsf, copy the documents (contacts, locations, and connections) from one database to another, then delete the old names.nsf and use the recently created one. That is very tedious as you need to trick the Notes Client and is very confussing for the support team.

It seems to me that preferences/archive settings pop-up windows were somehow signed with the old and therefore could not be opened.  The question to you guys is:

Where is the information stored about your preferences and archive settings stored? Is it in the bookmark.nsf?  Desktop? or names.nsf? I have opend the profiles for each and removed them. Still the problem persists. I am not sure what else to do? We have over 100 users affected and I hate to having to recreate names.nsf in every desktop!

Thank you!
Question by:JoseZald
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +1

Expert Comment

ID: 24061082
I'm not 100% sure here, but I would suspect all preferences are stored in the "desktop*.ndk" file in the data directory.  Then again, that "notes.ini" file contains a great many pointers and preferences.  Try the "notes.ini" file first, then shoot for the "desktop.ndk".  Good luck.

Author Comment

ID: 24061170
@ironclads. Thanks. I tried removing desktop.ndk, bookmark.nsf but all lingers in the names.nsf. Recreating a new DSK or bookmark.nsf does not fix it. They only thing I noticed that fixed it was recreating the personal names.nsf. It just does not make much sense.  I will wait to see if someone else has thoughts on this.

Very much appreciated!
LVL 20

Accepted Solution

brwwiggins earned 1500 total points
ID: 24061207
It's going to depend on the preference. Some preferences like calendar color settings and archive profile settings are stored in profile documents in each user's database.

Other local client settings are stored in the notes.ini. The location, cross certificates, ports, replication and LDAP account info is in the names.nsf . Bookmark.nsf and desktop*.ndk hold bookmarks and local cache.

Info such as cross certification, public keys, private keys, etc are stored in the user's ID file.
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

LVL 46

Expert Comment

by:Sjef Bosman
ID: 24061712
The preferences are indeed to be found in many places, sometimes for hysterical reasons but mainly because they are at their most logical place.

Let's focus on the error. It is not normal at all that you have 100 users with the same error, but in this case it's a consequence of recertifying the whole environment. Your server is of a new organisation but your users may still belong to the old organisation. Many parts of the environment will also be "old". What you assume is tricking Notes, it is not: you have an old and a new one, both with the same name but entirely different inside! YOU know that both organisations are the same, but Notes doesn't. And right it is! For it would otherwise be awfully easy to create a fake server and mimic your organisation. Breaking in would be easy.

You just have to finish the recertification process and indeed, you have to recertify a lot. If SysExpert's link doesn't help, read this:

Author Comment

ID: 24061985
@sjef_bosman, thanks. I will do a bit more investigation and report back. I agree with you with your comments about naming.  I will test re-certifying the users that were already certify with old ID to see if this issue goes away.

LVL 46

Expert Comment

by:Sjef Bosman
ID: 24064827

Featured Post


Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You’ve got a lotus Domino web server, and you have been told that “leverage browser caching” is a must do. This means that we have to tell the browser everywhere in the web to use cache. In other words, we set (and send) an expiration date in the HT…
IBM Notes offer Encryption feature using which the user can secure its NSF emails or entire database easily. In this section we will discuss about the process to Encrypt Incoming and Outgoing Mails in depth.
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question