Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4207
  • Last Modified:

Disabling Hyperlink Warning Message in PowerPoint 2007

Hello,
I am running PowerPoint 2007 and I want to include a hyperlink to a local Flash swf file.  I know that I can embed Flash movies in PowerPoint and I have done this many times.  But, for this presentation, I need to use a button in my PowerPoint slide that will open the Flash movie in a new swf player window.  This works fine, except that I can't get rid of the warning that pops up before the movie window opens.  The Microsoft Office warning box says:
"Some files can contain viruses or otherwise be harmful.....etc..   Would you like to open this file?"

I have seen the Microsoft Support solution for disabling this warning box  (http://support.microsoft.com/kb/925757)
And I have tried the suggestions indicated in this Knowledge Base report.  But, I am still getting the warning message.  

I believe there was an earlier similiar question posted on Experts-Exchange, but it also offered only the same suggestions as indicated in the Microsoft Knowledge Base report.

Any other ideas on how I can disable this message from appearing whenever I use a hyperlink button in a PowerPoint slide to open a swf file?
Thanks,
Stephen
0
sjp060497
Asked:
sjp060497
  • 3
  • 2
  • 2
1 Solution
 
DIIRECommented:
The registry edits in that KB article doesn't work for me either unless Windows Media Player is the default player.

If you use Winamp to play .swf files you can add the EditFlags entry to HKEY_CLASSES_ROOT\Winamp.File.SWF

Depending on the software your using to play them look for an entry in HKEY_CLASSES_ROOT with the swf as per above or just use winamp.  Add the EditFlags with value 10000 and you shouldn't be prompted anymore.


0
 
sjp060497Author Commented:
Hello Dire,
Thank you for your suggestion.  It makes sense, but I haven't been able to apply it to my situation.  I use a small swf player called "Swiff Player."  (http://www.globfx.com/products/swfplayer/).  I haven't been able to find any EditFlags entry to it in the HKEY_CLASSES_ROOT directory in the registry.  
Any ideas?
Thanks,
Stephen
0
 
GlennaShawCommented:
Move your SWF file to a trusted location:
http://office.microsoft.com/en-us/powerpoint/HA100319991033.aspx
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
sjp060497Author Commented:
Hi Glenna Shaw...
Thank you also for the suggestion.  I did try this option earlier....and I just tried it again by creating a different "Trusted Location" (in case made a mistake the earlier time).    But no luck.  I still get the same Microsoft Office warning box.  
0
 
GlennaShawCommented:
I'd go back to the http://support.microsoft.com/kb/925757 article and try it step by step again.
0
 
DIIRECommented:
The EditFlag entry wont be there - you will need to add it.

Go to HKEY_CLASSES_ROOT\ShockwaveFlash.ShickwaveFlash

Right click > select New > DWORD Value >  Make the name EditFlags
Double click - make value 10000 - Leave it as hexidecimal.

This will get rid of the warning for .swf files only.
0
 
sjp060497Author Commented:
Thanks Dire!!!  
That did it.  It works perfectly.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now