• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 697
  • Last Modified:

Standby Continuous Replication Exchange 2007 error

Morning - We have a 2003 AD structure and 2 member servers with Exchange 2007 SP2.  One has 2008 on it as the OS.  When I submit this command to the Management shell to implement SCR on the second server (whether I include the database name or not after the servername as 1 post suggested) I get this error- (names have been changed to protect the innocent ;-)

[PS] C:\Windows\System32>Enable-StorageGroupCopy -identity [Win2008/2007_servername] -standbymachine [Win2003/2007_Servername

Enable-StorageGroupCopy : The operation could not be performed because object '
[2007_servername] ' could not be found on domain controller '2003_AD_Server.domain.com'.
At line:1 char:24
+ Enable-StorageGroupCopy  <<<< -identity [2007_servername] -standbymachine [2nd-2007_servername] [PS] C:\Windows\System32>

The servers are part of the Domain and are listed in Active Directory.  I am wondering if I need to upgrade the AD to windows 2008 although neither of these servers will be DCs.  Thanks in advance.
0
sfeder11554
Asked:
sfeder11554
  • 4
  • 2
  • 2
  • +1
1 Solution
 
Stephen CroftTechnical ArchitectCommented:
when you are specifying 2007_servername, are you using the full domain name (i.e. server.domain.local) and not just the short name?

if you do a get-Exchangeserver, what is listed?
0
 
Stephen CroftTechnical ArchitectCommented:
BTW, if you can get-exchangeserver NAMEOFSERVER, do;

get-exchangeserver NAMEOFSERVER | enable-storagegroupcopy -standbymachine BACKUPSERVER

the Pipe will pass on the Exchange server name (in its required format also) to enable-storagegroupcopy.


0
 
madhuskCommented:
You can use the following command to enable the SCR on second machine.

Enable-StorageGroupCopy 2k7_exchange\STG StandbyMachine EXchangeSCR

2k7_Exchange is the Exchange name
and STG is the storage group Name
Exchange SCR is the Second Computer in which you want to enable SCR.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell┬« is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
madhuskCommented:
it is

-StandbyMachine
0
 
sfeder11554Author Commented:
Thank you for your quick responses - to update - I can get-servername and it does show up but adding the FQDN did not help - I also did the \storage name but I may not have used it correctly since it is first database.edb.  I added quotes around the entire "fqdn\.edb" name and also tried the folder name w/o success.  Is there a method to change the database name since this may not work with the default name (although that would be odd)?  BTW - the error response is the same.  
0
 
MesthaCommented:
This is the command that I ran to enable it:

Enable-StorageGroupCopy "First Storage Group" -StandbyMachine "TARGET-SERVER" -ReplayLagTime 0.01:00:00

I ran that on the source server itself. You will note that there is no mention of the server in the first part of the command because you are not setting it at the server level, but at the Storage Group Level.

Also note that if the SG contains a public folder store then it cannot be configured to use SCR.

Simon.
0
 
sfeder11554Author Commented:
We are getting closer - different error now with Mestha's suggestion- I am trying to set up SCR - the error now reads error at character 24 (which is the beginning of -identity) and says the error is related to IsNodeClustered.  Remote Registry is started on both servers - the cluster service is not on either box.  Can ping both by name and nslookup resolves correctly.  I have set up a second database and I am moving the 2 test user mailboxes over thinking that the problem might be that the name of the local storage group already exists on the remote server.  Any other comments please post.  Thanks.
0
 
MesthaCommented:
If you look at my command I don't use the -identity switch at all.
The command I posted is an SCR command, it was taken from my notes on a deployment I did a few weeks ago.

Simon.
0
 
sfeder11554Author Commented:
Well I am going to give you the points since your answer resolved the question initially asked so you deserve them - I am still getting the isnodeclustered error but I will post that separately.  Thanks.
0
 
sfeder11554Author Commented:
The solution resolved the initial error by removing the server name and putting the name of the storage group in quotes.  That led to an alternate error regarding the isnodeclustered - but that is for another question.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 4
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now