Solved

Javascript error 'microsoft jscript runtime error'

Posted on 2009-04-03
6
633 Views
Last Modified: 2012-05-06
I am having a ms javascript error when trying to run a service pack installation for a clinical application.  Tried updating java, uninstalling java and reinstalling it without luck.  I've included a print screen of the error and the offending line of code within the javascript file.  
xcelerasp1.JPG
0
Comment
Question by:netfriendsinc
  • 3
  • 2
6 Comments
 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 24062357
Java is different from Javascript and MS' JScript.  Updates to Java won't make a difference here.
How are you trying to run it?  Why are you in Excel and looking at the JS file?  Can you provide details on this app and how it works?  Also do they provide info on how you are suppose to run or apply this Service Pack?
What is your OS?  If you do think the scripting engine needs an update instead of Java you should do the Windows Script.  For XP I believe you'd want http://www.microsoft.com/downloads/details.aspx?familyid=47809025-D896-482E-A0D6-524E7E844D81&displaylang=en .
It is puzzling to see that file in Excel though so I really wonder if the process just isn't being done right.  It would definitely explain the error.
Let me know if you have a question about any of this.
bol
0
 

Author Comment

by:netfriendsinc
ID: 24062773
The application is installed from a network share (i've also tried running it locally) via an exe file; once the main application is installed, which went smoothly, SP1 is then run.  It is launched via an exe file, apparently it then copies files to the %username% directory under local setttings/temp and launches a ms jscript which continues the sp1 install.  I opened it in excel so i could see which was line 1103 which was having the error (as opposed to notepad which didnt tell me line numbers).  The company, Philips Medical provides instructions for installation and I have followed them to the tee.  After installing this app on over 70 workstations, I have noticed it either installs without a hitch or SP1 brings the entire thing down - a reimage of the computer will allow the install to go smoothly however.  I've also taken everything out of startuip, disabled services (not MS services) and tried the install again with the same results.  Philips Technical support says to reinstall the OS (which is Windows XP SP2).  

Again, i have it in excel so i could see the line which was causing the error, not to run it.  the file is a *.js file.above link actually fixed that error however, there is now a new error which I'm not sure if you can help with but I am attaching the screenshot of the new error and the js script (change ext to .js).
installSP1.js.jpg
xcelera2.JPG
0
 
LVL 54

Accepted Solution

by:
b0lsc0tt earned 500 total points
ID: 24063487
FYI:  When you post a file that has text like a JS file just add the .txt extension to it.  In the future EE will allow uploading .JS files but in the meantime the .txt extension will work better the .jpg.
The new error you are getting seems to be an issue with the install.  The error is cause by the line below failing:
    var myPrgDlg = new ActiveXObject("Progress.ScriptUI");
It could be caused by a missing DLL (from the install I believe) called ProgressBar.dll or just a problem when the install script tries to register it (done on line 89).
Are you running this as a user with administrative rights?  Are all programs closed as you try to do this?  You might try a restart of the computer and then try again to see if that helps.
If you are doing or have tried all of those then the tech support will be who you want to contact.  A "reinstall the OS" suggestion should probably be laughed at and responded to with "let me talk to next person in the 'food-chain'."  The answer should be simpler than that.  An older version of the JS file that doesn't have the progressbar code, which is really just a "pretty" thing and not usually required for success of the process, could be an answer.  Also it may just be a bad install "package" that doesn't have that DLL.
Hopefully the issue will be one of those few things I asked and suggested.  I am glad updating or installing wscript fixed the problem you had originally.  You might want to ask them to find out if there is a version of it their scripts require or which is used when developing.  It would've saved you some time had they just been able to say you need to update Wscript.
Let me know if you have a question about any this.
bol
0
 

Author Comment

by:netfriendsinc
ID: 24076924
sc0tt

thanks for your reply.  Previously I had disabled all startup files by using msconfig, as well as all non-essential services (leaving all the MS services enabled), without any success.  I do have administrative rights; I've tried using a domain admin account and a local admin account of which neither had any effect on the install.  Yes, the re-image the OS is laughable, I'll try and see if I can dig a little further on this with their helpdesk - I call it the 'unhelpful desk' lol.  sigh.  Thanks for your time, i'll leave this question open for a bit just in case.  


0
 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 24993162
I just wanted to check on the status of this.  Let me know if you need any more help with it or have a question about closing this.  I am glad I could help and it seems this was fixed but let me know if that isn't actually the case.

bol
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

I've been trying to accomplish this for a while and it just struck me yesterday how to accomplish this task. I have done searches all over the internet looking for ways to email pages from my applications and finally I have done it!!! Every single s…
Article by: DanRollins
This article describes a JavaScript program that creates a maze made of hexagonal cells.  In Part 2 (http://www.experts-exchange.com/Programming/Languages/Scripting/JavaScript/A_7850-Hex-Maze-Part-2.html), we'll extend the program by adding a depth-…
The viewer will learn the basics of jQuery, including how to invoke it on a web page. Reference your jQuery libraries: (CODE) Include your new external js/jQuery file: (CODE) Write your first lines of code to setup your site for jQuery.: (CODE)
The viewer will learn the basics of jQuery including how to code hide show and toggles. Reference your jQuery libraries: (CODE) Include your new external js/jQuery file: (CODE) Write your first lines of code to setup your site for jQuery…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now