ldapsearch is not returning result with wildcard search

I have installed openldap 2.2.29 on windows. I cannot get a search result using wildcard search. The same search resturns me correct result with exact search.  
Do I need to change slapd.conf to get results from wildcard search. Please see attached snippet from my command line operation.
I am gettting the same behaviour using JNDI call.

C:\OpenLDAP>ldapsearch -x -b "dc=authdev,dc=com" -s sub "(agjsUserName=ddas)"
# extended LDIF
#
# LDAPv3
# base <dc=authdev,dc=com> with scope sub
# filter: (agjsUserName=ddas)
# requesting: ALL
#
 
# ddas, AUTHDEV.COM
dn: agjsUserName=ddas,dc=AUTHDEV,dc=COM
agjsGroupId: 1
agjsMethod: 1
agjsInserted: 1238713834564
agjsChannel: -none-
agjsUpdated: 1238713834564
agjsStatus: 1
agjsId: 0
agjsChannelType: 0
objectClass: agjsUser
agjsPassword: -none-
agjsUserName: ddas
 
# search result
search: 2
result: 0 Success
 
# numResponses: 2
# numEntries: 1
 
C:\OpenLDAP>ldapsearch -x -b "dc=authdev,dc=com" -s sub "(agjsUserName=dda*)"
# extended LDIF
#
# LDAPv3
# base <dc=authdev,dc=com> with scope sub
# filter: (agjsUserName=dda*)
# requesting: ALL
#
 
# search result
search: 2
result: 0 Success
 
# numResponses: 1

Open in new window

LVL 1
ddas_authAsked:
Who is Participating?
 
ddas_authConnect With a Mentor Author Commented:
It seems ldapsearch is not fuly implemented on the windows version. it is a hackerware anyways.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.