Solved

USB flash drive - partition not recognized

Posted on 2009-04-03
11
933 Views
Last Modified: 2012-05-06
I have an 8Gb Corsair Voyager thumb drive, worked fine for about a year, not a glitch.

One day, out of the blue, unreadable.

Device manager recognizes it as Mass Storage Device / Generic Volume

But Disk Management snap-in says "Disk 1, removable, unreadable".

And in My Computer it shows up as "Removable Disk". When I double-click, it says "please insert disk into drive E:".

So far PC Inspector Smart Recovery, Easy Recovery Pro, Recuva, don't seem to be working. OnTrack Data Recovery Pro, it seems, doesn't do flash drives at all.

I don't really care about the drive - but the data on it was not backed up. That WAS the backup. What are my chances and options to try data recovery?
0
Comment
Question by:Ronino
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
11 Comments
 
LVL 8

Expert Comment

by:MrMintanet
ID: 24062631
http://download.wavepluz.net/pub/GetDataBack.v3.03.013/

GetDataBack for FAT

Free at the above URL.  Not sure how long it will be there, though.
0
 

Author Comment

by:Ronino
ID: 24062660
That is another one that I tried... no luck
0
 
LVL 1

Expert Comment

by:INTPdude
ID: 24062718
Try changing the drive letters. Right click on my computer and go to Manage. Click on Disk Management and you should see your USB drive below. Make sure the drive your clicking on is the right one by comparing size and everything.  Right click on the drive and choose Change driver letter and paths. Then change the drive letter to something else. This will make sure nothing is interfering with the drive read. happens a lot with network drives interfering with the USB drives.
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 8

Expert Comment

by:MrMintanet
ID: 24062940
Get a LiveCD of Knoppix or something.  See if you can get it from there.
0
 
LVL 8

Expert Comment

by:MrMintanet
ID: 24063045
Try it on another computer too.
0
 
LVL 34

Expert Comment

by:Michael-Best
ID: 24063550
Clean USB's contacts with cotton bud & a drop of (alcohol) cleaning fluid .
0
 
LVL 47

Expert Comment

by:noxcho
ID: 24064397
I would also reinstall USB controller drivers. First check the drive on any other PC to see that your USB bus controller is not the problem. If other PCs see your drive well and work with it then you need uninstall USB bus via Device Manager, then restart Windows and let it install them again.
0
 

Author Comment

by:Ronino
ID: 24064704
Thanks guys

I have tried the USB drive on several computers, one of them a brand new laptop. I've also tried other USB drives on my main machine, and they work. [I think that rules out dirty contacts, bad USB bus drivers...]

Will try Knoppix and... changing the drive letter, and will post results.
0
 
LVL 8

Expert Comment

by:MrMintanet
ID: 24064812
Well, being you've tried it on other computers, I'm venturing to bet that it is done, but Knoppix would be the last resort.  It's a different OS entirely, and I've seen it pick things up that Windows just won't see.  Man, I wish you the best.
0
 

Author Comment

by:Ronino
ID: 24070866
Ok, MrMintanet, you are very comforting :) Thank you - and for the suggestions, too. Knoppix couldn't read the drive either.

Any other suggestions, anybody else?

And why would it die / how can I prevent other flash drives from dying? There was no shock / EMP / untimely unplugging from a PC during a file transfer / no formatting... and it was fairly new.
0
 

Accepted Solution

by:
Ronino earned 0 total points
ID: 25128338
Drive dead, data not recovered
0

Featured Post

[Webinar] Learn How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Delta outage: 650 cancelled flights, more than 1200 delayed flights, thousands of frustrated customers, tens of millions of dollars in damages – plus untold reputational damage to one of the world’s most trusted airlines. All due to a catastroph…
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question