?
Solved

Windows 2003 VPN Error 668/6

Posted on 2009-04-03
3
Medium Priority
?
2,713 Views
Last Modified: 2012-05-06
Every step I make towards fixing my VPN, I run into another problem...
Been troubleshooting my RAS Win 2k3 hosted VPN connection today (worked yesterday).  Have a new issue.  When units connect we get past "Verifying User Name and Password", then hangs on Registering on network.  We get one of two errors:
Either
"Cannot Retrieve Protocol Information
Error 668: The connection was terminated"

or

"Invalid Handel
Error 6"

We are using the windows PPTP client for connections.
0
Comment
Question by:JamesonJendreas
  • 2
3 Comments
 
LVL 5

Expert Comment

by:dcsdave
ID: 24065007
Whenever my RRAS goes TU I just disable it then I reenable it.  I do however do it a little differently than what the wizard likes most people to do.  When the wizard asks what type of VPN I click "custom" then on the next screen I click VPN.  The default settings work every time I configure a new server.  In some instances I go and change things but generally the defaults are pretty good.

Another thing I do is build my own RAS disk instead of configuring it through the XP wizard.  This has helped in some specific instances where the XP wizard doesn't work.
0
 
LVL 1

Author Comment

by:JamesonJendreas
ID: 24065340
Thanks for the Suggestions!

I've tried disabling, odd thing is on this unit, when you disable it, it doesn't rest the configuration; all the protocols and items under the tree stay (my older unit, all these except apple talk would.

After I disable the server from the tree, if I look to enable the option isn't there,  but the option to DISABLE still is.  I can disable an infinite number of times, but it never truly does. The RAS is disabled, though.  The service is stopped.  To get it going, I just have go to tasks-> start.  Wizard does not try to pop up.

I've attempted to delete the server, and then create it again.  Once again it remembers it's old config.  I'v e deleted the server and rebooted, no love.  I have looked in to every setting in the RAS mmc (maybe need to see if there's any command line...) and nothing seems to want to work.
0
 
LVL 5

Accepted Solution

by:
dcsdave earned 1500 total points
ID: 24065360
Have you tried going to Start/ServerManagement/Internet and E-Mail/Configure Remote Access and run through the wizard that way?  

Always be careful running these wizards.  They are great sometimes and cause issues other times.  It just depends on how many custom settings you have and how many roles your server plays.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
Let’s list some of the technologies that enable smooth teleworking. 
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question