[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3305
  • Last Modified:

Windows Release DHCP Lease on Shutdown option not working

I am trying to configure the Windows Release DHCP Lease on Shutdown option, but it's not working. I have it setup in scope options with a value of 0x1. I'm running Windows 2003. Has anyone ran into this problem, any help would be greatly appreciated. Thanks
0
buckethead34
Asked:
buckethead34
  • 3
  • 2
1 Solution
 
samiam41Commented:
From what I can remember with this setting, it is set on the client side.  Where are you setting the 0x1 option and through which means (GP, script, etc...)?
0
 
samiam41Commented:
I did find this post from here -> http://www.computing.net/answers/windows-2003/server-2003-dhcp/2889.html

From:
http://www.microsoft.com/resources/documentation/WindowsServ/2003/all/techref/en-us/Default.asp?url=/Resources/Documentation/windowsserv/2003/all/techref/en-us/w2k3tr_dhcp_tools.asp

"Release DHCP Lease on Shutdown
This option can be used to control whether DHCP-enabled computers running Windows 2000, Windows XP, or Windows Server 2003 sends a DHCPRelease message to the DHCP server when a shutdown occurs. It is actually implemented and interpreted as a bit-masked value by the DHCP Client service. By default, these clients do not send DHCPRelease messages on proper shutdown.

Code 2

Length 4 octets

Value Accepted values for this option are:

1 = DHCP clients send a DHCPRelease message on proper shutdown
0 = DHCP clients do not send a DHCPRelease message on proper shutdown
Structure of Release DHCP Lease on Shutdown

Code Length Release
002 4 0 | 1
0
 
buckethead34Author Commented:
I go into Scope Options--> Add Option--> Advanced Tab-->Microsoft Options in dropdown menu--> Default User Class in Users Class dropdown--> Select Code 002--> Value is 0x1.

That's where it's set and I don't get any results. Thanks
0
 
buckethead34Author Commented:
I believe I got it working. I was on an XP box, and Microsoft Options wouldn't work, but when I went to Microsoft Windows 2000 options and did the same setting. It did work. Thanks for the replies.
0
 
samiam41Commented:
No argument here.  Glad you find the solution.  May be worth accepting your own answer so others will know what worked.  Just a thought.  Either way, glad to work with you.

-Aaron
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now