Solved

Exchange 2007 to SMTP server gives "cannot find OUTBOUND MX record for domain

Posted on 2009-04-03
17
1,948 Views
Last Modified: 2012-05-06
Have verified DNS entry via nslookup -qtype=MX, -qtype=a and qtype=domain, and all resolve correctly from the Exchagne 2007 server.
All emails sent to SMTP server do not reach, all give "cannot find OUTBOUND MX record error"

Exchange configured to point to IP address rather than FQDN, but have tried both ways.
0
Comment
Question by:kitadams
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 6
17 Comments
 

Author Comment

by:kitadams
ID: 24065105
I should add some more info because everything points to an Exchange configuration issue, NOT dns.  Using Microsoft SMTDiag tool, everything appears to be correct from a SMTP perspective.

C:\Documents and Settings\kadams\Desktop\SmtpDiag>smtpdiag kadams@airbiquity.com
 support@ops-preprod.airbiquity.com

Searching for Exchange external DNS settings.
Computer name is AIR-ADAMS.

Checking SOA for ops-preprod.airbiquity.com.
Checking external DNS servers.
Checking internal DNS servers.
SOA serial number match: Passed.

Checking local domain records.
Checking MX records using TCP: airbiquity.com.
Checking MX records using UDP: airbiquity.com.
Both TCP and UDP queries succeeded. Local DNS test passed.

Checking remote domain records.
Checking MX records using TCP: ops-preprod.airbiquity.com.
Checking MX records using UDP: ops-preprod.airbiquity.com.
Both TCP and UDP queries succeeded. Remote DNS test passed.

Checking MX servers listed for support@ops-preprod.airbiquity.com.
Connecting to ops-preprod.airbiquity.com [192.168.12.8] on port 25.
Successfully connected to ops-preprod.airbiquity.com.

Can anyone suggest where in my Exchange 2007 Hub transport area I might be missing something?  Or is there somewhere else in Exchange that I need to be looking?

Thanks!
0
 
LVL 49

Expert Comment

by:Akhater
ID: 24065132
Clarify to us, are you having problems sending to external users or  receiving from external users ?

from/to ALL domains or just specific domains
0
 

Author Comment

by:kitadams
ID: 24065164
Am only sending email from support@airbiquity.com to support@ops-preprod.airbiquity.com.  
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 

Author Comment

by:kitadams
ID: 24065183
Let me clarify better... Exchange mail works fine for all "normal" enterprise connectivity.  This is a new addition where we are forwarding support tickets that hit the exchange server to a ticketing system server.  I added a new entry for the ticketing server in the hub transport but it does not appear to send the mail.  But, ther error it sends back to the user is the "cannot find outboud MX domain".  
0
 
LVL 49

Expert Comment

by:Akhater
ID: 24065208
so airbiquity.com is your domain ops-preprod.airbiquity.com  is a subdomain you have created right ?


this ticketing system has its own mail server ?

where did you create the MX record for ops-preprod.airbiquity.com.  ?

" I added a new entry for the ticketing server in the hub transport " what do you mean by that
0
 

Author Comment

by:kitadams
ID: 24065310
ops-preprod.airbiquity.com is the server name, it is not a subdomain.

so, in hub transport, i have added a send connector pointing to ops-preprod.airbiquity.com with the appropriate address, etc.
additionally, i have added in Global settings, transport settings, Message delivery, i have added the ip address of the ops-preprod server.
lastly, but not needed, i added ops-preprod.airbiquity.com in accepted domains, although this, as i understand it, is only needed if we wanted ops-preprod mail to come back into the exchange server.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 24065319
if ops-preprod.airbiquity.com is a server name what is support@ops-preprod.airbiquity.com ???

if you tell me what you need to accomplish i might help you do the configuration instead
0
 

Author Comment

by:kitadams
ID: 24065350
I have created a contact in AD called ticketing support.  It emails via SMTP to support@ops-preprod.airbiquity.com which is a user on the smtp server that ticketing server email uses.  

Yesterday, it worked the way we've got it set up, but then the user changed it to a static address and i changed the ip addresses we initially used in Exchange both in exchange and in DNS>
0
 

Author Comment

by:kitadams
ID: 24065362
this is the error we get returned when sending an email now:
This message was created automatically by mail delivery software.

A message that you have sent could not be delivered to one or more recipients.  This is a permanent error.  The following address failed:

  <support@ops-preprod.airbiquity.com>: Cannot find OUTBOUND MX Records for domain (ops-preprod.airbiquity.com)



Included is a copy of the message header:
-----------------------------------------
Received: from unknown [70.103.219.124] (EHLO mail.airbiquity.com)
      by p02c11o141.mxlogic.net (mxl_mta-6.1.1-3) over TLS secured channel
      with ESMTP id 775a6d94.3150154640.5233.00-002.p02c11o141.mxlogic.net (envelope-from <kadams@airbiquity.com>);
0
 
LVL 49

Expert Comment

by:Akhater
ID: 24065366
in your send connector what address space did you use ? and what configuration in the "network" tab ?


When you've added ops-preprod.airbiquity.com to the list of accepted domains what type have you used

finaly did you try to restart the transport service on exchange
0
 

Author Comment

by:kitadams
ID: 24065385
my send connector is 192.168.12.8
the ops-preprod.airbiquity.com accepted domain is External because it is non exchange
and yes, i restarted the transport service, but no luck :-(
0
 

Author Comment

by:kitadams
ID: 24065394
and in the ops-preprod network properties i have tried both the use MX and route thru smart host and entered the .12.8 address.


0
 
LVL 49

Expert Comment

by:Akhater
ID: 24065397
"my send connector is 192.168.12.8" i guess this is in the network tab what about the address space ?

who is 70.103.219.124 ? is that your public IP ?
0
 
LVL 49

Accepted Solution

by:
Akhater earned 500 total points
ID: 24065405
edit your send connector

in address space put "ops-preprod.airbiquity.com" then in Network put smart-host and put the IP address 192.168.12.8

1
 

Author Comment

by:kitadams
ID: 24065408
so, in conclusion:
General tab  fwdn is ops-preprod.airbiquity.com
Address space is smtp 192.168.12.8 cost 1
Network is currently set to Route thru with smart host being 192.168.12.8 using IP address
0
 

Author Comment

by:kitadams
ID: 24065412
OK, sorry, just read your last sent.  have changed to FQDN
will test now.
0
 

Author Comment

by:kitadams
ID: 24065435
That may have done it!  I haven't gotten a bounce yet, and i now have 192.168.12.8 showing up in the queue!   I have an email out to the owner of ops-preprod for verification of receipt.  Assuming he gets it, we can close this ticket and award points!  Thanks!!!
0

Featured Post

Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
how to add IIS SMTP to handle application/Scanner relays into office 365.

735 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question