Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 517
  • Last Modified:

Problem with UTC time on Exchange Server 2003 (Windows Server 2003 R2 Standard)

On my exchange server clock, it shows correct time and time zone (PACIFIC GMT -0800), but when I telnet to this server, on port 25, exchange answers but the UTC shows -0700.
I did apply the december 2008, MS patch (KB955839) and stop and started net time, but nothing has changed.
I checked my server, that it queries net time from, and it does have the correct time and zone (UTC and PST)
Any ideas a\on how to resolve?
Thanks in advance!
0
smcmcnutt
Asked:
smcmcnutt
  • 8
  • 4
1 Solution
 
samiam41Commented:
Not that this will help but you should add this to the Exchange forum.  Hopefully by me mentioning this, the upper level experts will see that this is an Exchange server related question and give you the correct answer.

If you don't get anything from an expert soon, use the "request attention" button on the side.

Here is my stab:  http://support.microsoft.com/gp/dst_topissues  <article on Exchange server related time change issues/resolution>
0
 
MrMintanetCommented:
What time does it say on the local computer?
0
 
smcmcnuttAuthor Commented:
Current, correct time  (Utc -800)
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
MrMintanetCommented:
So, the only place where the problem is noticed is within telnet sessions?
0
 
smcmcnuttAuthor Commented:
MrMintanet-
I notice it in 1 other spot, and that's when I read headers in emails I receive from the outside world.  My received and sent time, from my outlook client, look correct though.  (I atatched sample below)

Microsoft Mail Internet Headers Version 2.0
Received: from XXX.XXXX.COM ([192.168.x.x]) by XXX.XXX.COM with Microsoft SMTPSVC(6.0.3790.3959);
	 Fri, 3 Apr 2009 14:31:20 -0700

Open in new window

0
 
MrMintanetCommented:
That's no good.  Are you using an external MX service?
0
 
smcmcnuttAuthor Commented:
MrMintanet-
Internal exchange server(s).  Front end- back end.  Both show the UTC -0700 when doing the telnet.
0
 
MrMintanetCommented:
Not just telnet.  Your mail headers also show the -0700 too, right?
0
 
smcmcnuttAuthor Commented:
Yes!
But I did not notice until you asked me about telnet, the first time.
0
 
smcmcnuttAuthor Commented:
I logged in to both of my exchange servers, today, since it's after hours.
I went to the clocks on both servers and unchecked the "Automatically adjust clock for daylight savings time".  And then manually adjusted the clocks to current time.
I sent myself an email from my home account and the header now shows -0800 UTC with correct time.
Now when I telnet (Port 25) to both servers, I also have the correct -0800 UTC showing when the servers answer.
Keep in mind, that I have applied the DST patches.  When I try to apply them again, I do get the error indicating that the patches have already been applied.
0
 
smcmcnuttAuthor Commented:
Manually adjusted time, and reset DST
0
 
smcmcnuttAuthor Commented:
Thanks
0
 
smcmcnuttAuthor Commented:
Thanks
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 8
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now