Solved

Cannot get DHCP to work on Cisco 1800 Router

Posted on 2009-04-03
7
581 Views
Last Modified: 2012-06-21
I am trying to install a T1 line into our office and having some problems.  I have the T1 line going into a Cisco 1840 router.  I got it working by putting in my static ip settings in on my server, but I can't get DHCP to work.  I disabled it on the server and trying to get it on the router to no avail.  I also need to make sure the router is handling NAT, which I think it is.

Thank You in Advance!

I'm not too experienced with Cisco setup, but here's my configuration:

Current configuration : 1600 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname u255009
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool gt
   import all
   network 10.2.1.0 255.255.255.0
   default-router 65.246.8.245
   dns-server 198.6.1.5
!
!
ip domain name ALTER.NET
ip name-server 198.6.100.38
!
!
!
!
!
interface FastEthernet0/0
 ip address 65.246.8.245 255.255.255.252
 speed 100
 full-duplex
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 bandwidth 1536
 no ip address
 no ip redirects
 no ip proxy-arp
 encapsulation frame-relay IETF
 no fair-queue
 service-module t1 timeslots 1-24
 frame-relay lmi-type ansi
!
interface Serial0/0/0.500 point-to-point
 ip unnumbered FastEthernet0/0
 no cdp enable
 no arp frame-relay
 frame-relay interface-dlci 500 IETF
!
interface Dialer0
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 ppp authentication chap
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/0.500
!
!
no ip http server
no ip http secure-server
ip nat pool gt 10.2.1.1 10.2.2.1 netmask 0.0.0.255
ip nat inside source list 1 interface Dialer0 overload
!
!
!
!
control-plane
!
!
!
line con 0
 password cisco
 login
 transport preferred none
line aux 0
 password cisco
 login
 modem InOut
 transport preferred none
 transport input all
 transport output all
 stopbits 1
 flowcontrol hardware
line vty 0 4
 password cisco
 login
 transport preferred none
!
scheduler allocate 20000 1000
end
0
Comment
Question by:gzarnick
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 28

Expert Comment

by:asavener
ID: 24065040
"ip dhcp pool gt
   import all
   network 10.2.1.0 255.255.255.0
   default-router 65.246.8.245
   dns-server 198.6.1.5"

These settings won't work.

a) You don't have any interfaces in the 10.2.1.x subnet, so your router will not offer addresses.
b) Your default router must be in the same subnet as the address you are giving out, or the device will not be able to communicate with the default router.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24065467
A) Actually, it will provided that a router on the 10.2.1.0 network is forwarding DHCP requests to this server.

0
 
LVL 5

Author Comment

by:gzarnick
ID: 24068080
What would be my best move.  Currently our DSL modem uses DHCP on the server.  Do I just set the server with the static IP and use the DHCP on there.

If so what would I need to change in the DHCP settings to get it to work.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 5

Author Comment

by:gzarnick
ID: 24068684
Okay.  I found out I need non-routable IP addresses to get to my clients.  How would I set that up?
0
 
LVL 28

Expert Comment

by:asavener
ID: 24068838
You need more public IP addresses from your ISP; you only have two useable addresses currently.
0
 
LVL 28

Accepted Solution

by:
asavener earned 500 total points
ID: 24068845
Oops.

Sorry; disregard last comment.


You need to set up another interface in the 10.2.1.x subnet, and plug it into your LAN switch.

Then change the default router command in your dhcp pool.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24069199
What do you mean as another interface?  Currently I have a DSL modem that plugs directly into the switch.  My server is connected to the switch and I run DHCP off there.  I am trying to get it so all client computers will have a T1 Connection.

Could please explain to me exactly what I'll need to do.

Thanks
0

Featured Post

Turn your laptop into a mobile console!

The CV211 Laptop USB Console Adapter provides a direct Laptop-to-Computer connection for fast and easy remote desktop access with no software to install.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
Hyper-convergence systems have taken the IT world by storm and have quickly started to change our point of view of how the data center should and could be architected. In this article, I’ll explain the benefits of employing a hyper-converged system …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

615 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question