Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 275
  • Last Modified:

Using CAS server for Exchange 2003 and Exchange 2007 mailboxes

Hi Guys

I understand that the CAS can service mailboxes on both Exchange 2003 and Exchange 2007 mailboxes, whereas an Exchange 2003 FE can only service mailboxes on Exchange 2003.

However! If using the CAS, different URL's need to be use depending on what server the mailbox resides on...i.e, if the mailbox resides on a 2003 mailbox server, then /exchange must be used in the URL string, and if on 2007 then /owa.

Is there anyway to get to use the same URL regardless of whether the mailbox is on a 2003 *OR* 2007 server?
0
kam_uk
Asked:
kam_uk
  • 10
  • 8
2 Solutions
 
AkhaterCommented:
1) your 2007 CAS should NOT be a Mailbox server it should be CAS only or CAS/HUB
2) let all your users use the /exchange virtual directory and your CAS will take care of redirecting your 2007 users to /owa

0
 
kam_ukAuthor Commented:
Hi there

Regarding #2, Ah, ok I didn't know that - so I can tell ALL my users to access via the /exchange URL and the CAS will forward those that are on 2007 mailbox servers to /OWA?
0
 
AkhaterCommented:
yep exactly
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
AkhaterCommented:
btw it wld be better if you let ppl simply access http://webmail.domain.com & setup the redirection to /exchange on the CAS so when you finish the migration you change it to /OWA
0
 
kam_ukAuthor Commented:
Hi

Hmmm, thanks...I'm not sure what you mean?

So, ALL users access http://webmail.domain.com - regardless of whether they are on 2007 or 2003 mailbox servers?

On the CAS I would set up redirection from http://webmail.domain.com to http://cas/exchange? Do you know how to do this? Is it via IIS redirection of some sort?

0
 
AkhaterCommented:
are you windows 2003 or 2008 ?
0
 
kam_ukAuthor Commented:
2008 mate
0
 
AkhaterCommented:
well i'll retrieve that for you when i'm back home.
it's a IIS thingy
0
 
kam_ukAuthor Commented:
Thanks...

But this doesn't redirect everything to https://owa.mycompany.com/owa?

Where it says to redirect, should I be entering https://owa.mycompany.com/exchange?

for example - to copy from Step1 b) of the post:

"b) Click on Respond with a 302 redirect and provide the absolute URL: https://owa.mycompany.com/owa"

Should this be:

"b) Click on Respond with a 302 redirect and provide the absolute URL: https://owa.mycompany.com/exchange"
0
 
AkhaterCommented:
yea exactly change /owa thing to /exchange

0
 
kam_ukAuthor Commented:
Hmm, thanks, ...doesn't seem to work, I get an HTTP Internal Server error?

0
 
AkhaterCommented:
if you do type the /exchange it works?
0
 
kam_ukAuthor Commented:
My mailbox is currently on a 2003 Mailbox server.

If I do /owa, then I get the message that my mailbox is located on a 2003 mailbox server and the CAS can't get to it, as I would expect.

If I do /exchange, then I get an HTTP 500 Internal server error.
0
 
AkhaterCommented:
ok so it is not the redirection that failed

what is the exact error message, can you put a screen shot
0
 
kam_ukAuthor Commented:
Sure...

To confirm - here are the settings I am using:

CAS server: cas.mydomain.com
CAS URL as specificed in Exchange Management Console: https://cas.mydomain.com/owa

I have amended the steps below to include exactly what I have typed:

>>>

Step 1:

1,Log on Interne Information Services (IIS) Manager

2, Switch back to Features view of the "Default Web Site" and double click on "Error Pages".

3, In the Actions pane, click on "Edit Feature Settings" and under "Error Responses", select: "Custom Error Pages". Then click OK

4, In the Actions pane, click on "Add" and configure the following

a) Status code: 403.4

b) Click on Respond with a 302 redirect and provide the absolute URL: https://cas.mydomain.com/exchange

 

Note: Make sure you are using "https"

 

Step 2:

1,Open IIS 7 Manager

2,Highlight the Default Website and ensure we are in the Features View

3, Double click on HTTP Redirect icon

4, Check the option "Redirect requests to this destination:" and type the absolute OWA URL: https://cas.mydomain.com/exchange

5, Under Redirect Behavior section, select the option "Only redirect requests to content in this directory (not subdirectories)"

6, From the drop down, select the Status code: Found (302)

7, Click Apply to save the settings

8, Run IISRESET /noforce command in CMD for the settings to take effect.

>>

I have set up a DNS entry pointing webmail.mydomain.com > cas.mydomain.com, but I get this error even if i use https://cas.mydomain.com/exchange

Thanks again for the excellent help on this one :)
CAS-error.docx
0
 
yoshi66Commented:
0
 
AkhaterCommented:
on the CAS server

open EMC server config => client access


right click on the exchange virtual directory -> authentication tab

and make sure that you have "basic authentication" enabled
0
 
kam_ukAuthor Commented:
Thanks guys - Yoshi's link worked perfectly, but I'm awarding points to Akhater as well since he helped so much and I really appreciate it!
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 10
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now