Solved

How can i fix a virtual server that will no longer boot?

Posted on 2009-04-03
11
571 Views
Last Modified: 2012-05-06
I have a virtual server that was working fine. Its a vmware virtual server running windows server 2003 with sql on an esx 3.5 host. It will get to the screen with windows server 2003 then the line scrolling at the bottom but will eventually get the blue screen of death. I tried going into last known good config and tried going into safe mode but it hangs on acpixx.dll.

What are my options. I need to fix this virtual server without losing the data.
0
Comment
Question by:SCrystal
  • 5
  • 5
11 Comments
 
LVL 42

Expert Comment

by:paulsolov
Comment Utility
i would first make a copy of the VMDK files.  Once you have a good copy you can mount a Windows 2003 server ISO and try to do a repair.  If that doesn't work you can try to create a new virtual machine and try to use current vmdk files to mount as hard disks.  If that doesn't work you'll need to restore from backup or moujnt the vmdk files to an existing server and get the data from it.
0
 
LVL 21

Expert Comment

by:za_mkh
Comment Utility
If you are aware of any changes to the VM config - e.g more vCPU's added or removed, change it so that it is what it was previously. I think it has to do with this.
If you didn't make changes to the VM config, but something in the guest operating system like a program was added, or something, you can sometime restore the windows\system32\config folder with something from a backup prior to making the change. That could allow the system to restart but of course any application installations ,etc that were made from the last backup point will be lost.
If the OS recovery doesn't start, you can use a bartpe disk to boot up the VM to get the files off, or do what Paulosolv says about attaching those VMDKS to a working os, so that you can get the data off
 
0
 

Author Comment

by:SCrystal
Comment Utility
Ok how would i make a copy of the VMDK files exactly? If I look at the datastore this vmware server is on it shows 466.75Gb capacity and 99.96Gb free. If I browse this datastore and browse inside this vmware server folder I see 2 vmdk files. One is slightly over 143Gb and the other is slightly over 10Gb.

Now we have added 7 more 300Gb disks recently to the Nas box. Did disk assign then increased the size of the volumes but esx does not see the extra space. I think this is due to not knowing how to resize an active LUN and how to make esx see the extra space.

Now I have another windows 2003 vmware server that I can play with and I do have a snapshot of the vmware server that won't boot but it is from a month ago. My dilemma is if I revert to the snapshot then I need not to lose the month or so changes to the sql database.

How can i mount the vmdk files as harddisks on another vmware server and backup the sql database. Is this possible? If i could do that then i could revert to the snapshot from a month ago and restore the database no?

za_mkh i tried booting that vmware server from a winternalsw disk but it does not see the hardrive
0
 

Author Comment

by:SCrystal
Comment Utility
I tried just adding the vmdk file to another server as a virtual disk and that server would not boot as well. I powered it off then removed the virtual disk then it powered up.
0
 

Author Comment

by:SCrystal
Comment Utility
Now after adding the virtual disk to my other server I am getting
Cannot open the disk  xxx.vmdk on the server I am trying to fix

The parent virtual disk has been modified since the child was created
It won't let me revert back to a snapshot as it says there is no operating system
0
Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

 
LVL 21

Expert Comment

by:za_mkh
Comment Utility
Oh bloody hell. Looks like you are in a tight mess there. I am hoping that you have backups of your VM or your SQL data?
1) Snapshots are not meant to be backups. They are meant to be short term backups like when you change or install something. Once the task is successful, you should remove the snapshots as they slow down your VM.
Now as to the problem!
In your original post you did not mention snapshots, and now this is why you have a problem! When you snapshot a disk e.g. disk1.vmdk a new delta disk is created e.g. disk1-delta1.vmdk. Any changes made to that disk from the point of snapshot is written to the delta disk. So the delta disk keeps growing with all the changes that are made inside the VM. When you create another snapshot, disk1-delta2.vmdk is created and the process of changes then get written to the delta2 disk. This is why you can revert to a previous snapshot. It loads the original disk1.vmdk without 'applying' the changes made in the delta disks. Only when you delete a snapshot, do all the changes in the delta disk(s) then get committed to the original vmdk!
So your changes are actually in the delta disk, but the delta disk is tried to the orignal vmdk. when you powered attached the original vmdk to another machine you changed it's configuration slightly and now VMware is not happy as it cannot tie the delta disk to the original VM!
If you made a copy of the VMDK or your VM with all it's files you would be able to recover, but now I can't think of anything you can do that would allow you to 'amalgamate' your delta disk and your original vmdk as there is no way you can load a delta disk to see the changes or files.
 
 
0
 
LVL 21

Expert Comment

by:za_mkh
Comment Utility
0
 

Author Comment

by:SCrystal
Comment Utility
Yes I am in a mess. I was able to revert to a snapshot from a month ago but it complained that it couldn't find the domain controller. I could login to the machine as local admin but as soon as i restarted it it said there was no o/s.

What i decided as my best shot is I still had the old physical server from about 6 months ago before the virtual conversion. So I brought that back online. Then I am in the process of converting it through the vmconverter cd to a virtual machine.

Once this is done I just need to figure out how to restore the sql database from the tape backup.

Can you give any advice on that? Can I just shutdown the mssql service than copy over the mysql folder and start the service? I know in oracle I can just shutdown the database then copy over the data folder then restart the database but not sure if its the same idea for mysql
0
 
LVL 21

Expert Comment

by:za_mkh
Comment Utility
I just had an idea this morning!
If you can follow the link that I sent earlier about trying to fix the parent disk issue, you should sort of get a system which starts ups and blue screens. If you get back to that level. Great! Why?
Because then you copy your entire virtual machine folder(s) to anotrher folder on your datastore. Register this new VM with ESX, and then apply the snapshot. So your operating system is messed, but if VMWare applies the snapshot, then all those changes from the delta files should get written back to the original VMDK. If this succeeeds (and it can take a long time to commit a snapshot depending on how long you've been running a snapshot for), you will be mount this VMDK to any other VM, and then copy the latest files!
Regarding your other question SQL is as easy as that too. Just make sure your restore the latest master database files too as that contains all the configuration for your SQL server.
Good luck with both options!
 
0
 

Author Comment

by:SCrystal
Comment Utility
za_mkh I will award you the points as you have been the most helpful but I do need your help. After working through the weekend and trying various things without success I have found the issue but not sure how to fix it.

We recently added extra sas drives to the SAN. We extended the volume on the SAN but as we were unsure the proper way to add it to the datastore so vmware saw it we left that for now.

I see that on one of our datastores it says there is 466.75Gb capacity 260.65Gb free but when i lookimit also has Extents vmhax:x:x:x 0.00B

This has to be our issue. Now how do i fix it. There are other vmware servers on that datastore that are currently up and running like exchange. So i am thinking the long way of fixing this is using vmconverter to convert all vmware servers from this datastore to the other one. Then deleting the problem datastore and creating a new one.

Unless you can tell me how to fix this extent issue
0
 
LVL 21

Accepted Solution

by:
za_mkh earned 500 total points
Comment Utility
Thanks! Hope you came right!
Extents are pointers to additional storage volumes that get 'bolted' on to an existing partition/volume. Extents are never a good thing to have due to the fact that if you lose one of them you lose everything. I would go with your idea of moving things off this VMFS volume and expanding/recreating your VMFS partition to include your new drives. Though I would advise you to look at Thin provisioning for your SAN volume if your SAN has this capability. It means that if you decided to ever add capacity to your SAN, you don't need to rebuild your VMFS LUNS, or use extents.
The fact that you have an extent of 0Bytes tell yous that someone deleted the LUN associated with that extent  - hence your VM dying! :-(
However, you don't have to use VMConverter to move VMs from one VMFS partition to another, you can use a fantastic free tool by veeam called FastSCP (www.veeam.com) to move files between your ESX servers  and/or VMFs volumes - really easy - drag and drop.
Once you use this tool to move file between the volumes. Good luck!
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
docker invalid registry name 2 49
Attempting to Install VisualESXTOP 2 35
VMWare iSCSI Issues 7 47
exchange, virtualization 1 25
David Varnum recently wrote up his impressions of PRTG, based on a presentation by my colleague Christian at Tech Field Day at VMworld in Barcelona. Thanks David, for your detailed and honest evaluation!
Last article we focus in how to VMware: How to create and use VMs TAGs – Part 1 so before follow this article and perform the next tasks, you should read the first article how to create the TAG before using them in Veeam Backup Jobs.
Teach the user how to edit .vmx files to add advanced configuration options Open vSphere Web Client: Edit Settings for a VM: Choose VM Options -> Advanced: Add Configuration Parameters:
This Micro Tutorial walks you through using a remote console to access a server and install ESXi 5.1. This example is showing remote access and installation using a Dell server. The hypervisor is the very first component of your virtual infrastructu…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now