Solved

IIS SMTP Mail Never Leaves Queue

Posted on 2009-04-03
4
628 Views
Last Modified: 2013-11-30
I have read so many posts about this and none seem to relate to me. I have just setup a new SMTP Virtual Server in IIS, with the Default Local Domain, and a domain I have pointed at an ip on the box for type remote.

When I put a test mail in the pickup directory, the server picks it up and adds it to the queue directory and that is as far as it goes. I see the following in the web log, any ideas on how I can get this to work? What am I missing here?

2009-04-04 01:59:13 209.85.221.44 OutboundConnectionResponse - - 220+mx.google.com+ESMTP+10si2912969qyk.125 0 0
2009-04-04 01:59:13 209.85.221.44 OutboundConnectionCommand EHLO - C59409-120719 0 0
2009-04-04 01:59:13 209.85.221.44 OutboundConnectionResponse - - 250-mx.google.com+at+your+service,+[74.55.233.130] 0 0
2009-04-04 01:59:13 209.85.221.44 OutboundConnectionCommand MAIL - FROM:<XXXXXXXXXXXXXXXX@XXXXXXXXXXXXXXXX.net>+SIZE=357 0 0
2009-04-04 01:59:13 209.85.221.44 OutboundConnectionResponse - - 250+2.1.0+OK+10si2912969qyk.125 0 0
2009-04-04 01:59:13 209.85.221.44 OutboundConnectionCommand RCPT - TO:<XXXXXXXXXXXXXXXX@gmail.com> 0 0
2009-04-04 01:59:13 209.85.221.44 OutboundConnectionResponse - - 250+2.1.5+OK+10si2912969qyk.125 0 0
2009-04-04 01:59:13 209.85.221.44 OutboundConnectionCommand DATA - - 0 0
2009-04-04 01:59:13 209.85.221.44 OutboundConnectionResponse - - 354++Go+ahead+10si2912969qyk.125 0 0
2009-04-04 02:09:13 209.85.221.44 OutboundConnectionResponse - - 451+4.4.2+Timeout+-+closing+connection.+10si2912969qyk.125 0 0
0
Comment
Question by:addicktz
  • 2
4 Comments
 
LVL 25

Assisted Solution

by:Ron M
Ron M earned 200 total points
ID: 24065888
Do you have any firewall that might be inspecting the smtp packets ?

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_22069551.html
0
 
LVL 2

Assisted Solution

by:ibiadmin6
ibiadmin6 earned 50 total points
ID: 24072814
Turn off AV scanning of the SMTP directories and see if it works then
0
 
LVL 14

Accepted Solution

by:
wolfman007 earned 250 total points
ID: 24088509
Have you configured your Virtual SMTP Server to relay your emails to a Smart Host?

If you do not tell the server where to send the emails then they will just sit in the queue.

To set up a smart host
1. In IIS Manager, right-click the SMTP virtual server, and then click Properties.
2. Click the Delivery tab, and click Advanced.
3. In the Smart host box, type the name of the smart host server. You can type a string to represent a name or enter an IP address.
4. If you want the SMTP service to attempt to deliver remote messages directly before forwarding them to the smart host server, select the Attempt direct delivery before sending to smart host check box. The default is to send all remote messages to the smart host, not to attempt direct delivery.
 
from

Configuring Smart Hosts (IIS 6.0)
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/6003ab51-7eb5-47b2-8d92-e26b1deeeac1.mspx?mfr=true
0
 
LVL 25

Assisted Solution

by:Ron M
Ron M earned 200 total points
ID: 24088598
wolfman....why do you assume he needs to use a smarthost ?...

Have you tested sending an email to an address other than a *gmail address ?... From your post above it looks like your server connected to google to try to deliver mail, then timed out...or the connection was closed by google mail server.
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Debug Tools to analyse IIS process: This article focus on taking memory dumps from IIS to determine which code is taking more time and to analyse which calls hangs/causes more CPU usage. To take dumps,download the following. Install1: To st…
Resolve Outlook connectivity issues after moving mailbox to new Exchange 2016 server
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now