Solved

Cisco 871 Routing Problem

Posted on 2009-04-04
4
815 Views
Last Modified: 2012-05-06
Hi Experts,
I am preparing a Cisco 871 router to interface between 2 subnets as follows:
VLAN1 : 10.10.10.0/29 on fe1(10.10.10.1) : Used for Router administration only
VLAN2:  192.168.0.0/24 on fe0 (192.168.0.253):  Subnet 1
VLAN3:  192.168.16.0/24 on fe2(192.168.16.253): subnet 2
fe4 is disabled.
Connected to VLAN2 and VLAN3 are 2 PCs named PC0 (192.168.0.2) and PC16 (192.168.16.2) respectively.
From within the Router (via telnet) I can ping fe0,fe2, PC0, PC16.
From PC0 I can ping it's respective interface on the Router (fe0).  The same is true for Pc16.
However I cannot ping PC0 from PC 16 and vice-versa.   The running config is below
Thank you for your help





!This is the running config of the router: 10.10.10.1
!----------------------------------------------------------------------------
!version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
username admin privilege 15 secret 5 $1$1NIU$fc81TDDVS3AvKrgR97zET0
no aaa new-model
ip subnet-zero
ip cef
!
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool sdm-pool
   import all
   network 10.10.10.0 255.255.255.248
   default-router 10.10.10.1 
   lease 0 2
!
!
ip domain name preskilkenny.local
ip ips po max-events 100
no ftp-server write-enable
!
!
!
! 
!
!
!
interface FastEthernet0
 switchport access vlan 2
 no ip address
 no cdp enable
!
interface FastEthernet1
 no ip address
 no cdp enable
!
interface FastEthernet2
 switchport access vlan 3
 no ip address
 no cdp enable
!
interface FastEthernet3
 switchport access vlan 4
 no ip address
 no cdp enable
!
interface FastEthernet4
 description $ETH-WAN$
 ip address dhcp client-id FastEthernet4
 shutdown
 duplex auto
 speed auto
 no cdp enable
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
 ip address 10.10.10.1 255.255.255.248
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
interface Vlan2
 ip address 192.168.0.253 255.255.255.0
!
interface Vlan3
 ip address 192.168.16.253 255.255.255.0
 ip mask-reply
!
interface Vlan4
 no ip address
!
ip classless
!
!
ip http server
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
ip nat inside source list 1 interface FastEthernet4 overload
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.10.10.0 0.0.0.7
access-list 1 permit 192.168.16.0 0.0.0.255
no cdp run
!
!
control-plane
!
banner login ^C
-----------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device. 
This feature requires the one-time use of the username "cisco" 
with the password "cisco".
 
Please change these publicly known initial credentials using SDM or the IOS CLI. 
Here are the Cisco IOS commands.
 
username <myuser>  privilege 15 secret 0 <mypassword>
no username cisco
 
Replace <myuser> and <mypassword> with the username and password you want to use. 
 
For more information about SDM please follow the instructions in the QUICK START 
GUIDE for your router or go to http://www.cisco.com/go/sdm 
-----------------------------------------------------------------------
^C
!
line con 0
 login local
 no modem enable
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
 privilege level 15
 login local
 transport preferred all
 transport input telnet ssh
 transport output all
!
scheduler max-task-time 5000
end

Open in new window

0
Comment
Question by:freshfordian
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 300 total points
ID: 24066920
PC0 has a default gateway of 192.168.0.253 and PC16 has a default gateway of 192.168.16.253, right?
0
 
LVL 1

Author Comment

by:freshfordian
ID: 24067078
Yes
0
 
LVL 1

Author Comment

by:freshfordian
ID: 24070355
Hi JFrederick29,

The gateways SHOULD have been set s you suggested.  I thought that they were.  I was wrong.  When I corrected the settings everything worked like a dream.  Thanks for the solution.
0
 
LVL 1

Author Closing Comment

by:freshfordian
ID: 31566537
Thanks for your help
0

Featured Post

Secure Your Active Directory - April 20, 2017

Active Directory plays a critical role in your company’s IT infrastructure and keeping it secure in today’s hacker-infested world is a must.
Microsoft published 300+ pages of guidance, but who has the time, money, and resources to implement? Register now to find an easier way.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Cisco IPSec lan to lan tunnel - encryption domain. 3 61
snmp v2 configuration on a switch 3 44
Cisco SRST questions 5 27
Cisco 3650x ACL 8 9
If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
David Varnum recently wrote up his impressions of PRTG, based on a presentation by my colleague Christian at Tech Field Day at VMworld in Barcelona. Thanks David, for your detailed and honest evaluation!
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question