Solved

How to change the Transaction Log setting of a DB running in MOSS farm?

Posted on 2009-04-04
6
355 Views
Last Modified: 2012-05-06
DB Recovery Model-Full
SQL 2005 DB size 72231.88 MB
Space available 3 MB

Log File Initial size 72217 as seen in DB properties >File
Auto Growth set as :By 10% restricted growth to 2097152 (MB)

Presently Transcation Log fil size shown as 70.5 GB
Current SQL server Logs saying:


Database backed up. Database: MOSS_new_config, creation date(time): 2009/03/28

(22:23:14), pages dumped: 1770, first LSN: 18676:482407:58, last LSN:

18676:482431:1, number of dump devices: 1, device information: (FILE=1,

TYPE=DISK: {'H:\Backup\MOSSSBK\MOSS_new_config_backup_200904041409.bak'}). This

is an informational message only. No user action is required.

Autogrow of file 'MOSS_new_config_log' in database 'MOSS_new_config' took 69250

milliseconds.  Consider using ALTER DATABASE to set a smaller FILEGROWTH for

this file.

How to remove this warning withoouit stopping the DB activity.
(Log file kept in different Drive with space availability 0f above 100 GB)


I cannot stop the DB and do any process isnce its my SharePoint Configuration DB
0
Comment
Question by:Paaki
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
6 Comments
 
LVL 17

Expert Comment

by:k_murli_krishna
ID: 24066866
0
 

Author Comment

by:Paaki
ID: 24066998
I went through the links..but still could not make out how to do a workaround to remove thsi error shown in SQL server log...I am new to SQL 2005..It would be really helpful if youcan help  me with steps to do the right solution.
Thanks in advance
0
 
LVL 17

Accepted Solution

by:
k_murli_krishna earned 250 total points
ID: 24068598
This is an informational message only. No user action is required.
Autogrow of file 'MOSS_new_config_log' in database 'MOSS_new_config' took 69250 milliseconds.  Consider using ALTER DATABASE to set a smaller FILEGROWTH for this file.

This is exactly what is addressed in below link. It is too long to put it inline. Now you will solve your problem & it is explained step by step.

ALTER DATABASE to set SMALLER FILEGROWTH
http://social.msdn.microsoft.com/Forums/en-US/sqldatabaseengine/thread/cb42262c-abfa-40f5-86b5-62e8132f2559/
0
 
LVL 43

Assisted Solution

by:zephyr_hex (Megan)
zephyr_hex (Megan) earned 250 total points
ID: 24088779
the easiest solution is to change your recovery model to simple.  unless you are doing something really unique with sharepoint, a simple recovery model is sufficient.  just make sure you are taking complete farm backups on a daily basis.

to change the recovery model of your sharepoint database(s):
the easiest method is to use SQL Management Studio ... because then it has a nice graphical interface.  in this case, right click on the database and select Properties.  In the left panel of the Properties window, select Options.  you can change the recovery model to Simple using the drop-down.
0
 
LVL 43

Expert Comment

by:zephyr_hex (Megan)
ID: 24088877
this article explains each of the recovery models, show you how to change the recovery model using SQL Management Studio (which are the steps i gave you) ... and also shows you how to change the recovery model using TSQL... in case you prefer that method:
http://www.mssqltips.com/tip.asp?tip=1497

as a side note...
when i installed sharepoint, i went through and changed the recovery model on all of my sharepoint databases to simple, as i knew there would never be the case where i would need to roll back a transaction, or recover from a specific point in time.  i run full farm backups on a daily basis using stsadm, and also run daily database backups using SQL maintenance plans...  so i have 2 options for recovery in case of disaster.  this is more than sufficient for my requirements...
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Note:  There are two main ways to deploy InfoPath forms:  Server-side and directly through the SharePoint site.  Deploying a server-side InfoPath form means the form is approved by the Administrator, thus allowing greater functionality in the form. …
Pimping Sharepoint 2007 without Server-Side Code Part 1 One of my biggest frustrations with Sharepoint 2007 in the corporate world is that while good-intentioned managers lock down the more interesting capabilities of Sharepoint programming in…
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question