Solved

How to create non-routable IP addresses with Cisco 1840 Router?

Posted on 2009-04-04
3
1,006 Views
Last Modified: 2012-05-06
I have a Cisco 1840 router that I run my T1 connection to.  I need to get the client computers to be able to use the T1 connection and I think I need non-routable ip addresses, but I don't know how to do so.  Could someone please explain to me what exactly to do.  I can get into the router through hyperterminal and config whatever I need, I just don't know what to config.

Thanks.

Here's my current configuration:

Current configuration : 1694 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname u255009
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool gt
   import all
   network 65.246.8.244 255.255.255.252
   default-router 65.246.8.245
   dns-server 198.6.1.1
   lease 10
!
!
ip domain name ALTER.NET
ip name-server 198.6.100.38
ip name-server 198.6.1.1
ip name-server 198.6.1.2
ip name-server 198.6.1.38
!
!
!
!
!
interface FastEthernet0/0
 ip address 65.246.8.245 255.255.255.252
 speed 100
 full-duplex
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 bandwidth 1536
 no ip address
 no ip redirects
 no ip proxy-arp
 encapsulation frame-relay IETF
 no fair-queue
 service-module t1 timeslots 1-24
 frame-relay lmi-type ansi
!
interface Serial0/0/0.500 point-to-point
 ip unnumbered FastEthernet0/0
 no cdp enable
 no arp frame-relay
 frame-relay interface-dlci 500 IETF
!
interface Dialer0
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 ppp authentication chap
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/0.500
!
!
no ip http server
no ip http secure-server
ip nat pool gt 10.2.1.1 10.2.2.1 netmask 0.0.0.255
ip nat inside source list 1 interface Dialer0 overload
!
!
!
!
control-plane
!
!
!
line con 0
 password cisco
 login
 transport preferred none
line aux 0
 password cisco
 login
 modem InOut
 transport preferred none
 transport input all
 transport output all
 stopbits 1
 flowcontrol hardware
0
Comment
Question by:gzarnick
  • 2
3 Comments
 
LVL 2

Expert Comment

by:vaiha
ID: 24068696
Does your basic internet connectivity from the client computers work ?
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24069187
I can't connect to the Internet from client computers when I plug the router into the switch.  I get no addresses or connectivity.
0
 
LVL 2

Accepted Solution

by:
vaiha earned 500 total points
ID: 24072328
Ok, I have no idea how is your network supposed to be like.
But what I can tell from the config is that there are a few problems with it.

1)
ip nat pool gt 10.2.1.1 10.2.2.1 netmask 0.0.0.255
and
ip dhcp pool gt
   import all
   network 65.246.8.244 255.255.255.252
   default-router 65.246.8.245

2)
ip nat inside source list 1 interface Dialer0 overload
and
ip route 0.0.0.0 0.0.0.0 Serial0/0/0.500

3)
interface FastEthernet0/0
 ip address 65.246.8.245 255.255.255.252

Maybe if you could explain how are the cables connected to the router & ip addressing, or could you explain what are you trying to achieve with some sort of a network diagram?

Hope it helps.


0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
cisco ubr7200 problem with  interface Wideband-Cable 1 36
Stack Switches in IOU  web V22 6 64
Public IP Address Amazon Servers 2 45
P2P and MPLS 3 47
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now