Solved

Connect client computers to T1 router

Posted on 2009-04-04
102
362 Views
Last Modified: 2012-05-06
I have a T1 line installed that runs into a Cisco 1840 router.  I have only one static IP address (65.246.8.246) and then the router's IP (65.246.8.245).  I am trying to find out how I can connect the router to my switch and give all the client computers the T1 connection because I have no more IP addresses. I think I need some non-routable IP addresses, but I have no clue how to set that up on the router so any help would be great.

Thank You
0
Comment
Question by:gzarnick
  • 54
  • 43
  • 2
  • +2
102 Comments
 
LVL 42

Expert Comment

by:paulsolov
ID: 24069583
what you will need to do is configure a NAT (Network Address Translation) on the router.  You should configure the second interface as the inside interface and setup a private subnet such as 192.168.1.0 255.255.255.0.  Once you do this you can configure dhcp on this interface or let a dhcp server do this and provide your internal systems IP Address from the 192.168.1.0 subnet.  You should be able to login into the router via web interface (SDM) and configure it using the startup guide provided by cisco.
0
 
LVL 1

Accepted Solution

by:
woodall01 earned 500 total points
ID: 24069598
Do you have a console cable for the unit?  It's pretty easy to set up.  A little bit of CLI.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24069683
I can get into the router from hyperterminal and get around a little bit.  I just don't know exactly what to do.  Here is my current configuration:

Current configuration : 1694 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname u255009
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool gt
   import all
   network 65.246.8.244 255.255.255.252
   default-router 65.246.8.245
   dns-server 198.6.1.1
   lease 10
!
!
ip domain name ALTER.NET
ip name-server 198.6.100.38
ip name-server 198.6.1.1
ip name-server 198.6.1.2
ip name-server 198.6.1.38
!
!
!
!
!
interface FastEthernet0/0
 ip address 65.246.8.245 255.255.255.252
 speed 100
 full-duplex
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 bandwidth 1536
 no ip address
 no ip redirects
 no ip proxy-arp
 encapsulation frame-relay IETF
 no fair-queue
 service-module t1 timeslots 1-24
 frame-relay lmi-type ansi
!
interface Serial0/0/0.500 point-to-point
 ip unnumbered FastEthernet0/0
 no cdp enable
 no arp frame-relay
 frame-relay interface-dlci 500 IETF
!
interface Dialer0
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 ppp authentication chap
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/0.500
!
!
no ip http server
no ip http secure-server
ip nat pool gt 10.2.1.1 10.2.2.1 netmask 0.0.0.255
ip nat inside source list 1 interface Dialer0 overload
!
!
!
!
control-plane
!
!
!
line con 0
 password cisco
 login
 transport preferred none
line aux 0
 password cisco
 login
 modem InOut
 transport preferred none
 transport input all
 transport output all
 stopbits 1
 flowcontrol hardware
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24069735
I am assuming that fast0/0 is your internet connection or is it interface Serial0/0/0.500 point-to-point?  This will dictate how we go forward?  What is the inside address for your network, are your client computers running a private address?  If not, can you renumber the network?
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24069754
Other question, do you have any devices that you would need ports forwarded to, IE mail, web, RDP?
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24069800
FYI, you should just beable to go in to enable mode, then config t.
here are the base commands for put 10.2.2.1 on fast ether0/0 and basic NAT.
Just cut and paste.  It will work as soon as the config is pasted to the unit.  If everything works then type "wr" at the "#" prompt.  Is will also turn off DHCP on your fastethernet 0/0.  If you need any port forward, let me know and I will send you the commands.

IP Subnet-zero


no ip dhcp pool gt

interface FastEthernet0/0
 ip address 10.2.2.1 255.255.255.0
 speed auto
 duplex auto
 IP Nat Inside


ip cef

no ip dhcp use vrf connected
no ip dhcp pool gt
   

ip domain name ALTER.NET
ip name-server 198.6.100.38
ip name-server 198.6.1.1
ip name-server 198.6.1.2
ip name-server 198.6.1.38

interface Serial0/0/0.500 point-to-point
 ip address 65.246.8.245 255.255.255.252
 no cdp enable
 no arp frame-relay
 frame-relay interface-dlci 500 IETF
 no ip directed-broadcast
 ip nat outside



access-list 1 permit 10.2.2.0 0.0.0.255
ip nat inside source list 1 interface Serial0/0/0.500 overload
ip nat translation timeout 3600
ip nat translation tcp-timeout 3600
ip nat translation udp-timeout 3600
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24069807
The fast 0/0 is the internet connection from the router to the switch right now.  I have the static ip setup on the server with all my info and I can connect there.

The static IP address is:  65.246.8.246

I believe the inside address for my network is current 10.0.1.15
Currently I was running a DSL connection and I believe that default gateway was set to the above address so that should be it.

The clients are just obtaining IP automatically.

I don't believe I have any devices where I need ports forwarded.  Is there a way to confirm on my current setup though?
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24069816
Where is the DSL connected to?  Is the DSL your internet connect, you state something about a T-1? Are we dealing with two network here? The router or is it comming from a bridge device? Sounds like something is missing?  could you give me a little digram of your network? Also, when you are done you really need to change your telnet and enable password.  They are in your config!
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24069817
Do you want your internet connect to go thru the DSL or thru the T-1?
0
 

Expert Comment

by:3l3mn8r
ID: 24069821
I dont see any Internet DNS addressing in the config.  Does this router receive its internet connection from another router at the end of the PPP connection or do you have a server handing out public DNS pr is your internet coming in on fa 0/0?  If your fa 0/0 is your ethernet you should have public ip name servers in there somewhere.

ip name-server 63.90.67.10 63.90.67.11  

This the public DNS for one of our providers.  You will need to call your internet service provider to find out what yours are.
0
 
LVL 42

Expert Comment

by:paulsolov
ID: 24069831
The DNS servers are there:  198.6.1.1, 198.6.1.2 are MCI external DNS servers
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24069832
The DHCP Server should supply the DNS information on the network, if not then the router can be configed to to the same.
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24069834
What kind of server in on the inside of this network?
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24069849
Okay here's the current setup.

We have DSL where the modem plugs into the switch.  The server and all clients are also connected to the switch.

The IP settings for the DHCP on the server are range of 10.1.1.129-10.1.1.199

The default gateway is: 10.1.1.1
DNS is 10.1.1.1

I know it said the gigabit ethernet adapter on the server is 10.1.1.15, but my local area connection is 10.1.1.13 on the server.

I only switched over the T1 to test it.  The setup for the T1 is that the T1 goes into the Cisco 1840 router.  The F0/0 port is going out to the switch.  The server is currently connected to the switch and I input the IP, subnet mask, dns server, default gateway into the local area connection and it connects and then I got on to the router from hyperterminal from there.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24069851
I would rather set it up so the DHCP on the windows server still ran DHCP.  I can disable DHCP on the router.  I just don't know what to do to get the client computers connectivity.
0
 

Expert Comment

by:3l3mn8r
ID: 24069856
Ahh, paulsolov, you are right.  I quickly went through the configs looking for public dns servers.  It does appear he has a server handing out dns name servers. I see an import on dhcp pool with the 192.168.1.1 entry.  

gzarnick, could you post an ipconfig /all for one of your workstations.  It may help us see where you are getting your addressing from and if it is correct. Since your server is handing out your dhcp then you may have to look at it as well, nevertheless your client network settings can surely help.

0
 
LVL 1

Expert Comment

by:woodall01
ID: 24069872
Is the T-1 replacing the DSL?
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24069876
Is this sever running Exchange?  If so, how do you get your mail?
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24069881
Do you have a console cable connected to the Router?
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24071679
Yes.  The T1 is replacing the DSL connection.  The email is IMAP.

I do not have a console cable connected to the router.  I can get into the router through hyperterminal though.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24071762
I am going into my office soon and will post a IPCONFIG from our current setup on a workstation.  
The only reason the Cisco router config has the DNS server and DHCP stuff is that I was trying to get it to work and put it in there.

Here are my new settings:

Network:  62.246.8.244 /30
Router IP:  62.246.8.245
Subnet:  255.255.255.252
DNS:  198.6.1.1-198.6.1.5
Usable Range:  62.246.8.246
0
 
LVL 3

Expert Comment

by:qualchoice-it
ID: 24071818
dont forget to add your IP-Helper if your going to use a internal Windows DHCP server

config t

IP Helper "Ipaddress of DHCP server"
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24071821
Well, that makes it a little harder.  we need to do some tricking to make this work.
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24071824
IP Helper "Ipaddress of DHCP server"  is not needed if they are in the same segment only if they are remote to DCHP server.
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24071848
Paste this into the router

interface FastEthernet0/1
 ip address 10.1.1.254 255.255.255.0
 speed auto
 duplex auto
no shut

plug fast0/1 into you switch, then you will need to telnet to 10.1.1.254.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24071876
I'll be going in very shortly and will post my current DSL setup ipconfig.  
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24071884
Don't worry about the onfig from the DSL,  I will just need your IP address config for you internal network.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24071893
I will post your above info woodall.  Should I post the other stuff into the router as well that you posted before?
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24071903
How do I find my IP address config for my internal network?
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24071926
IPconfig on one of the desktops
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072010
Okay.  Currently connected to my DSL on a client station.  Here's the IPConfig info:

IP address:  10.2.1.184
Subnet:  255.255.255.0
Default Gateway:  10.2.1.1
DHCP Server 10.2.1.13
DNS Server:  10.2.1.1

I will want to give the server the static IP address of 62.246.8.246 whenever I switch over to the T1 though.
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072021
You will need to telnet to the router and go to the # prompt. Then go to Config t mode.  Then paste the following command in.

interface FastEthernet0/1
 ip address 10.2.1.254 255.255.255.0
 speed auto
 duplex auto
no shut
Then plug the ether0/1 in to your switch, and try telneting to it from one of the workstations.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072039
Where should the cable from FE 0/0 be plugged into?
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072051
For the config please plug a second cable into FE0/1,  you will need to reconfig FE0/0 and you will loose connect to it once you start with the reconfig
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072067
Okay I tried telnetting to no avail.  I think I have the configuration incorrect.

What should my ip settings be on the server?  I changed the local area connection settings to the:

IP: 65.246.8.246
Subnet:  255.255.255.252
Gateway:  65.246.8.245
DNS:  198.6.1.1

I have my server plugged into the switch.  I have FE 0/0 plugged into the switch and FE 0/1 plugged into the switch
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072072
DO you want me to do it for you?
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072080
If you can do for me that would be great.  I appreciate everything very, very much.

I just think I'm screwing something up because I still can't telnet from a workstation
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072089
try telneting to the rotuer now at 10.2.1.254
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072095
okay that worked!
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072097
once you telnet to the unit, change the IP address of the server back to your inside address.
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072100
I need to make sure you unbind 65.246.8.246 from you network, we need that IP address to make this work.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072118
Okay I'll change the IP back, but when I do I lose connectivity.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072123
Okay it's changed back.  I'll go on the internet on my phone to communicate with you.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072148
Okay I'm up now on a laptop.  
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072174
telnet to the router and type reload. If if asks to save current config DON"T answer yes.  Let me know when that is done.
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072194
In fact just turn it off the back on.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072215
okay that's done.
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072246
I need you telnet to the router, and type enable, then config t, then let me know when you are there.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072249
I noticed the green lights on FE 0/1 went out.  Is that okay?
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072254
Oh hold on
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072258
try it now
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 5

Author Comment

by:gzarnick
ID: 24072268
green lights still aren't on and I can't telnet
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072273
try now
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072275
They are on and I'm in.
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072289
are you in conf t mode?  If so, the cut and paste the following

interface FastEthernet0/0
 ip address 10.2.2.1 255.255.255.0
 speed auto
 duplex auto
 IP Nat Inside

Then

interface Serial0/0/0.500 point-to-point
 ip address 65.246.8.245 255.255.255.252
 no cdp enable
 no arp frame-relay
 frame-relay interface-dlci 500 IETF
 no ip directed-broadcast
 ip nat outside


Let me know when that is done.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072312
okay all of that is in..
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072320
is your dsl modem still pluged in, if so unplug it
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072324
No. The DSL is unplugged
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072337
see if you can ping 216.53.130.2 from one of the workstations.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072339
I also just wanted to make sure the ip address for FE0/0 should be what you posted above as 10.2.2.1

just because I know on my DSL the gateway and DNS were 10.2.1.1??
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072342
no i changed it to 10.2.1.1
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072343
Yes.  I pinged that address fine.
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072344
I need to use the other IP address to unblnd the address
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072345
oh okay.  thank you
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072347
try browsing the internet
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072354
are you hosting anything thing on that server that I might need to forward ports to?  IMAP, SMTP, SSL, HTTP?
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072358
It didn't go to any page.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072361
no.  nothing is hosted on the server
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072363
Is your DNS forwaing on your server?
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072368
You are getting out, sound like a DNS issue
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072369
No.  DNS is not on the server
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072374
Should DNS on the DHCP still be 10.2.1.1

0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072377
There is the DNS server? nevermind, let me see what I can do.
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072383
try it now
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072389
Nope.  It still won't go to a page.
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072392
could you change the dns on desk to
198.6.100.38
198.6.1.1


And then try it.
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072400
nevermind, try it again
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072402
with the old DNS ip address.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072404
Yeah the desktop worked now.

Should I change it to that on DHCP.  A
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072407
Which one did you use?  I had to make one other change to the router.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072409
It's working!!!

Now can I setup my static IP on the server?

Should I use:

IP:  65.246.8.246
Subnet:  255.255.255.252
Gateway:  65.246.8.245
DNS:  198.6.1.1
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072410
I'm using the old one.  10.2.1.1
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072412
NO, NO, NO. Use something else.  you will your connection. If you need to use a private IP address on that server.
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072416
What is the IP address of the server before you changed it?
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072420
Okay so just leave everything how it is now!

So the server will not have a static IP?
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072422
The server didn't have a Static IP previously.  Well not an external static IP.  I just have it set as

10.2.1.13
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072424
an inside address, yes. If you need anything forwarded to it the we do thru translastion
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072430
Alright.  THANK YOU SOOOOO VERY VERY MUCH!!!

I hope you understand how much I appreciate this!  I know I took up tons of your time and probably a little frustrated with my inexpertise!  THANK YOU!
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072433
Use that address, and you are done. last thing, you need to change your passwords.

From the config t mode
enable secret  (what ever password you want execpt cisco)

line vty 0 4
password (what ever password you want execpt cisco)
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072438
I guess close this out I and I guess get the credit!
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24072448
Okay passwords are changed!

Thanks again!!!
0
 
LVL 5

Author Closing Comment

by:gzarnick
ID: 31566676
This Expert was amazing!!!! Thank you sooo much!
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072458
Don't forget to secure that router.
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24072459
Last thing type wr from a # prompt then you are done!!
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24078102
Hi woodall,

Sorry to bother you again.

I actually do need a couple ports forwarded:  3389 and 1723

Can you let me know what to input.  Thanks
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24078130
I will need your password for the router.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24078168
ok.  the password is gt
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24078191
I also need the IP address of the server you want these ports forwarded to.
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24078232
10.2.1.13
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24078348
done
0
 
LVL 5

Author Comment

by:gzarnick
ID: 24078392
It works!  Thanks again!

I have two open questions that I posted previous to this one if you want to post I can allot you points there.

http://www.experts-exchange.com/Hardware/Networking_Hardware/Routers/Q_24295101.html
http://www.experts-exchange.com/Hardware/Networking_Hardware/Routers/Q_24293993.html
0
 
LVL 1

Expert Comment

by:woodall01
ID: 24078429
Sure, do I need to post there first?
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Cisco 1830 AP behaving wierdly 7 64
High Density Switches 8 38
Need to separate small office by VLAN... 3 56
Managed vs unmanaged switches 8 49
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now