Solved

Cisco 971 and two Windows 2000 Server Subnets Routing Problem

Posted on 2009-04-05
5
516 Views
Last Modified: 2013-12-05
Hi Experts,
I am using a Cisco 871 router to interface between 2 subnets as follows:
VLAN1 : 10.10.10.0/29 on fe1(10.10.10.1) : Used for Router administration only

VLAN2:  192.168.0.0/24 on fe0 (192.168.0.253):  Subnet 1 - Administration Subnet
The Administration Subnet has a Windows 2000 Server (192.168.0.2) - ADMIN1-with 1 NIC.  This server connects to the internet via a 3COM Router.

VLAN3:  192.168.16.0/24 on fe2(192.168.16.253): subnet 2 - Labs Subnet.
The LABS Subnet also has a Windows 2000 server (192.168.16.2) - LABS1-with 2 NICs. This server acts as the internet Router for the Labs Subnet via RRAS.

fe4 on the Router is disabled.
.
From within the Router (via telnet) I can ping fe0,fe2, ADMIN1, LABS1). Each Server can ping it's respective port on the Router but not each other!
 The running config for the Router is below.  If I connect 2 PCs to the respective ports, they can ping one another - but not the servers!  Therefore I am assuming that a routing problem existis on the servers.
I added a static route to the LABS server (192.168.0.0 255.255.255.255 192.168.0.253) but this did not work ( I know I forgot the metric).
All suggestions welcome. Thank you for your help.  

!This is the running config of the router: 10.10.10.1

!----------------------------------------------------------------------------

!version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname router1

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

username admin privilege 15 secret 5 $1$1NIU$fc81TDDVS3AvKrgR97zET0

no aaa new-model

ip subnet-zero

ip cef

!

!

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool sdm-pool

   import all

   network 10.10.10.0 255.255.255.248

   default-router 10.10.10.1 

   lease 0 2

!

!

ip domain name preskilkenny.local

ip ips po max-events 100

no ftp-server write-enable

!

!

!

! 

!

!

!

interface FastEthernet0

 switchport access vlan 2

 no ip address

 no cdp enable

!

interface FastEthernet1

 no ip address

 no cdp enable

!

interface FastEthernet2

 switchport access vlan 3

 no ip address

 no cdp enable

!

interface FastEthernet3

 switchport access vlan 4

 no ip address

 no cdp enable

!

interface FastEthernet4

 description $ETH-WAN$

 ip address dhcp client-id FastEthernet4

 shutdown

 duplex auto

 speed auto

 no cdp enable

!

interface Vlan1

 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

 ip address 10.10.10.1 255.255.255.248

 ip nat inside

 ip virtual-reassembly

 ip tcp adjust-mss 1452

!

interface Vlan2

 ip address 192.168.0.253 255.255.255.0

!

interface Vlan3

 ip address 192.168.16.253 255.255.255.0

 ip mask-reply

!

interface Vlan4

 no ip address

!

ip classless

!

!

ip http server

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

ip nat inside source list 1 interface FastEthernet4 overload

!

no cdp run

!

!

control-plane

!

banner login ^C

-----------------------------------------------------------------------

Cisco Router and Security Device Manager (SDM) is installed on this device. 

This feature requires the one-time use of the username "cisco" 

with the password "cisco".
 

Please change these publicly known initial credentials using SDM or the IOS CLI. 

Here are the Cisco IOS commands.
 

username <myuser>  privilege 15 secret 0 <mypassword>

no username cisco
 

Replace <myuser> and <mypassword> with the username and password you want to use. 
 

For more information about SDM please follow the instructions in the QUICK START 

GUIDE for your router or go to http://www.cisco.com/go/sdm 

-----------------------------------------------------------------------

^C

!

line con 0

 login local

 no modem enable

 transport preferred all

 transport output all

line aux 0

 transport preferred all

 transport output all

line vty 0 4

 privilege level 15

 login local

 transport preferred all

 transport input telnet ssh

 transport output all

!

scheduler max-task-time 5000

end

Open in new window

0
Comment
Question by:freshfordian
  • 3
  • 2
5 Comments
 
LVL 9

Accepted Solution

by:
craigothy earned 400 total points
ID: 24071136
Basically, wherever you have a client or server whose default gateway is not the cisco router, then you are going to have to add a static route on the windows machine that routes those network segments.

For example, on the ADMIN1, you would need the following:
route add 192.168.16.0 mask 255.255.255.0 192.168.16.253
Sounds like you already have your route statement on the LABS server:
route add 192.168.0.0 mask 255.255.255.0 192.168.0.253

Once that is setup, you should be able to ping between the servers as a test.  You will have to add routes to each workstation also that doesn't point to the cisco router as the default gateway.
0
 
LVL 1

Author Comment

by:freshfordian
ID: 24075093
Thank you craigothy.  
I'll add the static routes to the servers ths  morning and let you know how it works out.
Each subnet has it's own respective DHCP server that points to it's own respective default gateway
for internet access.
  I'm assuming that the static routes setup on each server will handle inter-subnet communications.

.
0
 
LVL 1

Author Comment

by:freshfordian
ID: 24183985
Hi Craigorthy

Our School was closed for Easter and re-opned today.  So I could only add the static routes until today
I regret the delay in responding to you.

 I can ping the router from either server. I can ping the respective gateway from eirhter server but I still cannot ping one server from the other.  My ping results are below.

If I conect the router between 2 PCs, set static ips from both subnets on both and add a static route on both, I can ping each PC respectively.  I am therefore convinced that I have a routing problem on the servers.  Your advice would be welsomce. Thanks for your help to date
C:\>ping 192.168.16.253
 

Pinging 192.168.16.253 with 32 bytes of data:
 

Reply from 192.168.16.253: bytes=32 time<10ms TTL=2

Reply from 192.168.16.253: bytes=32 time<10ms TTL=2

Reply from 192.168.16.253: bytes=32 time<10ms TTL=2

Reply from 192.168.16.253: bytes=32 time<10ms TTL=2
 

Ping statistics for 192.168.16.253:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% l

Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum =  0ms, Average =  0ms
 

C:\>ping 192.168.0.253
 

Pinging 192.168.0.253 with 32 bytes of data:
 

Reply from 192.168.0.253: bytes=32 time<10ms TTL=25

Reply from 192.168.0.253: bytes=32 time<10ms TTL=25

Reply from 192.168.0.253: bytes=32 time<10ms TTL=25

Reply from 192.168.0.253: bytes=32 time<10ms TTL=25
 

Ping statistics for 192.168.0.253:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% l

Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum =  0ms, Average =  0ms
 

C:\>ping 192.168.0.2
 

Pinging 192.168.0.2 with 32 bytes of data:
 

Request timed out.

Request timed out.

Request timed out.

Request timed out.
 

Ping statistics for 192.168.0.2:

    Packets: Sent = 4, Received = 0, Lost = 4 (100%

Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum =  0ms, Average =  0ms
 

C:\>

Open in new window

0
 
LVL 9

Expert Comment

by:craigothy
ID: 24184398
Can you post the results of the "route print" command from each server?
0
 
LVL 1

Author Comment

by:freshfordian
ID: 24203212
Hi Croadorthy,
routinh was incorrect pn Labs server.  Once corrected, the system works fine now

Thanks for all your h
0

Featured Post

Do email signature updates give you a headache?

Do you feel like you are constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

Join & Write a Comment

If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
This article will cover setting up redundant ISPs for outbound connectivity on an ASA 5510 (although the same should work on the 5520s and up as well).  It’s important to note that this covers outbound connectivity only.  The ASA does not have built…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now