Setup Cacti on remote server


I have installing a Cacti on Ubuntu host. I managed to setup the Cacti.

The problem is, i cannot monitor remote server. The remote server is running Centos. I already install snmp on remote server and configure it. But i cannot find what goes wrong. The UDP port 161 is already open at firewall side.

I also refer to:

But i'm disappointed it not producing any graph.

Anybody have suggestion?

Who is Participating?
WizRd-LinuxConnect With a Mentor Commented:
if the RRD doesn't exist, which it would appear (Check via a shell or file manager first) delete the graph and re-create it.

If it does exist you could be looking at a permissions issue.
From the box that has Cacti installed, are you able to use the command snmpwalk -c public -v2c <ip address of remote box>

Does it give any response?
smksaAuthor Commented:
Yes, the snmpwalk -c public -v2c <ip address of remote box> able to give response.

The only problem is that the cacti , cannot display the graph image, i can see the graph is generated, but the graph image is not available.

Does it because of the php GD or other issue ?
If the web server user is able to write to the rrd directory it should be fine.

In Cacti check out "Utilities -> System Utilities -> View Poller Cache" and see if you graph is listed in there, also check that the Cacti Log isn't reporting any errors.  Running the graph generation in debug mode can also help you track down problems.

Graph Management -> Select Graph -> *Turn On Graph Debug Mode to left to see if the rrd file exists where it should and any errors being reported by rrdtool.
smksaAuthor Commented:

I found the following , may i know how to fixed it ?

RRDTool Command:

/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start=-86400 \
--end=-300 \
--title="Switch Rack G4 - Traffic - 1/1" \
--rigid \
--base=1000 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit=0 \
--vertical-label="bits per second" \
--slope-mode \
DEF:a="/usr/share/cacti/site/rra/switch_rack_g4_traffic_in_81.rrd":traffic_in:AVERAGE \
DEF:b="/usr/share/cacti/site/rra/switch_rack_g4_traffic_in_81.rrd":traffic_out:AVERAGE \
CDEF:cdefa=a,8,* \
CDEF:cdefe=b,8,* \
AREA:cdefa#00CF00:"Inbound"  \
GPRINT:cdefa:LAST:" Current\:%8.2lf %s"  \
GPRINT:cdefa:AVERAGE:"Average\:%8.2lf %s"  \
GPRINT:cdefa:MAX:"Maximum\:%8.2lf %s\n"  \
LINE1:cdefe#002A97:"Outbound"  \
GPRINT:cdefe:LAST:"Current\:%8.2lf %s"  \
GPRINT:cdefe:AVERAGE:"Average\:%8.2lf %s"  \
GPRINT:cdefe:MAX:"Maximum\:%8.2lf %s\n"
RRDTool Says:

ERROR: opening '/usr/share/cacti/site/rra/switch_rack_g4_traffic_in_81.rrd': No such file or directory

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.