Solved

IPv4 Static address showing 169.254 address... I cannot access the internet

Posted on 2009-04-05
22
1,833 Views
Last Modified: 2012-06-27
Hello all,

I have PC with Windows Vista and the IPv4 Static address showing 169.254 address with no connection.  I do not have any idea how to resolve this issue.  Any help will be greatly appreciated.  Thank you.
0
Comment
Question by:fcoit
  • 8
  • 6
  • 4
  • +3
22 Comments
 
LVL 2

Expert Comment

by:ReinisB
Comment Utility
What do you mean "no connection"?  The PC will default to a 169.254 IP address if there are no DHCP servers available and it doesn't have a specified 192.168 address.

If you have cables connected, it sounds like the cables, or the NIC is bad.
0
 
LVL 6

Expert Comment

by:Kentrix70
Comment Utility
You get an adress from the APIPA function in Windows, which means, that no DHCP server is detected on the network,
so it is getting an auto-assigned adress.
If this is not what you expect, you should check out for network problems (wires etc.)
to find out why your pc can not contact the DHCP server (which could be at your ISP or given from your local router, if you got one).
0
 

Author Comment

by:fcoit
Comment Utility
Thanks guys for your prompt response.  I am totally ignorant of networking lingo, so please bare with me.  I have other PCs communicating through the same router without any problems is just this one computer that when I run ipconfig from the command prompt I see is not getting the correct address.  How can I resolve this issue?  Can you please give me any hints?  Thank you.
0
 
LVL 6

Expert Comment

by:Kentrix70
Comment Utility
Try to run

ipconfig /release

ipconfig /renew

to let the client try to get an address from the router.
0
 

Author Comment

by:fcoit
Comment Utility
I see the 169.254 instead of the 192.168.  I cannot get internet access.
0
 
LVL 2

Expert Comment

by:icsi_wiz
Comment Utility
what is your network like?
Do you have more then one computer? if so, do the other computers work?

are you wireless, or wired?

if wired, and other connections are working, then take one of the other connections and connect it to your computer to verify that it is or is not your computer that is the problem.

if wireless, a common issue with wireless gives your this same result when you have saved the wrong wireless access code (password.) If this is the case you will need to delete that wireless connection and create a new connection.

0
 

Author Comment

by:fcoit
Comment Utility
Thanks Kentrix70.

I tried ipconfig/release and got a "No operation can be performed on Wireless Network Connection while it has its media disconnected."
0
 
LVL 6

Expert Comment

by:Kentrix70
Comment Utility
Are you trying to get an address wia wireless networking, or through wired network?
We have sometimes experienced, that when we started some of our labtops at the company,
if the network cable was not connected, when they turned those labtops on, the network card was
disabled, and they experienced that the labtop tried to get an address from a wireless network.
0
 

Author Comment

by:fcoit
Comment Utility
I am trying wireless networking, but even if I tried wired network I got the same message.
0
 
LVL 6

Expert Comment

by:Kentrix70
Comment Utility
Try to shut your pc down, remove all power from it,
connect a network cable, put in the powercable,
start it up, and see, what is happening.
0
 

Author Comment

by:fcoit
Comment Utility
I tried what you suggested and did not work.
0
How does your email signature look on mobiles?

Do your employees use mobile devices to reply to emails? With mobile becoming increasingly important to the business world, it is in your best interest to make sure that your email signature looks great across all types of devices.

 
LVL 6

Expert Comment

by:Kentrix70
Comment Utility
Try to run ipconfig /all in a prompt and provide the output for us.
0
 
LVL 27

Expert Comment

by:Lukasz Chmielewski
Comment Utility
try with static ip, the router does not have to be dhcp server - see what are the ip addressess on other computers. then pick one that is not present in the network and just enter it in your wifi card management.
0
 
LVL 10

Expert Comment

by:sublifer
Comment Utility
It sounds like you aren't even connecting to your network.  Do you have an integrated wireless adapter (internal on a laptop) or is this an add-on or plug in card? Has this machine connected to a network before or otherwise displayed that it has a functioning network adapter?  Could you please let us know a bit more about the hardware? Type, brand and model of computer? Type, brand and model of network adapters, both wired and wireless?

One possible problem is that the router you are trying to connect and pull DHCP from has a limit address pool and all of its IP addresses are already assigned.
0
 

Author Comment

by:fcoit
Comment Utility
Thanks everyone for your input.  I am currently away from home so I cannot give you any more feedback as soon as I get back I will try what you all are suggesting and give you more info.  Thanks again.
0
 
LVL 2

Expert Comment

by:icsi_wiz
Comment Utility
try reseting the TCP/IP stack. Go to the command prompt as Administrator. This can be done easy enough by using the search box in the Vista startmenu type 'cmd' and wait for the result. with the right mouse button click on the cmd.exe icon and choose 'Run as Administrator.' Click the continue button, then at the command prompt type:
   netsh winsock reset
then press enter.

You'll need to restart the PC after this done. If it's the stack it should be fixed.

If you're using any Windows OS before Windows Vista try using a utility called: winsockxpfix.exe. It will rebuild your TCP/IP stack. Sometime malware will leave the stack corrupted, and this easy utility will put it put together. I don't think it's compatible with vista, but with all others it works great.
here some good info about winsockxpfix.exe:
http://www.pchell.com/winsockxpfix/index.shtml
0
 
LVL 10

Expert Comment

by:sublifer
Comment Utility
Just wondering if there was any update?
0
 

Author Comment

by:fcoit
Comment Utility
Hello all,

I apologize for not getting back to you sooner.  Here is the feedback of all your recommendations.

Kentrix70  here is what I got when I run the ipconfig/all  -- see code
Roads_Roads - With regard to ip static and I am not sure what should I put on the dsn
icsi_wiz -  My system came with Vista and was working just fine.  I run the netsh winsock reset  and nothing happen.

I would really appreciate if you have any more hints.  Thank you all for your suggestions.  
C:\Windows\system32>ipconfig/all
 

Windows IP Configuration
 

   Host Name . . . . . . . . . . . . : family-PC

   Primary Dns Suffix  . . . . . . . :

   Node Type . . . . . . . . . . . . : Hybrid

   IP Routing Enabled. . . . . . . . : No

   WINS Proxy Enabled. . . . . . . . : No
 

Wireless LAN adapter Wireless Network Connection:
 

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Network Con

nection

   Physical Address. . . . . . . . . : 00-1B-77-92-BB-08

   DHCP Enabled. . . . . . . . . . . : Yes

   Autoconfiguration Enabled . . . . : Yes

   Autoconfiguration IPv4 Address. . : 169.254.138.180(Preferred)

   Subnet Mask . . . . . . . . . . . : 255.255.0.0

   Default Gateway . . . . . . . . . :

   NetBIOS over Tcpip. . . . . . . . : Enabled
 

Ethernet adapter Local Area Connection:
 

   Media State . . . . . . . . . . . : Media disconnected

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Broadcom NetLink (TM) Fast Ethernet

   Physical Address. . . . . . . . . : 00-1A-A0-FE-37-D6

   DHCP Enabled. . . . . . . . . . . : Yes

   Autoconfiguration Enabled . . . . : Yes
 

Tunnel adapter Local Area Connection* 6:
 

   Media State . . . . . . . . . . . : Media disconnected

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface

   Physical Address. . . . . . . . . : 02-00-54-55-4E-01

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes
 

Tunnel adapter Local Area Connection* 7:
 

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : isatap.{8CCFE54F-D655-4CEE-B403-242672BA8

6C5}

   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

   Link-local IPv6 Address . . . . . : fe80::5efe:169.254.138.180%12(Preferred)
 

   Default Gateway . . . . . . . . . :

   NetBIOS over Tcpip. . . . . . . . : Disabled
 

Tunnel adapter Local Area Connection* 9:
 

   Media State . . . . . . . . . . . : Media disconnected

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : isatap.{0D7F6E20-4D37-4DF4-8E12-C5FE63E44

83A}

   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

Open in new window

0
 
LVL 10

Expert Comment

by:sublifer
Comment Utility
Yup, you aren't even connected to the network.  I assume when you did this you weren't trying wired as it mentioned "Media disconnected"

As for the wireless, lets see if we can figure how to get you connected.  How close is the wireless router to the computer? Has it been working before from this same position? If so, what changes were recently made to the machine?  I see three tunnel adapters listed, could those be recent and the cause of your issues?

One thing you can try is: Make your way to the network connections screen, one at a time, click on a connection and press the delete key on your keyboard to delete it.  Get rid of all of them and then reboot your PC.  It will recreate your network connections and you should be able to connect the wireless like as if it was a new computer.
0
 

Author Comment

by:fcoit
Comment Utility
I already recreating my network connections.  As far as distance I am about one feet away from the router.  And before this I did not have any problems with the connections.  This started after my cousins were browsing, so who knows what they did.  Thank you.
0
 
LVL 6

Accepted Solution

by:
Kentrix70 earned 500 total points
Comment Utility
I think you should attach a network cable to your computer and check out if you get an ip-adress that way,
and perhaps list the ipconfig /all output again.
If this works, then we know for sure, that the problem that prevent you from getting wireless access, can be
in the router or the wireless setup on your computer.

If it is not working, then you should get wired network on your computer to work before you try to fix problems with wireless network.
As always - keep it simple :-)
0
 
LVL 10

Expert Comment

by:sublifer
Comment Utility
Maybe your cousins changed some of the config settings on the router?  Perhaps they enabled mac address filtering on the router and without your mac listed it won't allow you to connect?  Have you tried resetting the routers config?  Most routers have a button on the back, sometimes you have to use a paperclip to get at it, you hold the button in for about 10 seconds, let go and it resets. Some routers may have a slightly different method to do the reset.
0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

Case Summary: In this Article we introduce the new method to configure the default user profile using Automated profile copy with sysprep rather than the old ways such as the manual copy of a configured profile to default user profile Old meth…
Remote Apps is a feature in server 2008 which allows users to run applications off Remote Desktop Servers without having to log into them to run the applications.  The user can either have a desktop shortcut installed or go through the web portal to…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now