Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

XP Workgroup File/Folder Shares - sharing fails

Posted on 2009-04-05
56
Medium Priority
?
772 Views
Last Modified: 2012-05-06
I added a second HDD to a file-sharing computer in a 5 computer (all XP) workgroup.
The primary HDD (SATA) has a C and D partition - D partition shares are accessible from all computers.
I added an IDE HDD (E: drive) for additional space and set the sharing identical to the D:

None of the other computers can connect to the E: drive share.

Why can they all connect to the D: share, but not the E:?

Thanks
0
Comment
Question by:younghv
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 25
  • 11
  • 7
  • +5
56 Comments
 
LVL 44

Accepted Solution

by:
Davis McCarn earned 800 total points
ID: 24073446
Plain and simple; there must be some difference in the shares......
If you are using Norton or McAfee, you may need to tell its firewall to allow the new access.  Otherwise; there is some difference in either the groups or the user permissions on the new drive.  Right-click My Computer, left-click Manage, and inspect the shared folder and user sections.
0
 
LVL 70

Expert Comment

by:KCTS
ID: 24073560
Check BOTH the share permissions and the NTFS Security permissions.
0
 
LVL 26

Expert Comment

by:PCBONEZ
ID: 24073564
I agree with DavisMcCarn.

When you are on the host machine do the individual folders on that drive show as shared or just the whole drive?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 38

Author Comment

by:younghv
ID: 24073620
All -
Thanks - I have tried it both ways.
Drive AND Test Folder "Shared" and - ONLY - Test Folder "Shared".

All permissions/All users is full control.

All boxes are running AVG-Pro.

I played around with this quite a bit before posting the question and - believe me - I hope it is something simple, but nothing comes to mind.
0
 
LVL 98

Expert Comment

by:John Hurst
ID: 24073657
I don't think you have really answered the post by KCTS fully.

Is Drive E: an NTFS-formatted drive? And have you put a folder with files in this drive? (I'm sure you have, but I am just checking).

Have you tried to map the drive manually? NET USE X: \\pcname\E$ to see what you get.
... Thinkpads_User
0
 
LVL 38

Author Comment

by:younghv
ID: 24073769
NET USE X: \\pcname\D_Sharename (works).
NET USE X: \\pcname\E_Sharename (Fails - 'cannot connect' error).

<<All permissions/All users is full control.>>

Both drives formatted NTFS.

From all other computers, I can 'see' the Share on the E: Drive - Double-clicking or "NET USE" attempts all fail out.
0
 
LVL 98

Expert Comment

by:John Hurst
ID: 24073818
Something is wrong with the drive (it certainly thus appears).

Is it a dynamic drive? Was it moved in from another machine?

Main drive is SATA (not an XP natural). Do you have the most modern adapater for the SATA drive? Not that I think that would make any difference.

The IDE drive is thus on a different controller. What says Drive Management? Right Click MY Computer and Select Manage. Is the driver for the IDE drive up-to-date? Is the IDE drive in PIO mode? That will make it very, very slow, but should not affect drive mapping.

Is the PC happy with two different controllers? Should be.
... Thinkpads_User
0
 
LVL 38

Author Comment

by:younghv
ID: 24073820
Correction:
NET USE Z(or L or M, etc): \\pcname\E_Sharename (Fails - 'cannot connect' error).
0
 
LVL 98

Expert Comment

by:John Hurst
ID: 24073859
It does not matter what drive letter you use, assuming no conflicts.

However to be sure, look at what drive letters have been used (Open Windows Explorer -> Tools -> Map Network Drive and look at the pull down box for starters).

Then try NET USE Z: /delete and replace Z with all used letters.

This is truly a shot in the dark. ... Thinkpads_User
0
 
LVL 38

Author Comment

by:younghv
ID: 24073861
On the actual 'Share' computer - full access to the 2nd HDD.
Very quick data transfer, no problems of any kind.

I did not check for DMA vs PIO - I thought that was set during the discovery of 'New Hardware'.

0
 
LVL 98

Expert Comment

by:John Hurst
ID: 24073937
Try backing up the file on your extra drive, clear all the partioning on it and re-formatting it. Do not use Quick Format (given all the issues).  and while I am it, is the drive too big for your XP BIOS. And also while I am at it, I had a strange problem with a client that had updated automatically to SP3. Much to my surprise, additional memory cleared the error. Make sure you are at SP3 and make sure each machine has 2Gb of memory.  ... Thinkpads_User
0
 
LVL 44

Assisted Solution

by:Davis McCarn
Davis McCarn earned 800 total points
ID: 24076860
I hate to make the asker wait another five days, so will go back to the original problem.......
Now that we know it is AVG, have you tried either disabling the firewall (temporarilly) or ensuring that it is set to trust your local IP address range?  While it was before AVG cleaned up AVG 8, I had fits with a server where the AVG firewall kept juming in and denying access.
0
 
LVL 38

Author Comment

by:younghv
ID: 24077003
DavisMcCarn - thanks for posting again.

I have tried all of the tricks I know - enabling/disabling ICS, playing with AVG, mapping with IP address, etc.

None of the other computers have a problem connecting to the D share, so the typical stuff doesn't seem to be the problem.

All other computers can 'see' the shared folder on the E (secondary) drive - they just can't open it to see the test file inside.

The NET USE command executes without error, there is a shared printer on that computer and all other computers have been able to 'add' that printer, from the computer itself I have full access to that second drive -- in short, everything works as expected - except remote access to that IDE drive.

I will be going back on-site tomorrow morning and probably just take along a spare SATA drive. The actual backup files that the customer uses are only 1.5 GB in size, so the D share is more than sufficient to the task - it is just that the problem was so vexing that I was hoping I had simply over-looked something elemental.

Feel free to post any other thoughts and I will respond from the site about 24 hours from now.

Thanks,
Vic
0
 
LVL 38

Author Comment

by:younghv
ID: 24077138
I am 'objecting' to my own deletion request and ask that a Moderator edit my comments as he/she sees fit.
I will keep this open and continue working with the other Experts.
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 24078729
Hi younghv - anything specific in the event logs (from client or server) in these instances?
Personally, I can't see this being a firewall issue - netbios/smb requests would be disrupted for 'all' shares - never heard of a firewall selectively blocking/misdirecting any to a specific device/share...

When you say they can't connect to the E share - are you referring to the admin share (E$) or some folder-sharing on that drive?

To eliminate any drive letter conflicts, use
net use * \\remotePC\e$ (or share name on e - depending on answer to above question)...

Also, I'd be curious if you type
net use \\remotepc\ipc$
(if you get a successful message), can you then navigate to the share by using Start->Run->\\remotepc\sharename ??

Lastly - check your incoming connections.  You mentioned only 5 nodes, but I'd be curious how many incoming connections that counts as...(just clarifying as I don't know the full scope of the network).

Try  net config server from a command line - post that here, if you can (mask sensitive data).
0
 
LVL 38

Author Comment

by:younghv
ID: 24079314
sirbounty - I might be having a 'DOH!' moment when I go back tomorrow.
4 computers connecting to the printer share + 4 computers connecting to the D: share ... I wonder if I have exceeded the 10 connection limit.

Details tomorrow - thank you.
Vic
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 24079362
net config server will tell you the idle session time as well - I'm sure you know how to reduce that, if needed...
However, I don't think it totals smb for each partition, so you should be good - just tossing that out there.
0
 
LVL 98

Expert Comment

by:John Hurst
ID: 24083498
You did not tell us about the printers in your first post. If your assertion is true, you can purchase an inexpensive print server, put the printer on that, and your connections will be reduced by half.

0
 
LVL 38

Author Comment

by:younghv
ID: 24085252
thinkpads_user - I have gone out of my way to avoid escalation and I would really appreciate it if you would go find some other questions to work on.
Good discussion here that all Experts should read and evaluate.
http://www.experts-exchange.com/Other/Expert_Lounge/Q_24238764.html 
0
 
LVL 58

Assisted Solution

by:tigermatt
tigermatt earned 400 total points
ID: 24085582
Vic,

Just to add my $0.02:

It might be worth checking the path in the registry where shares are actually defined. I somewhat doubt the cause will be evident in checking this, but you will be able to see any differences between the configuration of the working shares compared with the dead one.

The path you're looking for is:

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Shares

In there, you can see each of the shares listed by name, and the properties of each entry is the share configuration settings. Just compare it to one of the other working shares and see if there are any differences.

As I said, I somewhat doubt it's this and is likely something a LOT simpler, but it's worth checking the raw configuration data.

-Matt
0
 
LVL 38

Author Comment

by:younghv
ID: 24085623
Hey Matt - thank you for that. I will add it to my 'to-do' list.

FWIW - I had the same problem on my home network last night (4 XP Pro computers + Vista + WIN7). I did all the normal trouble-shooting (and swearing) - then found a "w32time" error on my share computer. As soon as I synched the time, the problem went away.

If I find out that this was the error when I get on-site, I'm going to kick my butt all the way over to that small island you occupy. LOL!

Vic
0
 
LVL 44

Expert Comment

by:Davis McCarn
ID: 24086002
Is the error you get on the Test folder  "access denied"?
If it is, did you create users on the shared computer that match the logins of the systems that access it and do they have passwords that match at both ends?
I still kepp thinking its in AVG's firewall; but, I can also see one of M$'s security updates changing the default permissions for new shares.  You might fiond ACLView useful: http://www.freewarefiles.com/NCS-Z-toolshe-ACLView_program_8049.html
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 24086080

If a peer-to-peer workgroup has any similarities to an Active Directory domain (in that it uses Kerberos, which I'm sure it does), then a time synchronization error could definitely be the cause. As you know, these sorts of services don't work if the time (always compared internally in GMT, to avoid time zone clashes :-) ) is out by more than 5 - 15 minutes.

Let us know how you get on,

-Matt
0
 
LVL 38

Author Comment

by:younghv
ID: 24086138
@DavisMcCarn - the nutty part of this whole thing is: "Why can I access the "D" share from all computers -- but not the "E" share?

BTW - this is just the AVG-Pro 8.5 -- no firewall. I install hardware firewalls for all my clients and don't need the hassle of futzing around with third-party software firewalls.
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 24086162
>> third-party software firewalls

Which are not as secure as a proper NAT firewall with SPI and all the other advanced features, anyway. :-)
0
 
LVL 38

Author Comment

by:younghv
ID: 24086701
Netgear FVS114 - I've got a stack of them (spares) under my workbench.
0
 
LVL 38

Author Comment

by:younghv
ID: 24087848
Some new errors.
I used the suggested command from sirbounty and got the 'password is invalid' message.
When I manually entered the same username and password that I am currently logged in (to this remote computer) I got the 'Mulitple connections' error.

I am going to break all connections and try the e$ connection again.

C:\>net use \\newthree\e$
The password is invalid for \\newthree\e$.

Enter the user name for 'newthree': work
Enter the password for newthree:
System error 1219 has occurred.

Multiple connections to a server or shared resource by the same user, using more
 than one user name, are not allowed. Disconnect all previous connections to the
 server or shared resource and try again..
0
 
LVL 67

Assisted Solution

by:sirbounty
sirbounty earned 800 total points
ID: 24087870
perform a
net use * /del <Enter>

You can also check the incoming connections on the remote machine (GUI route) using:
Start->Run->fsmgmt.msc <Enter> - check sessions/open files to ensure a complete disconnect.

Which command gave you the invalid message?
How are you initially connecting to the target device?  Are you using the same username/password combo on all systems?
0
 
LVL 38

Author Comment

by:younghv
ID: 24087958
Right on username password (work/double-secret password).
I have a persistent map to the D partition (\\Newthree\QBHost)

C:\>net use * /del
You have these remote connections:

                    \\Newthree\_Data
                    \\newthree\ipc$
Continuing will cancel the connections.
0
 
LVL 38

Author Comment

by:younghv
ID: 24087971
btw - I am typing this from the remote computer - but can switch to the 'share' computer if needed.
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 24087976
Ok - if you kill all of them and then just connect via ipc:

net use \\newthree\ipc$
(optionally specify /user:)

Can you then use:

Start->Run->\\newthree\d$
and
Start->Run->\\newthree\e$

?
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 24088018
Listening - let's see if we can get this working
0
 
LVL 38

Author Comment

by:younghv
ID: 24088076
C:\>net use \\newthree\ipc$
The command completed successfully.

Then I tried Start->Run->\\newthree\d$
Got long error message pop up -- \\newthree\d$ is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again.

Note: if I have managed to break the 'D' share connection, I am going to start drinking early today.
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 24088134
"nuttin wrong wit dat" :^)

Ok, so I think I need a bit more detail...this system is connecting to both shared folders and at least one shared printer on the target pc, correct?
How is that happening?  Presumably you've got persistent mappings setup?  Or do you have some logon script generating those connections?
Also - how is the printer connecting?  Did you force that connection to an LPT1 assignment or what?

Check the incoming on the target - what do you show in sessions (noted above)?

And please - to verify - you have all in the same workgroup?  All are SP3?
 
Lastly - check the network security model:

Start->Run->gpedit.msc <Enter>
Navigate to Computer Config \ Windows settings \ Security settings \ Local Policies \ Security Options
Beneath there - right-side, you'll see:
Network access: Sharing and security model for local accounts (should 'not' be Guest only)
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 24088149

I'd reboot the box, then try to connect to \\newthree\d$ and \\newthree\e$ (without initiating the \\newthree\ipc$ connection first). See what happens.

-Matt
0
 
LVL 38

Author Comment

by:younghv
ID: 24088299
OK - from the remote computer (I will log back in from the Share in a minute):
Security Model is "Classic - local users authenticate as themselves."
Pinters were add with the Add Printer Wizard.
"Shared Folders" PLUS the printer - all computers - check

I mapped the share settings with:
net use y: \\newthree\QBHost /persistent:yes
(Did not do a script or batch command - but that is the part that is working.

I just found one XP Home computer in the mix - but not the one I am working on right now.
All same workgroup, same username, all SP3.

Let me go to the Share computer and log on.
0
 
LVL 32

Expert Comment

by:willcomp
ID: 24088428
Vic,

You may want to share with everyone else what happened when a Vista PC was added to the mix. Now I'll leave it with the real network experts.

Dalton
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 24088473
Please - don't distract him...
It's taking him a half hour just to walk across the room.
I'm thinking an office that size should have their own local IT, no? :^D
0
 
LVL 38

Author Comment

by:younghv
ID: 24088513
Sorry Matt - I didn't refresh.
Anyway, the Bookkeeper is doing a reconciliation, so I can't get on the other computer.
Logged back in to the remote.

However - and this is weird ...
Inside the 'Share' I created on the E drive is another folder named "NewE" that I have access to.

I can get there from this (XP Pro) and from the Vista notebook they just added.

Soooooooo - I can't get to the Shared Drive (E) and I can't get to the Shared Folder (_DATA), but I CAN get into the shared folder (NewE) inside of that.

Is this nuts - or what?

At this point, I am just going to connect the computers to "NewE" (for data backup) and go find a bar.

Any comments/wisecracks cheerfully accepted - with the caveat that I have already said "WTF" 17 times.
0
 
LVL 44

Expert Comment

by:Davis McCarn
ID: 24088520
hmmmm......  I don't know if I'm learning something new here; but, I thought the default shares required remote administration rights and that you weren't supposed to use them.  I always create a new share (which might well wind up as "E")
I did though, have another thought.  Was there an "E" drive before you added the new hard disk?  If it existed as a mapped drive to another computer or one of those wonderfully pesky memory slots in either the computer or the shared printer, we could be chasing ourselves around for days!  How about disconnecting the new drive temporarilly and seeing if something else appears as "E"?  If it is a memory card slot, change its drive letter with disk management.
0
 
LVL 38

Author Comment

by:younghv
ID: 24088571
<<I'm thinking an office that size should have their own local IT, no? :^D>>

They had their own guy who quit (with no notice) to go be a programmer. In addition to all of his other successes here, he wired the office with CAT 3 cable .... 3 years ago.

Maybe I'll just open up remote sharing and let you guys fix all this stuff at 500 poinks per problem.

=))
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 24088575

Can you clarify? You can browse to \\PC\share\newE, or is newE shared (so \\PC\newE directly)?
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 24088578
"Inside the 'Share' I created on the E drive"
which share is that?

Apparently I presumed you had admin rights - but that is correct the $ shares are left for admin usage only.  Thus you're better off creating your own if they're not admins.

Your saying it's weird also leads me to believe you didn't create it?

"can't get to the shared folder _Data)" - I recall a thread on that with the _ in the share name when Vista was involved (though I still have no luck with EE's search feature, so... meh).

Still a little early for the bar though, don't you think?  What will the boss say?
0
 
LVL 38

Author Comment

by:younghv
ID: 24088643
DavisMcCarn -
Good proof that I haven't done the best job of giving details.

The 'Share' computer causing all this grief is a brand new box that I brought in and installed.
The additional HDD was already installed when I brought it in.

All that was on the computer was the OS and AVG.
0
 
LVL 38

Author Comment

by:younghv
ID: 24088710
\\newthree is the computer
E: is the 2nd HDD
E$ is not accessible
\\newthree\_DATA (share) is not accessible

The literal path of \\newthree\_DATA\NewE IS accessible.
NewE is a 'Shared Folder' and it is accessible with:
\\newthree\NewE

This is a landscaping\contruction outfit - so everyone drinks for lunch - I'll just tell the boss is was a 'conference'.

The "Work" account and password are the same on all computers - and has full Admin rights.
0
 
LVL 67

Assisted Solution

by:sirbounty
sirbounty earned 800 total points
ID: 24088748
I didn't hear confirmation that the accounts were/were not admins?
If not - then E$ would not be accessible and that would close that up.

What's the abs path to _Data on newthree?  E:\_Data?  Shared out everyone/full?  What's the acl on it? (cacls e:\_Data)
Reasoning for _?  Have you tried with simply E:\Data shared as Data?
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 24088765
...and you cheated...
Ok, admin answered - which does beg why they can't access $ shares - what about E:\Data$ - is that accessible?

...and if I'm holding you up from your, er, "lunch", do feel free to reply whenever you're done "eating"...
0
 
LVL 38

Author Comment

by:younghv
ID: 24088851
Busted :^D

I'm going to have access to that computer in a few minutes.
The "_" is just something I've been pre-pending to my BAK or DATA folder forever.
Makes them list first in Windows Explorer (in other words, no reason).

Back when I can get to the other one.
0
 
LVL 38

Author Comment

by:younghv
ID: 24089272
Anyone got a dunce cap I can borrow?

Finally got to the computer in question.
I mucked up the 'Share Name' on this computer.

The Shared Folder is named "_Data".
... The "Share Name" is NewE.

I still don't understand the permissions errors with E$, but the connection error was based on my misnaming/double-naming the actual Shared Folder.

All of you are now eligible for all the beer you can drink the next time I am in your city.

sirbounty - here is the cacls info:

C:\>cacls e:\_data
e:\_DATA BUILTIN\Administrators:(OI)(CI)F
         NEWTHREE\me:F
         CREATOR OWNER:(OI)(CI)(IO)F
         Everyone:(OI)(CI)F
         NT AUTHORITY\SYSTEM:(OI)(CI)F
         BUILTIN\Users:(CI)(special access:)
                           SYNCHRONIZE
                           FILE_WRITE_DATA

         BUILTIN\Users:(CI)(special access:)
                           SYNCHRONIZE
                           FILE_APPEND_DATA

         BUILTIN\Users:(OI)(CI)R
0
 
LVL 38

Author Comment

by:younghv
ID: 24089385
C:\>cacls e:
E:\ BUILTIN\Administrators:(OI)(CI)F
    CREATOR OWNER:(OI)(CI)(IO)F
    Everyone:(OI)(CI)F
    NT AUTHORITY\SYSTEM:(OI)(CI)F
    BUILTIN\Users:(CI)(IO)(special access:)
                          SYNCHRONIZE
                          FILE_WRITE_DATA

    BUILTIN\Users:(CI)(special access:)
                      SYNCHRONIZE
                      FILE_APPEND_DATA

    BUILTIN\Users:(OI)(CI)R
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 24089503
All of you are now eligible for all the beer you can drink the next time I am in your city.

Careful what you put in print - you're well aware of the limited geography separating us and the rather large frame that I posses... ;^)

Ok so it looks like the actual connection to the share desired is working correctly now, yes?
The only outstanding is the lack of administrative share access to E$?

Please confirm shares on server device using net share from a command prompt (just to ensure you haven't tried to be equally clever in creating a E_$ share that is causing confusion).  No need to post unless something appears out of the norm.

acl on E: is correct if the user is an Admin.
Presumably the 'me' account is your own masked version?
0
 
LVL 38

Author Comment

by:younghv
ID: 24096931
Too true - it is only about 800 air miles from Anchorage to Point Barrow - I'll drop down and bring money.

About this question ... although the problem was created by my own mistakes, there are a variety of good questions/comments/suggestions that might help out a future reader.

I am amenable to closing this one any way you guys like - just post your recommendations and I'll make it happen.

Thank you for your time.

Vic
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 24097008
V - the decision is entirely yours and I'll have no ill response towards any assignment or combination of points.
If any of my comments were in any way helpful, feel free to select with the minimum allotment necessary to include those comments in the PAQ.
And certainly if they rated beneath other input, feel free to exclude altogether - I only hopped on board to help out a fellow musher.
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 24097211
^^ I agree with the above.
0
 
LVL 44

Expert Comment

by:Davis McCarn
ID: 24100545
I feel dumb that I didn't suggest browsing My Network Places as it would have shown the problem right from the getgo; but, I don't feel like I answered this one either.
0
 
LVL 38

Author Closing Comment

by:younghv
ID: 31566848
LOL!
"Dumb" is changing the default share name and not remembering that you did it.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

pc, laptop  monitor connection configurations
In the modern office, employees tend to move around the workplace a lot more freely. Conferences, collaborative groups, flexible seating and working from home require a new level of mobility. Technology has not only changed the behavior and the expe…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question