Solved

Windows Server 2003 SP1 upgrade and now services won't start

Posted on 2009-04-05
3
527 Views
Last Modified: 2013-12-05
Late i know, but we've just installed SP1 for Windows Server 2003 and we're now having problems with Services not starting.  We first noticed it coz the BackupExec backup jobs were failing due to the BackupExec service not starting.  Upon further investigation we saw that it was other services that weren't stating as well.  See below


The Event log contains the following errors

############################

Event Type:      Error
Event Source:      Service Control Manager
Event Category:      None
Event ID:      7023
Date:            03/04/2009
Time:            22:57:48
User:            N/A
Computer:      
Description:
The Backup Exec Device & Media Service service terminated with the following error:
The class is configured to run as a security id different from the caller

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


############################
Event Type:      Error
Event Source:      Service Control Manager
Event Category:      None
Event ID:      7009
Date:            03/04/2009
Time:            22:57:48
User:            N/A
Computer:      
Description:
Timeout (30000 milliseconds) waiting for the DCOM Server Process Launcher service to connect.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

##############################

Event Type:      Error
Event Source:      Service Control Manager
Event Category:      None
Event ID:      7023
Date:            03/04/2009
Time:            22:57:48
User:            N/A
Computer:      
Description:
The Automatic Updates service terminated with the following error:
The class is configured to run as a security id different from the caller

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

######################

Event Type:      Error
Event Source:      Service Control Manager
Event Category:      None
Event ID:      7022
Date:            03/04/2009
Time:            22:59:05
User:            N/A
Computer:      
Description:
The COM+ Event System service hung on starting.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

##########################



We think it might be something to do with DCOM but can't find a definitlve fix for our situation, i.e. post 2003 SP1 upgrade  Anyone had similar experiences post Windows Server 2003 SP1 upgrade?

Cheers
0
Comment
Question by:kswan_expert
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 95

Expert Comment

by:John Hurst
ID: 24073929
None. I am now at SP2 on my client servers. Try going to SP2 and see if that helps.
... Thinkpads_User
0
 

Author Comment

by:kswan_expert
ID: 24073940
Cheers Thinpad - we tried installing SP2 but that hangs and then uninstalls, eventually.  So we want to try and fix what we have.
0
 
LVL 95

Accepted Solution

by:
John Hurst earned 500 total points
ID: 24073956
At this point, I would open a case with Microsoft. It is a Server, and they should assist you. They have always assisted me. Something sounds wrong because I had no problems of any kind with SP1 on IBM servers, and no problems going to SP2. I had one issue getting to SP2 with a DELL server, but I we fixed that by downloading SP2 and applying manually.

I had a conversation with my support vendor and they suggested that applying fixes in order before applying SP2 was useful in some circumstances but that wound up not applying to my clients. Still I thought I would mention it.

Call Microsoft tomorrow morning. ... Thinkpads_User
0

Featured Post

Salesforce Has Never Been Easier

Improve and reinforce salesforce training & adoption using WalkMe's digital adoption platform. Start saving on costly employee training by creating fast intuitive Walk-Thrus for Salesforce. Claim your Free Account Now

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
local administrator password solution 26 104
Anything wrong with Window server backup? 8 144
Cannot find SCCM 2012 online lab 4 24
Exchange password change on mobile 2 109
Problem Description: Actually I found the below issue with some customers after migration from SMS 2003 to SCCM 2007 and epically if they change site code, some clients may appear in the console with old site code, plus old sites still appearing …
Know what services you can and cannot, should and should not combine on your server.
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question