Autodiscover certificate error

I recently upgraded exch2003 to 2007 and removed 2003 , but When I open outlook it is showing certificate error. autodiscover.domain.com.
I have created a A record  'autodiscover.domain.com' in DNS server. Even after that the same error is coming.

Furthermore, An error is showing up when they click send/recieve button
0x8004010f.an object could not be found.
I have changed the internal and external url to the common url. and
I have removed the OAB and recreated, but still showing the same error.

Your help is highly appreciated.
Thanks
Muhammed Asif
LVL 29
MAS (MVE)Technical Department HeadAsked:
Who is Participating?
 
MAS (MVE)Connect With a Mentor Technical Department HeadAuthor Commented:
?
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
When I click send/recieve it will come up to 97% and end up with the same error
'Microsoft exchange reported error (0x8004010f). The operation failed, An object cannot be found'.

Awaiting your reply
Muhammed Asif

0
 
Hendrik WieseConnect With a Mentor Information Security ManagerCommented:
The possible cause would be:

If the Outlook 2007 client resides on a different subnet than the Exchange 2007 server,
and the router that connects from the subnet listen to TCP Port 443 (HTTPS), the auto discover
mode of Outlook 2007 and Exchange 2007 may fail due DNS name resolution issue or/and unavailable
socket on the router that can support SSL connection.
This failure occur due a certificate mismatch that Outlook 2007 try to use to create a
secure channel between the client to the server.

Resolution:
If you are using Cisco (For example) network equipment, you can disable the listen to TCP Port 443 (HTTPS) by using the command:
"no ip http secure-server"
Its recommended to consulate the vendor documentation, before applying any new settings.
Also, use "NSLOOKUP" command, to verity correct DNS settings for the record:
autodiscover.yourdomainname.com
http://msexchangeteam.com/archive/2006/11/15/431502.aspx

Please let me know if this helped?
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
MAS (MVE)Technical Department HeadAuthor Commented:
disable the listen to port 443. This I have to do it in cisco switch or firewall (PIX).
Because we are using cisco PIX and cisco switch.

Thanks
Muhammed Asif
0
 
Hendrik WieseConnect With a Mentor Information Security ManagerCommented:
Do it on both the Switch and Firewall.
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
Sorry for the late response
'no ip http secure-server'
This command is not working on both switch and pix.

Thanks
Muhammed Asif


0
 
Hendrik WieseInformation Security ManagerCommented:
Please let me know what models you are using so I can send you the correct command?
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
Catalyst 3590, and PIX 506E
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.