Forefront detecting all emails as virus, "Exceeded Realtime Timeout"

Hi All

All our internal emails that are being sent are coming up with the following Quarantine Message:

File Quarantined

The original contents of this file has been replaced with this message because of its characteristics.
File name: "Body of Message"
Virus name: 'Exceeded Realtime Timeout"

Even if emails do not have any attachments, ie. just plain text the above error is sent to the recipient of the message.

Our Exchange 2007 mailbox store also has MS Forefront installed on that box

I've checked for the following things:

-Disabling each of the 5 default Scan engines
-Restarted Forefront Services
-Increased Max Container Scan Time parameter to 4 - 10 mins
-Rebooted server

all which had no effect on stopping internal messages from being quarantined.

For the interim I've changed in (Forefront's General Settings) the Realtime Scan Timeout Action parameter and have set it to Skip: detect only to at least allow for mail to flow.
I'm a bit uncomfortable with leaving this setting on.

Has anyone experienced this before? I'm not too sure on how to resolve this issue, any advice would be greatly appreciated.
racineskAsked:
Who is Participating?
 
racineskConnect With a Mentor Author Commented:
Just letting you know that this article helped us out http://support.microsoft.com/kb/939411
It turns out that Norman scan engine updates have caused these issues

This is what we did to fix it:

1. Open the Forefront engines folder C:\Program Files (x86)\Microsoft Forefront Security\Exchange Server\Data     \Engines\x86
2. Rename the Norman folder to Norman.old (so that Forefront will not load the corrupted Norman engine)
3. Open Registry Editor
4. Locate the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Forefront Server Security\Exchange Server
5. Create a new DWORD value EngineDownloadTimeout under this key
6. Change its value data to 1200 (decimal)
7. Restart Forefront services
8. Update Norman engine

This resolved our issue, but I found that the server's memory usage was abnormally high so I disabled the Norman engine and used another one instead.

0
 
Mechanic_KharkovCommented:
It seems that You change wrong parameter. Try to change the maximum time limit to scan a message (default is 5 minutes).
And "Max Container Scan Time" is for compressed content only.
0
 
racineskAuthor Commented:
Just letting you know that this article helped us out http://support.microsoft.com/kb/939411
It turns out that Norman scan engine updates have caused these issues

This is what we did to fix it:

1. Open the Forefront engines folder C:\Program Files (x86)\Microsoft Forefront Security\Exchange Server\Data     \Engines\x86
2. Rename the Norman folder to Norman.old (so that Forefront will not load the corrupted Norman engine)
3. Open Registry Editor
4. Locate the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Forefront Server Security\Exchange Server
5. Create a new DWORD value EngineDownloadTimeout under this key
6. Change its value data to 1200 (decimal)
7. Restart Forefront services
8. Update Norman engine

This resolved our issue, but I found that the server's memory usage was abnormally high so I disabled the Norman engine and used another one instead.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.