Solved

multiple smtp connectors with multiple domains problem

Posted on 2009-04-06
11
673 Views
Last Modified: 2012-05-06
Hi Guys
I have this strange problem with two smtp connectors. We did updates in the weekend and after the updates the smtp connectors are not functioning properly.

What I've got is multi domain exchange 2003 environment.
On this server I've configured two smtp connectors.

The first does the address space of * with cost of 5, it uses dns to route traffic out.
The delivery restrictions accepts mail from everyone except one group.

The second has the address space of * with a cost of 10, it uses a smart host to route traffic.
The delivery restrictions reject mail from everyone except one group.

Prior to the weekend everyone would go through the main smtp connector except the memebers of the group which would go via the smart host.
Today everyone is going via the smart host (trying to), the smart host will only allow a specific domain so all mail not from that domain will bounce.

If I remove the smart host and use dns both smtp connectors work as they should, so connector 1 will deal with mail for everyone and connector 2 will deal with mail for that group. As soon as I change the 2nd connector to use the smart host suddenly everyone goes via the smart host as if its become a global setting.

I've run out of idea's as to what the reason is, I originally thought we had misconfigured the connectors and the updates had just stopped that but I know its configured correctly now, it's just not working since the updates. I've recreated the connectors, verified the restrictions reg key hasn't been unset.
I've double checked the smtp virtual server and it doesn't magically start using a smart host after the connector is changed.

Help!

OS is 2003 with SP2 and all updates up to march
Exchange is 2003 with SP2
0
Comment
Question by:dj_relentless
  • 8
  • 2
11 Comments
 
LVL 12

Expert Comment

by:florin_s
ID: 24075299
Hi,

What errors do you get in event log and can you provide the updates(KB's) that you have installed.
0
 
LVL 4

Author Comment

by:dj_relentless
ID: 24075455
The only error events that show in the event log are the ones for the mail bouncing because the smarthost only accepts mail from one domain. I have the server logging at max for mstransport.
I can provide I list of installed kb's tomorrow (which is tonight for the us)
0
 
LVL 12

Expert Comment

by:florin_s
ID: 24075708
only the last kb's that you installed, that presumably cause the problem
0
 
LVL 15

Expert Comment

by:abhaigh
ID: 24076361
"I've double checked the smtp virtual server and it doesn't magically start using a smart host after the connector is changed."

No - you have to re-initialize it before it will use the new settings

So, after you change the config, remember to roll the virtual machine (and maybe the smtp service for good measure)
0
 
LVL 4

Author Comment

by:dj_relentless
ID: 24081316
After making the changes to the smtp connector I am restarting the smtp service, routing engine and mta stacks as per ms recommendation.

So just that we're clear, I have 1 smtp virtual server and 2 smtp connectors. I'm not changing the config on the virtual server, only the connectors.

I couldn't get the dates on some of the updates so I'll list all without dates as well. We didn't do any exchange updates during this round, only OS updates.

Hotfix report date: 4/7/2009 8:08:42 AM

OS version: Microsoft(R) Windows(R) Server 2003, Enterprise Edition
SP version: Service Pack 2
OS language: English

Hotfixes Identified:
HotFixID: Q147222
Description:
InstalledBy:
InstallDate: (none found)

HotFixID: KB933854
Description: Security Update for Windows Server 2003 (KB933854)
InstalledBy:
InstallDate: (none found)

HotFixID: SP1
Description: Microsoft .NET Framework 1.1 Service Pack 1
InstalledBy:
InstallDate: (none found)

HotFixID: KB911829
Description: Update for Exchange Server 2003 (KB911829)
InstalledBy: administrator
InstallDate: (none found)

HotFixID: KB912442
Description: Security Update for Exchange Server 2003 (KB912442)
InstalledBy: administrator
InstallDate: (none found)

HotFixID: KB916803
Description: Security Update for Exchange Server 2003 (KB916803)
InstalledBy: administrator
InstallDate: (none found)

HotFixID: KB924334
Description: Update for Exchange Server 2003 (KB924334)
InstalledBy: username
InstallDate: (none found)

HotFixID: KB926666
Description: Update for Exchange Server 2003 (KB926666)
InstalledBy: username
InstallDate: (none found)

HotFixID: KB931832
Description: Security Update for Exchange Server 2003 (KB931832)
InstalledBy: username
InstallDate: (none found)

HotFixID: KB937653
Description: Hotfix for Exchange Server 2003 (KB937653)
InstalledBy: username
InstallDate: (none found)

HotFixID: KB950159
Description: Security Update for Exchange Server 2003 (KB950159)
InstalledBy: username
InstallDate: (none found)

HotFixID: KB959897
Description: Security Update for Exchange Server 2003 (KB959897)
InstalledBy: username
InstallDate: (none found)

HotFixID: Q827429
Description: FIX: ASP stops responding when calling Response.Redirect to another server using msxml4 sp2
InstalledBy: username
InstallDate: (none found)

HotFixID: Q927978
Description: FIX: ASP stops responding when calling Response.Redirect to another server using msxml4 sp2
InstalledBy: username
InstallDate: (none found)

HotFixID: Q936181
Description: Security update for MSXML4 SP2 (KB936181)
InstalledBy: username
InstallDate: (none found)

HotFixID: Q954430
Description: Security update for MSXML4 SP2 (KB954430)
InstalledBy: username
InstallDate: (none found)

HotFixID: IDNMitigationAPIs
Description: Microsoft Internationalized Domain Names Mitigation APIs
InstalledBy: username
InstallDate: (none found)

HotFixID: NLSDownlevelMapping
Description: Microsoft National Language Support Downlevel APIs
InstalledBy: username
InstallDate: (none found)

HotFixID: KB925398_WMP64
Description: Security Update for Windows Media Player 6.4 (KB925398)
InstalledBy:
InstallDate: (none found)

HotFixID: KB961260-IE7
Description: Security Update for Windows Internet Explorer 7 (KB961260)
InstalledBy: username
InstallDate: 3/6/2009

HotFixID: KB952069
Description: Security Update for Windows Server 2003 (KB952069)
InstalledBy: username
InstallDate: 3/6/2009

HotFixID: KB954600
Description: Security Update for Windows Server 2003 (KB954600)
InstalledBy: username
InstallDate: 3/6/2009

HotFixID: KB955839
Description: Update for Windows Server 2003 (KB955839)
InstalledBy: username
InstallDate: 4/3/2009

HotFixID: KB956802
Description: Security Update for Windows Server 2003 (KB956802)
InstalledBy: username
InstallDate: 3/6/2009


HotFixID: KB958687
Description: Security Update for Windows Server 2003 (KB958687)
InstalledBy: username
InstallDate: 3/6/2009

HotFixID: KB958690
Description: Security Update for Windows Server 2003 (KB958690)
InstalledBy: username
InstallDate: 4/3/2009

HotFixID: KB960225
Description: Security Update for Windows Server 2003 (KB960225)
InstalledBy: username
InstallDate: 4/3/2009

HotFixID: KB960715
Description: Security Update for Windows Server 2003 (KB960715)
InstalledBy: username
InstallDate: 3/6/2009

HotFixID: KB967715
Description: Update for Windows Server 2003 (KB967715)
InstallDate: 3/6/2009
0
Do email signature updates give you a headache?

Do you feel like you are constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

 
LVL 4

Author Comment

by:dj_relentless
ID: 24083383
I did spot this post on a different site which is an identical problem except I'm using different cost for the connectors.
http://www.tech-archive.net/Archive/Exchange/microsoft.public.exchange.admin/2005-06/msg04091.html
0
 
LVL 4

Author Comment

by:dj_relentless
ID: 24091357
No one come across this before?? I'm thinking of making the call to ms today.
0
 
LVL 4

Author Comment

by:dj_relentless
ID: 24092469
Well I've put an incident through to Premier support so we'll see what they came back with.
0
 
LVL 4

Author Comment

by:dj_relentless
ID: 24142346
Prem support is currently looking at the regtraces but no answer yet.
0
 
LVL 4

Author Comment

by:dj_relentless
ID: 24164560
Alright issue is finally sorted.
End of the day we had a bad configuration for what we were trying to do.
The recommended configuration for this is to have a second smtp virtual server acting as the bridgehead for the 2nd smtp connector. Once this was done mail flowed correctly.
In our particular case we also had to add the fqdn of the server to the spn of the machine account so clients would authenticate against the new virtual server correctly.
For future people that read this, the spn change is done via adsiedit.msc , you should be able to find a while paper on it.

Can a mod please close this question now.
0
 
LVL 4

Accepted Solution

by:
dj_relentless earned 0 total points
ID: 24164814
If anyone is wondering, no there are no current whitepapers that describe this configuration. This recommendation came straight from Prem support.
0

Featured Post

Do email signature updates give you a headache?

Do you feel like you are constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

Join & Write a Comment

ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Not sure what the best email signature size is? Are you worried about email signature image size? Follow this best practice guide.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now