?
Solved

ACPI.sys Causing system instability

Posted on 2009-04-06
4
Medium Priority
?
1,213 Views
Last Modified: 2012-05-06
Hi Experts,

I recently had my system Process running very high. It was taking between 60 - 80% of my processing power.

I installed process explorer and so i was able to dbl click the system process to see which threads were causing the problem. I found that it was ACPI.sys that was causing me grief. Through Process explorer you are able to suspend the thread which i did and found that i had no more problems. CPU instantly dropped to around 2%.

I have not installed anything recently nor have changed anything. There was a micosoft update from what i can see but thats it.

Last night i decided to restart my server as i had the need to and completely forgot about this Process and so naturally it tried to restart but it seemed to have frozen. CPU must have reached 100% and stayed there.

I came in this morning and had to restart again. It took a long time to reboot and cutting a long story short i stopped the ACPI.sys thread and it was running better. Today however everything is not running perfectly as i am seeing the CPU jumping all over the place and at times reaching 100%. Even after aplying my quick fix.

Now after a little research i found the location to be c:\windows\system32\drivers\acpi.sys. I read some forums saying this can be deleted and other saying no. I renamed the file to .old and saw that the system just created a new one.

Does anyone know what i should do. Is there a patch for this. Is anyone else having this problem. I seemed to have identified the source but not sure what i need to do with it. I am not even completely sure if it was the microsoft update. how can i check and see the latest update. Is this through add/remove programs and then do a search on the KB....

Also just to eliminate spyware as a possible course. I ran 5 scans using different well recognised programs and they all reported no  spyware

Please can someone help.

Ps:

I have a SBS server 2003 std edition.
0
Comment
Question by:DCHMIEL
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 7

Assisted Solution

by:dolomiti
dolomiti earned 150 total points
ID: 24076026
hi,
could you tell us about HW?
When you shutdown the machine (no reboot),
does it poweroff correctly (with acpi going or not) ?
bye
vic
0
 
LVL 2

Author Comment

by:DCHMIEL
ID: 24076466
Hi There,

It powers off absolutely fine. The problem must occu when the system is loading again and the ACPI.sys thread loads again from its suspended status. Thus taking all the CPU ussage.

I have a dual core 3.4, 2GB Ram
Fiitsue server
SBS 2003 SP2
150GB Disk

Not sure what HW you wanted. I do feel the hardware is fine however.


0
 
LVL 10

Accepted Solution

by:
sublifer earned 1350 total points
ID: 24078654
ACPI.sys handles advanced power management functions.  First off, if you're using a newer OS and older hardware you may see issues like you are describing and you may want to disable Windows power management (essentially the same as you're doing by suspending it in process explorer)

If this is recent activity on an older and unchanged system then you may be seeing the first signs of a hardware failure.  The power supply may not be able to provide the correct stable voltages, the motherboard's power circuits may be failing or even the processor's circuits are experiencing severe electron migration.

Please go to the Control Panel > Power Options and verify the "Power scheme" is set to "always on", "Turn hard disks off" is set to never, and on the Hibernate tab that hibernation is not enabled (may want to check this first as I believe setting to "Always on" will disable the hibernate feature.  If this resolves your problems then it may have just been a driver problem.  If this does not solve it you can disable power management in the system bios.  

Just because these may "fix" your problem does not mean you don't have a hardware issue.  You may want to find some diagnostics from your hardware vendor to see if any hardware problems may be apparent.

0
 
LVL 2

Author Comment

by:DCHMIEL
ID: 24135745
Hi,

The above power options were default.

I spent many hours researching this problem and did not find a definite fix. I had however come across a forum where someone had reseated thier RAM and all signs of the problem was gone. I did the same and my problem went away. Now im not saying that if anyone is having this problem it will fix it but i would check all hardware is correctly seated in the machine: ie hard drives, memory, any cards etc

So Far so good and will be monitoring it.

Thx for the suggestions above and will split the points
0

Featured Post

Does Your Cloud Backup Use Blockchain Technology?

Blockchain technology has already revolutionized finance thanks to Bitcoin. Now it's disrupting other areas, including the realm of data protection. Learn how blockchain is now being used to authenticate backup files and keep them safe from hackers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question