?
Solved

deployment error weblogic solaris

Posted on 2009-04-06
4
Medium Priority
?
575 Views
Last Modified: 2013-12-10
Hi,
 While starting weblogic in solaris machine. i am getting the following error

# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  SIGSEGV (0xb) at pc=0xfeceb5c8, pid=11011, tid=11
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_11-b03 mixed mode, sharing)
# Problematic frame:


# V  [libjvm.so+0xeb5c8]
#
# An error report file with more information is saved as hs_err_pid11011.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#

Any help is highly appreciated

Regards
Rk
0
Comment
Question by:radhnki
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 10

Expert Comment

by:rajesh_bala
ID: 24078389
Can you post hs_err_pid11011.log

It would be present in the same folder where you started weblogic or in the JDK folder
0
 
LVL 10

Accepted Solution

by:
rajesh_bala earned 1500 total points
ID: 24078430
Well, looks like you started weblogic in non-production mode. That is why JVM started with client mode.

can you do this and try again.

1. edit setDomainEnv.sh
2. Search for PRODUCTION_MODE=
3. Most likely it may not have any values set. If no value is set, set to PRODUCTION_MODE=true

PRODUCTION_MODE="true"
export PRODUCTION_MODE

Also, MEM_ARGS="-Xms256m -Xmx512m" (by default)
set it to MEM_ARGS="-Xms512m -Xmx768m"

Now, start your weblogic with startWeblogic.sh

When it starts check -server is added to java (it happens only its started in production mode).

That should solve the problem mostly.

The memory arguement I gave is not a hard and fast value. Based on your system memory you can adjust it. However, 256M was a little lower.
0
 
LVL 10

Expert Comment

by:rajesh_bala
ID: 24087399
Any updates on this. did that help?
0
 

Author Closing Comment

by:radhnki
ID: 31566950
Your steps were valid, and it was actually a version problem.

Thanks
Rk
0

Featured Post

Flexible connectivity for any environment

The KE6900 series can extend and deploy computers with high definition displays across multiple stations in a variety of applications that suit any environment. Expand computer use to stations across multiple rooms with dynamic access.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Configure Web Service (server application) I. Configure security for Web Services methods First, we need to protect Session bean which implements the service: 1. Open EJB deployment descriptor (ejb-jar.xml) in the EJB project that contains you…
This exercise is about for the following scenario: Dmgr and One node with 2 application server. Each application server contains it owns application. Application server name as follows server1 contains app1 server2 contains app1 Prereq…
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
Suggested Courses
Course of the Month10 days, 12 hours left to enroll

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question