Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Adding Web Sites to IIS7

Posted on 2009-04-06
1
Medium Priority
?
869 Views
Last Modified: 2013-12-04
I'm moving from XP+Sambar Server+ISAPI+PHP to W2K8+IIS7+FastCGI+PHP.

When I choose to "Add Web Site", I enter the details of the "Content Directory" and I have 2 buttons - "Connect As..." and "Test Settings ..."

If I choose Test Settings (not changed the Connect As... details), I get ...

"The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has Read access to the physical path. Then test these settings again."

The "Authentication" (Pass-through authentication (DefaultAppPool:NetworkService) has a green tick, but the "Authorization" has a yellow warning triangle and the above message.

With regard to my setup, there is a folder (D:\Web Sites), which will contain ALL the code related to the development sites for this web server. I've set full rights all local users as well as this server, but I can't get this message to go away.

Any help would be appreciated.

I know next to nothing about Windows security beyond limited XP level (My MSCP was for Windows 95 - anyone remember that?)

Regards,

Richard Quadling.
0
Comment
Question by:Richard Quadling
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 
LVL 14

Accepted Solution

by:
wolfman007 earned 2000 total points
ID: 24088412
The warning errror message is normal since IIS can't verify the 'built-in' account (the default app pool identity is Network Service acc) until it is being used or accessed at run-time.

So the warning message will not go away when you are testing, just setup your website and test it by running the website at run-time and ignore the warning in future.

http://forums.iis.net/t/1154398.aspx

http://forums.iis.net/t/1148262.aspx
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
A phishing scam that claims a recipient’s credit card details have been “suspended” is the latest trend in spoof emails.
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
Suggested Courses

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question